GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: ISDN Rookie Question? posted 03/14/2004
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Oh I just saw that, I bet you are doing InternetworkExpert lab 9 :)))

-----Mensaje original-----
De: alsontra@xxxxxxxxxxx [mailto:alsontra@xxxxxxxxxxx]
Enviado el: domingo, 14 de marzo de 2004 21:15
Para: Richard Dumoulin; ccielab@xxxxxxxxxxxxxx
Asunto: Re: ISDN Rookie Question?


Richard,
The key here is the dialer persistent command.  When you issue this command
on a dialer interface, it continually dials the number specified in the dial
string. When you use the "backup interface dialer0" command it puts the
interface in standby. When the interface is in standby mode dialer
persistent command is inactive. However, as soon as the backup interface
command bring the dialer interface up, the dialer persistent command dial
the dialer string. Internetworkexperts lab 9 cover these commands.

The completed config for R4 :
!
interface BRI0/0
 no ip address
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 5272074
 ppp multilink
!
interface Serial0/0.401 point-to-point
 ip address 148.7.0.4 255.255.255.0
 backup delay 0 300
 backup interface Dialer0
 frame-relay interface-dlci 401
!
interface Dialer0
 ip address 148.7.45.4 255.255.255.0
 encapsulation ppp
 load-interval 30
 dialer pool 1
 dialer remote-name ROUTER5
 dialer idle-timeout 0
 dialer string 5272075
 dialer persistent
 ppp chap hostname ROUTER4
 ppp multilink
 multilink load-threshold 191 either
!
interface Dialer1
 ip address 10.45.45.4 255.255.255.0
 encapsulation ppp
 dialer pool 1
 dialer remote-name R5TEST
 dialer string 5272075
 dialer-group 1
 no cdp enable
 ppp chap hostname R4TEST
 ppp chap password 0 CISCO
!

Alsontra-


----- Original Message ----- 
From: "Richard Dumoulin" <richard.dumoulin@xxxxxxxx>
To: <alsontra@xxxxxxxxxxx>; <ccielab@xxxxxxxxxxxxxx>
Sent: Sunday, March 14, 2004 10:01 AM
Subject: RE: ISDN Rookie Question?


> Ok so help me to understand how the dialer 0 interface will ever initiate
a
> call !?!?  I still can't see how if interesting traffic does not provoke
the
> call.
> When you add the "backup interface" command, the dialer0 will be in
standby
> state and will only become up up(spoofing) once the main interface becomes
> up down or down down. But the call won't still be successfull until
> interesting traffic exist,
>
> Regards
>
> --Richard
>
> -----Mensaje original-----
> De: alsontra@xxxxxxxxxxx [mailto:alsontra@xxxxxxxxxxx]
> Enviado el: domingo, 14 de marzo de 2004 20:53
> Para: Richard Dumoulin; ccielab@xxxxxxxxxxxxxx
> Asunto: Re: ISDN Rookie Question?
>
>
> One of the interfaces is going to be used in a backup interface
> configuration and does not require a dialer-group statement. Eventually,
> I'll add the dialer persistent statement back to the interface, after
> applying the appropriate backup inter command to the protected interface.
>
> Thanks,
> Alsontra-
>
>
>
> ----- Original Message ----- 
> From: "Richard Dumoulin" <richard.dumoulin@xxxxxxxx>
> To: <alsontra@xxxxxxxxxxx>; <ccielab@xxxxxxxxxxxxxx>
> Sent: Sunday, March 14, 2004 9:44 AM
> Subject: RE: ISDN Rookie Question?
>
>
> > It may not be related to your problem but I cannot see a dialer-group on
> > both Dialer 0 interfaces,
> >
> > --Richard
> >
> > -----Mensaje original-----
> > De: alsontra@xxxxxxxxxxx [mailto:alsontra@xxxxxxxxxxx]
> > Enviado el: domingo, 14 de marzo de 2004 19:26
> > Para: ccielab@xxxxxxxxxxxxxx
> > Asunto: ISDN Rookie Question?
> >
> >
> > Group,
> >           What are the rules for using multiple ISDN dialer interfaces
> with
> > chap. I'm basically experimenting to find out what works and what
doesn't.
> > The
> > config below always results in the ISDN layer 2 error message
"user-busy".
> > The first dialer interface is meant to backup another interface and will
> > later
> > be reference by the backup interface and dialer persistent command.
Right
> > now,
> > I simply want dialer0 to be able connect to the remote routers dialer0
> > interface.
> >
> > topology
> >
> > R4----R5
> >
> >
> > R5
> > username ROUTER4 password 0 CISCO
> > username R4TEST password 0 CISCO
> > username R4 password 0 CISCO
> >
> > interface BRI0/0
> >  no ip address
> >  encapsulation ppp
> >  dialer pool-member 1
> >  isdn switch-type basic-ni
> >  isdn spid1 5272075
> >  ppp multilink
> > !
> > interface Dialer0
> >  ip address 148.7.45.5 255.255.255.0
> >  encapsulation ppp
> >  dialer pool 1
> >  dialer remote-name ROUTER4
> >  dialer idle-timeout 0
> >  dialer string 5272074
> >  no cdp enable
> >  ppp authentication chap
> >  ppp chap hostname ROUTER5
> >  ppp multilink
> > !
> > interface Dialer1
> >  ip address 10.45.45.5 255.255.255.0
> >  encapsulation ppp
> >  dialer pool 1
> >  dialer remote-name R4TEST
> >  dialer string 5272074
> >  dialer-group 1
> >  no cdp enable
> >  ppp authentication chap
> >  ppp chap hostname R5TEST
> >  ppp chap password 0 CISCO
> > !
> >
> > R4
> > username ROUTER5 password 0 CISCO
> > username R5TEST password 0 CISCO
> > username R5 password 0 CISCO
> > !
> > interface BRI0/0
> >  no ip address
> >  encapsulation ppp
> >  dialer pool-member 1
> >  isdn switch-type basic-ni
> >  isdn spid1 5272074
> >  ppp multilink
> > !
> > interface Dialer0
> >  ip address 148.7.45.4 255.255.255.0
> >  encapsulation ppp
> >  load-interval 30
> >  dialer pool 1
> >  dialer remote-name ROUTER5
> >  dialer string 5272075
> >  no cdp enable
> >  ppp chap hostname ROUTER4
> >  ppp multilink
> >  multilink load-threshold 191 either
> > !
> > interface Dialer1
> >  ip address 10.45.45.4 255.255.255.0
> >  encapsulation ppp
> >  dialer pool 1
> >  dialer remote-name R5TEST
> >  dialer string 5272075
> >  dialer-group 1
> >  no cdp enable
> >  ppp chap hostname R4TEST
> >  ppp chap password 0 CISCO
> >  ppp multilink
> >
> >
> > debug isdn q931
> > *Mar  1 01:01:45.033: ISDN BR0/0 Q931: TX -> SETUP pd = 8  callref =
0x1B
> >         Bearer Capability i = 0x8890
> >                 Standard = CCITT
> >                 Transer Capability = Unrestricted Digital
> >                 Transfer Mode = Circuit
> >                 Transfer Rate = 64 kbit/s
> >         Channel ID i = 0x83
> >         Keypad Facility i = '5272075'
> > *Mar  1 01:01:45.085: ISDN BR0/0 Q931: RX <- SETUP_ACK pd = 8  callref =
> > 0x9B
> >         Channel ID i = 0x89
> >         Signal i = 0x00 - Dial tone on ...
> > *Mar  1 01:01:49.753: ISDN BR0/0 Q931: RX <- CALL_PROC pd = 8  callref =
> > 0x9B
> >         Channel ID i = 0x89
> > *Mar  1 01:01:49.821: ISDN BR0/0 Q931: RX <- DISCONNECT pd = 8  callref
=
> > 0x9B
> >         Cause i = 0x8291 - User busy
> > *Mar  1 01:01:49.833: ISDN BR0/0 Q931: TX -> RELEASE pd = 8  callref =
> 0x1B
> > *Mar  1 01:01:49.881: ISDN BR0/0 Q931: RX <- RELEASE_COMP pd = 8
callref
> =
> > 0x9B
> > *Mar  1 01:01:51.035: ISDN BR0/0 Q931: TX -> SETUP pd = 8  callref =
0x1C
> >         Bearer Capability i = 0x8890
> >                 Standard = CCITT
> >                 Transer Capability = Unrestricted Digital
> >                 Transfer Mode = Circuit
> >                 Transfer Rate = 64 kbit/s
> >         Channel ID i = 0x83
> >         Keypad Facility i = '5272075'
> > *Mar  1 01:01:51.091: ISDN BR0/0 Q931: RX <- SETUP_ACK pd = 8  callref =
> > 0x9C
> >         Channel ID i = 0x89
> >         Signal i = 0x00 - Dial tone on ..
> > Success rate is 0 percent (0/5)
> > R4#
> > *Mar  1 01:01:55.735: ISDN BR0/0 Q931: RX <- CALL_PROC pd = 8  callref =
> > 0x9C
> >         Channel ID i = 0x89
> > *Mar  1 01:01:55.807: ISDN BR0/0 Q931: RX <- DISCONNECT pd = 8  callref
=
> > 0x9C
> >         Cause i = 0x8291 - User busy
> > *Mar  1 01:01:55.819: ISDN BR0/0 Q931: TX -> RELEASE pd = 8  callref =
> 0x1C
> > *Mar  1 01:01:55.863: ISDN BR0/0 Q931: RX <- RELEASE_COMP pd = 8
callref
> =
> > 0x9C
> >
> > _______________________________________________________________________
> > Please help support GroupStudy by purchasing your study materials from:
> > http://shop.groupstudy.com
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Please help support GroupStudy by purchasing your study materials from:
> > http://shop.groupstudy.com
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Please help support GroupStudy by purchasing your study materials from:
> http://shop.groupstudy.com
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Please help support GroupStudy by purchasing your study materials from:
http://shop.groupstudy.com

Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html