GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: Disappearing route posted 11/27/2003
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


John,
The passive-interface/virtual-link problem has been around for sometime. It
looks to be a bug in the IOS as there shouldn't be a need to passive a
virtual link.

As a side note when building a network that needs a virtual link, make sure
that the virtual link is up and working before you start configuring the
area that the virtual link will be tying to the backbone. No use in building
a broken network and then using the virtual link to fix it. Just build it
from the start in a working fashion. 

1) Configure area 0.
2) Configure the areas that are directly attached to area 0.
3) Configure the virtual link.
4) Finally, configure the non-zero area that the virtual link is tying to
area 0.

Sometimes order of operations can be important when implementing a network
(aka configuring a lab ;-). That's why we're including a good bit of this
kind of information in the book we're writing.

Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
bdennis@xxxxxxxxxxxxxxxxxxxxxx 
Toll Free: 877-224-8987
Direct: 775-745-6404 (Outside the US and Canada)
Internetwork Expert, Inc.
http://www.InternetworkExpert.com


-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of John
Underhill
Sent: Thursday, November 27, 2003 10:35 AM
To: Brian Dennis; 'Bob Sinclair'; 'ccielab Groupstudy'
Subject: Re: Disappearing route

Ok, I figured out what is happening to keep the virtual link down.. I was
using passive-interface default, (as is my habit), on all routers, and only
freeing up interfaces running the ospf process. As soon as I remove the
passive default command the VL comes up. But I do not see the virtual link
as an option when I want to remove the default passisivity, (is that a
word?) from the virtual link.. any ideas, or should I just manually passify
interfaces not running the process on peers destined to be transit areas for
virtual links?

----- Original Message ----- 
From: "Brian Dennis" <bdennis@xxxxxxxxxxxxxxxxxxxxxx>
To: "'John Underhill'" <stepnwlf@xxxxxxxx>; "'Bob Sinclair'" <bsin@xxxxxxx>;
"'ccielab Groupstudy'" <ccielab@xxxxxxxxxxxxxx>
Sent: Wednesday, November 26, 2003 7:23 PM
Subject: RE: Disappearing route


> John,
> First off, look at the routing tables on R2 and R7. They are not complete.
> For example, R7 does not the area 0 route and R2 does not have the area 2
> routes.
>
> Secondly, the output from the "show ip ospf virtual-links" command you
> pasted does not show that you have a working virtual link. The "X.X.X.X is
> up" from the "show ip ospf virtual-links" command indicates that the
router
> sees another router with that particular router-ID but it does not mean
the
> virtual link is working. You need to look for the virtual link to have an
> adjacency state of 'FULL' to determine if it's working. See below:
>
> Non-working virtual link:
> Rack12R4#sho ip os vi
> Virtual Link OSPF_VL1 to router 150.1.1.1 is up
>   Run as demand circuit
>   DoNotAge LSA allowed.
>   Transit area 1234, via interface Serial0/0, Cost of using 64
>   Transmit Delay is 1 sec, State POINT_TO_POINT,
>   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
>     Hello due in 00:00:02
> Rack12R4#
>
> Working virtual link:
> Rack12R4#sho ip os vi
> Virtual Link OSPF_VL1 to router 150.1.1.1 is up
>   Run as demand circuit
>   DoNotAge LSA allowed.
>   Transit area 1234, via interface Serial0/0, Cost of using 64
>   Transmit Delay is 1 sec, State POINT_TO_POINT,
>   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
>     Hello due in 00:00:06
>     Adjacency State FULL (Hello suppressed) <-- HERE
>     Index 1/3, retransmission queue length 0, number of retransmission 0
>     First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
>     Last retransmission scan length is 0, maximum is 0
>     Last retransmission scan time is 0 msec, maximum is 0 msec
> Rack12R4#
>
> Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> bdennis@xxxxxxxxxxxxxxxxxxxxxx
> Toll Free: 877-224-8987
> Direct: 775-745-6404 (Outside the US and Canada)
> Internetwork Expert, Inc.
> http://www.InternetworkExpert.com
>
>
> -----Original Message-----
> From: John Underhill [mailto:stepnwlf@xxxxxxxx]
> Sent: Wednesday, November 26, 2003 3:50 PM
> To: Brian Dennis; 'Bob Sinclair'; 'ccielab Groupstudy'
> Subject: Re: Disappearing route
>
> Thats a good explaination, and it makes sense.. except for two things.. 1)
> you can see and ping all other routes from R7, so.. there has to be an
> adjacency via the virtual link. 2) The link is up and running..
> r5# sh ip ospf v
> Virtual Link OSPF_VL1 to router 202.1.1.1 is up
>   Run as demand circuit
>   DoNotAge LSA allowed.
>   Transit area 1, via interface Serial0, Cost of using 64
>   Transmit Delay is 1 sec, State POINT_TO_POINT,
>   Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
>     No Hellos (Passive interface)
>
> ----- Original Message ----- 
> From: "Brian Dennis" <bdennis@xxxxxxxxxxxxxxxxxxxxxx>
> To: "'Bob Sinclair'" <bsin@xxxxxxx>; "'John Underhill'"
<stepnwlf@xxxxxxxx>;
> "'ccielab Groupstudy'" <ccielab@xxxxxxxxxxxxxx>
> Sent: Wednesday, November 26, 2003 6:27 PM
> Subject: RE: Disappearing route
>
>
> > John,
> > Look at R5's routing table and you should be able to quickly see the
> > problem.
> >
> > R5:
> > O IA    150.50.1.0/24 [110/192] via 12.1.1.2, 00:32:50, Serial0
> > ^^^^
> > If the virtual link was working between R2 and R5, R5 would not see area
0
> > routes as inter-area since R5 would also be an area 0 router. With a
> working
> > virtual link between them, R5 would see area 0 routes as intra-area. The
> > 150.50.1.0/24 area 0 route from R2 should show up as intra-area on R5 if
> the
> > virtual link was working:
> >
> > O       150.50.1.0/24 [110/192] via 12.1.1.2, 00:32:50, Serial0
> > ^
> >
> > As a side note, although that is a good link that Bob sent, it is
missing
> a
> > couple other reasons why a 'route' may be in the database but not in the
> > routing table. This is one of them ;-)
> >
> > Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
> > bdennis@xxxxxxxxxxxxxxxxxxxxxx
> > Toll Free: 877-224-8987
> > Direct: 775-745-6404 (Outside the US and Canada)
> > Internetwork Expert, Inc.
> > http://www.InternetworkExpert.com
> >
> > -----Original Message-----
> > From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
> Bob
> > Sinclair
> > Sent: Wednesday, November 26, 2003 2:45 PM
> > To: John Underhill; ccielab Groupstudy
> > Subject: Re: Disappearing route
> >
> > John,
> >
> > Not sure of your problem, but, if you have not seen it, here is a great
> > article that directly addresses your question.  It is titled:  "Why are
> some
> > OSPF Routes in the Database but not in the Routing Table?
> >
> >
>
http://www.cisco.com/en/US/tech/tk365/tk480/technologies_tech_note09186a0080
> > 09481a.shtml
> >
> > HTH,
> >
> > -Bob Sinclair
> >  CCIE #10427, CISSP, MCSE
> >  bsinclair@xxxxxxxxxxxxxxxxxx
> > ----- Original Message ----- 
> > From: "John Underhill" <stepnwlf@xxxxxxxx>
> > To: "ccielab Groupstudy" <ccielab@xxxxxxxxxxxxxx>
> > Sent: Wednesday, November 26, 2003 5:30 PM
> > Subject: Disappearing route
> >
> >
> > >                P2M --R4
> > >                  /
> > >     area 0  /     VL  area 1        area 2
> > >       R1--R2 ---- P2M -R5 --- P2P --R7
> > >                \
> > >                  \
> > >                P2P--R6
> > >
> > > I have this config that I can't seem to make sense of.. Area 0 is on
> hdlc
> > > between r1 and r2. Area 1 is between a point to multipoint link on R2
to
> > the
> > > ser0 of r4 and r5. A p2p connection between r6 and r2. There is a
> virtual
> > link
> > > using r2 to r5 as the transit area. The serial1 is connected via ppp
to
> > the s0
> > > of r7 in area 2. I am not using any authentication. Now here's the
> strange
> > > part. R7 sees all the routes, can ping all of them but the multipoint
> int
> > on
> > > r2, (coming up as a host route with p2m). R2 does not see routes
> injected
> > via
> > > R7 at all, but, they are showing up in the ospf database, just not in
> the
> > > route table. All other routers have full connectivity. R7 can ping r5,
> and
> > all
> > > other interfaces, including those that have to pass through the hub to
> > reach
> > > the end spokes. R2 in turn can ping everything up to r5. A trace shows
> r7
> > gets
> > > to r5 then the route is blackholed. Debugs show only a normal
adjacency
> > > forming between routers involved. I think it might have something to
do
> > with
> > > the VL. or a route summary. not sure, but one thing I wonder is how a
> > route
> > > can show up in the ospf database and not be installed in the route
> table..
> > > here's my configs..
> > >
> > > R2
> > > O    205.1.1.0/24 [110/65] via 12.1.1.5, 00:31:22, Serial0.1
> > > O    206.1.1.0/24 [110/65] via 13.1.1.2, 00:31:22, Serial0.2
> > >      172.18.0.0/18 is subnetted, 4 subnets
> > > O       172.18.128.0 [110/65] via 12.1.1.5, 00:31:22, Serial0.1
> > > O       172.18.192.0 [110/65] via 12.1.1.5, 00:31:22, Serial0.1
> > > O       172.18.0.0 [110/65] via 12.1.1.5, 00:31:22, Serial0.1
> > > O       172.18.64.0 [110/65] via 12.1.1.5, 00:31:22, Serial0.1
> > > C    202.1.1.0/24 is directly connected, Loopback0
> > >      12.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
> > > O       12.1.1.4/32 [110/64] via 12.1.1.4, 00:31:22, Serial0.1
> > > O       12.1.1.5/32 [110/64] via 12.1.1.5, 00:31:22, Serial0.1
> > > C       12.1.1.0/24 is directly connected, Serial0.1
> > >      13.0.0.0/30 is subnetted, 1 subnets
> > > C       13.1.1.0 is directly connected, Serial0.2
> > >      150.50.0.0/16 is variably subnetted, 4 subnets, 2 masks
> > > C       150.50.1.0/24 is directly connected, Serial1
> > > C       150.50.9.0/24 is directly connected, Dialer0
> > > C       150.50.9.2/32 is directly connected, Dialer0
> > > C       150.50.17.0/24 is directly connected, Ethernet0
> > >
> > > interface Loopback0
> > >  ip address 202.1.1.1 255.255.255.0
> > > interface Serial0.1 multipoint
> > >  ip address 12.1.1.2 255.255.255.0
> > >  ip ospf network point-to-multipoint
> > >  frame-relay map ip 12.1.1.4 101 broadcast
> > >  frame-relay map ip 12.1.1.5 102 broadcast
> > > !
> > > interface Serial0.2 point-to-point
> > >  ip address 13.1.1.1 255.255.255.252
> > >  frame-relay interface-dlci 103
> > > router ospf 100
> > >  router-id 202.1.1.1
> > >  log-adjacency-changes
> > >  area 1 virtual-link 205.1.1.1
> > >  passive-interface default
> > >  no passive-interface Serial0.1
> > >  no passive-interface Serial0.2
> > >  no passive-interface Serial1
> > >  network 12.1.1.0 0.0.0.255 area 1
> > >  network 13.1.1.0 0.0.0.3 area 1
> > >  network 150.50.1.0 0.0.0.255 area 0
> > > r5
> > >
> > > C    205.1.1.0/24 is directly connected, Loopback0
> > > O    207.1.1.0/24 [110/65] via 150.50.18.7, 00:32:48, Serial1
> > > O    206.1.1.0/24 [110/129] via 12.1.1.2, 00:32:48, Serial0
> > >      172.16.0.0/24 is subnetted, 1 subnets
> > > C       172.16.1.0 is directly connected, TokenRing0
> > >      172.18.0.0/16 is variably subnetted, 5 subnets, 2 masks
> > > C       172.18.128.0/18 is directly connected, Loopback3
> > > C       172.18.192.0/18 is directly connected, Loopback4
> > > S       172.18.0.0/16 is directly connected, Null0
> > > C       172.18.0.0/18 is directly connected, Loopback1
> > > C       172.18.64.0/18 is directly connected, Loopback2
> > >      12.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
> > > O       12.1.1.4/32 [110/64] via 12.1.1.4, 00:32:48, Serial0
> > > C       12.1.1.0/24 is directly connected, Serial0
> > > O       12.1.1.2/32 [110/64] via 12.1.1.2, 00:32:50, Serial0
> > >      13.0.0.0/30 is subnetted, 1 subnets
> > > O       13.1.1.0 [110/128] via 12.1.1.2, 00:32:50, Serial0
> > >      150.50.0.0/16 is variably subnetted, 5 subnets, 2 masks
> > > O IA    150.50.1.0/24 [110/192] via 12.1.1.2, 00:32:50, Serial0
> > > C       150.50.9.1/32 is directly connected, Dialer0
> > > C       150.50.9.0/24 is directly connected, Dialer0
> > > C       150.50.18.7/32 is directly connected, Serial1
> > > C       150.50.18.0/24 is directly connected, Serial1
> > >
> > > interface Loopback0
> > >  ip address 205.1.1.1 255.255.255.0
> > >  ip ospf network point-to-point
> > > !
> > > interface Loopback1
> > >  ip address 172.18.0.1 255.255.192.0
> > >  ip ospf network point-to-point
> > > !
> > > interface Loopback2
> > >  ip address 172.18.64.1 255.255.192.0
> > >  ip ospf network point-to-point
> > > !
> > > interface Loopback3
> > >  ip address 172.18.128.1 255.255.192.0
> > >  ip ospf network point-to-point
> > > !
> > > interface Loopback4
> > >  ip address 172.18.224.1 255.255.192.0
> > >  ip ospf network point-to-point
> > >
> > > interface Serial0
> > >  ip address 12.1.1.5 255.255.255.0
> > >  encapsulation frame-relay
> > >  ip ospf network point-to-multipoint
> > >  no fair-queue
> > >  frame-relay map ip 12.1.1.2 301 broadcast
> > >
> > > router ospf 100
> > >  log-adjacency-changes
> > >  area 1 range 172.18.0.0 255.255.0.0
> > >  area 1 virtual-link 202.1.1.1
> > >  passive-interface default
> > >  no passive-interface Loopback0
> > >  no passive-interface Serial0
> > >  no passive-interface Serial1
> > >  network 12.1.1.0 0.0.0.255 area 1
> > >  network 150.50.18.0 0.0.0.255 area 2
> > >  network 172.18.0.0 0.0.63.255 area 1
> > >  network 172.18.64.0 0.0.63.255 area 1
> > >  network 172.18.128.0 0.0.63.255 area 1
> > >  network 172.18.192.0 0.0.63.255 area 1
> > >  network 205.1.1.0 0.0.0.255 area 1
> > > !
> > > ip classless
> > > ip route 172.18.0.0 255.255.0.0 Null0
> > > ip http server
> > >
> > > r7
> > >
> > > O IA 205.1.1.0/24 [110/65] via 150.50.18.5, 00:33:33, Serial0
> > > C    207.1.1.0/24 is directly connected, Loopback0
> > > O IA 206.1.1.0/24 [110/193] via 150.50.18.5, 00:33:33, Serial0
> > > O IA 172.18.0.0/16 [110/65] via 150.50.18.5, 00:33:33, Serial0
> > >      12.0.0.0/32 is subnetted, 3 subnets
> > > O IA    12.1.1.4 [110/128] via 150.50.18.5, 00:33:33, Serial0
> > > O IA    12.1.1.5 [110/64] via 150.50.18.5, 00:33:33, Serial0
> > > O IA    12.1.1.2 [110/128] via 150.50.18.5, 00:33:34, Serial0
> > >      13.0.0.0/30 is subnetted, 1 subnets
> > > O IA    13.1.1.0 [110/192] via 150.50.18.5, 00:33:34, Serial0
> > >      150.50.0.0/16 is variably subnetted, 4 subnets, 2 masks
> > > C       150.50.5.0/24 is directly connected, Serial1
> > > C       150.50.18.5/32 is directly connected, Serial0
> > > C       150.50.17.0/24 is directly connected, Ethernet0
> > > C       150.50.18.0/24 is directly connected, Serial0
> > >
> > > interface Loopback0
> > >  ip address 207.1.1.1 255.255.255.0
> > >  no ip directed-broadcast
> > >  ip ospf network point-to-point
> > >
> > > interface Serial0
> > >  ip address 150.50.18.7 255.255.255.0
> > >  no ip directed-broadcast
> > >  encapsulation ppp
> > >  no fair-queue
> > > !
> > > interface Serial1
> > >  ip address 150.50.5.68 255.255.255.0
> > >  no ip directed-broadcast
> > > !
> > > interface Async1
> > >  no ip address
> > >  no ip directed-broadcast
> > >  shutdown
> > > !
> > > router ospf 100
> > >  passive-interface default
> > >  no passive-interface Loopback0
> > >  no passive-interface Serial0
> > >  network 150.50.18.0 0.0.0.255 area 2
> > >  network 207.1.1.0 0.0.0.255 area 2
> > >
> > >
_______________________________________________________________________
> > > Please help support GroupStudy by purchasing your study materials
from:
> > > http://shop.groupstudy.com
> > >
> > > Subscription information may be found at:
> > > http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Please help support GroupStudy by purchasing your study materials from:
> > http://shop.groupstudy.com
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
> >
> > _______________________________________________________________________
> > Please help support GroupStudy by purchasing your study materials from:
> > http://shop.groupstudy.com
> >
> > Subscription information may be found at:
> > http://www.groupstudy.com/list/CCIELab.html
>
> _______________________________________________________________________
> Please help support GroupStudy by purchasing your study materials from:
> http://shop.groupstudy.com
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Please help support GroupStudy by purchasing your study materials from:
http://shop.groupstudy.com

Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html