GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Redistribute connected and route-maps posted 11/24/2003
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hi all,

As I know while doin redistribution connected, before we have to use
route-maps not to redistribute the interface that already uses the
protocol (except to tag ex.), but after 12.1 I red that redistribute
connected is enough.

I am asking this question because Ipexpert workbook always using
route-maps for connected. Which one should I use on the exam?
Redistribute connected enough but will the proctor agree?

Example

router ospf 1
 
 redistribute connected subnets route-map conet2ospf
  network 172.31.100.0 0.0.0.7 area 0
 network 172.31.200.0 0.0.0.127 area 200

access-list 1 permit 210.6.6.6
access-list 1 permit 172.31.100.0 0.0.0.7
access-list 1 permit 172.31.200.0 0.0.0.127
access-list 1 permit 172.31.69.0 0.0.0.3
!
route-map conet2ospf permit 10
 match ip address 1
 set tag 666
 
This can be made by only "redistribute connected" too. 

Best regards,

Budak Timuralp
Sabanci Telecommunication Services Inc.

-----Original Message-----
From: Bob Sinclair [mailto:bsin@xxxxxxx] 
Sent: Monday, November 24, 2003 1:05 AM
To: Ken.Farrington@xxxxxxxxxxxxxxxxxxx; ccielab@xxxxxxxxxxxxxx
Subject: Re: BGP Soft Reset (BGP RIB)

Ken,

The soft-reconfiguration inbound  command is required if you want to
issue a
"neighbor received-routes" command.    The received routes command will
show
you what the neighbor is sending you BEFORE any inbound policies are
applied.  Very helpful!

HTH,

-Bob Sinclair
 CCIE #10427, CISSP, MCSE
 bsinclair@xxxxxxxxxxxxxxxxxx

----- Original Message ----- 
From: <Ken.Farrington@xxxxxxxxxxxxxxxxxxx>
To: <ccielab@xxxxxxxxxxxxxx>
Sent: Sunday, November 23, 2003 5:05 PM
Subject: BGP Soft Reset (BGP RIB)


> Guys,
>
> Please can I confirm that nowadays you do not have to use the "
neighbor
> 200.200.1.1 soft-reconfiguration inbound" command.
>
> All my routers without this command have the route-refresh capability
on
> (please see output below), and as such and I can do a
>
> "cle ip bgp 200.200.1.1 soft in"    or    "cle ip bgp 200.200.1.1 in"
>
> without configuring soft-reconfiguration under the BGP process.
>
>
> Also,  I assume the router stores two copies of the RIB,  one
unmodified
and
> one modified with inbound policies.  If this is correct, is there a
way of
> showing the unmodified RIB ?
>
>
> TEST2#sh ip bgp nei 200.200.1.1
> BGP neighbor is 200.200.1.1,  remote AS 6500, external link
>   BGP version 4, remote router ID 155.195.16.161
>   BGP state = Established, up for 00:06:48
>   Last read 00:00:48, hold time is 180, keepalive interval is 60
seconds
>   Neighbor capabilities:
>     Route refresh: advertised and received(new)
> <======================Please Note
>     Address family IPv4 Unicast: advertised and received
>   Received 1481 messages, 936 notifications, 0 in queue
>   Sent 1537 messages, 0 notifications, 0 in queue
>   Route refresh request: received 0, sent 6
>   Default minimum time between advertisement runs is 30 seconds
>
>
>
>
>
>
------------------------------------------------------------------------
> For more information about Barclays Capital, please
> visit our web site at http://www.barcap.com.
>
>
> Internet communications are not secure and therefore the Barclays
> Group does not accept legal responsibility for the contents of this
> message.  Although the Barclays Group operates anti-virus programmes,
> it does not accept responsibility for any damage whatsoever that is
> caused by viruses being passed.  Any views or opinions presented are
> solely those of the author and do not necessarily represent those of
the
> Barclays Group.  Replies to this email may be monitored by the
Barclays
> Group for operational or business reasons.
>
>
------------------------------------------------------------------------
>
>
_______________________________________________________________________
> Please help support GroupStudy by purchasing your study materials
from:
> http://shop.groupstudy.com
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html

_______________________________________________________________________
Please help support GroupStudy by purchasing your study materials from:
http://shop.groupstudy.com

Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html