GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: FRTS Be rate posted 11/19/2003
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


There are a couple things I see here.. For one they ask that you use the
'minimum configuration possible', this would indicate generic traffic
shaping rather then a map class. I also see that the sub interface is 0.2
which indicates the presence of another sub interface, this is important,
because the AR (link speed) has to be divided between the logical interfaces
by assigning bandwidth to each subinterface. Also I don't see the map class
statement applied on the subinterface. Best thing to do is break it all
down.
AR - Link speed
CIR - Provisioned sustainable rate
MinCIR - Throttle down to speed when receiving BECNs
BC - Bit rate of transfer per time interval (TC)
BE - excess bit rate if CIR is less then AR
TC - Range of 10 - 125ms set by CIR/BC

Here it asks you to set BC as 1/8 of CIR so 32k/8 = 8k BC=8000
Now if you have two subinterfaces sharing the same 128k link, you could
assign each sub interface 64k, (bandwidth 64), then apply a map class to
each sub interface, (which is how it should be done), and then use the
remainder of the bandwidth for that link to calculate BE, ex.
Interface_bandwidth - CIR = BE, but I leave it up to you to interpret the
requirements. BE is only transfered on the first TC, and are simply token
credits. If you were configuring generic traffic shaping, it would be like
this..
 int s0/0
 traffic-shape rate 32000 8000 64000 1000 (CIR BC BE)
 traffic-shape adaptive 16000 (MinCIR)

I leave you with some of my notes on traffic shaping, hope this helps..

FRAME RELAY



TRAFFIC SHAPING



FRAGMENTATION
FRF.12 - For voip, fragments all traffic above the size specified. Default
is 53 bytes.

FRF.11 - For vofr, creates sub channels on the dlci and separates layer two
voice traffic before the fragmentation engine. Enabled with the vofr cisco
command under the interface, then set fragmentation.

Fragmentation is used to minimize serialization delay, time to put bits on
the wire.

Delay = (frame size * 8) / bandwidth

Fragmentation chart:

 56k = 70 bytes

 64k = 80 bytes

128k = 160 bytes

256k = 320 bytes

512k = 640 bytes

768k = 1000 bytes



RTP
Real Time Protocol. Creates strict priority queue for a range of UDP
destination ports, (16384 - 32767). Other queues are then serviced via WFQ.
Will allow bursting when there is bandwidth available on the default queue.
Compression is set under the interface with CRTP, compresses header from 40
bytes to 2 to 4 bytes.



LLQ
Low Latency Queueing. Strict priority queue with Class based WFQ (CBWFQ).
Voice is in priority queue, then class maps define other priority traffic
under the policy. Default queue can still be assigned to WFQ, ex. Class
class-default - fair-queue.



AR Access Rate - Interface speed.

CIR Commited Information Rate - Provider guaranteed data transfer rate.

BC Commited Burst rate - Bits transferred per TC interval.

BE Burst Excess rate - Number of uncommitted bits to transfer on 1st TC
interval.

TC Commited time interval - (BC + BE) per interval (10 - 125 ms).

BECN Backwards Explict Congestion Notification. Notifier of congestion
frame.



Codecs - Low bit-rate codecs are G.729 (8K) and G727.1

VAD - Voice Activity Detection, suppresses frames for silence, on by
default.



CLASSIFYING VOICE TRAFFIC
Access-list 101 permit udp any any range 16384 32767   or

Access-list 101 permit udp any any precedence critical (5)   or

Access-list 101 permit udp any any dscp ef



Then call the access list with a class map statement:

Class-map VOICEDATA

Match access-group 101



Then create a policy map:

Policy-map VOICECONTROL

Class VOICEDATA

Priority 64 (assign this traffic to priority queue and give 64K of
bandwidth)

Note * priority and bandwidth set in policy must be less then MinCIR.



Then create the frame policy map and add the policy map:

Map-class frame MYMAP

Service-policy output VOICECONTROL



For RTP use:

Frame map-class MYMAP

Frame ip rtp priority 16384 16383 45

Bandwidth 32



RTP example:

Map-class frame MYMAP

Frame bc 640

Frame cir 64000

Frame be 0

No frame adaptive

Frame fair-queue

Frame fragment 80

Frame ip rtp priority 16384 16383 45



SHOW COMMANDS
Show policy-map int ser0/0

Show policy-map name

Show queue int s0/0

Show class-map name

Show call active

Show frame ip header-compression

Show frame fragment



GENERIC TRAFFIC SHAPING
Traffic-shape rate rate(burst-size excess-burst-size) ACL

Traffic-shape adaptive rate (mincir)



TRAFFIC SHAPING


DATA SETTINGS
CIR - provisioned rate

MinCIR - defaults at half of CIR.

BC  - CIR/8 =125ms

BE  - rate above BC if less then CIR.



VOICE SETTINGS
CIR - provisioned rate.

MinCIR - same as CIR.

BC - CIR /100 to make TC 10ms.

BE - set to 0.

BECN - no adaptive traffic shaping.



FORMULAS


SERIALIZATION
For converting serialization delay to 10ms:

Serial_delay = frame_size Bps /link_speed bps

Or bandwidth /8 * .01 =10ms serialization

Ex. 64000 /8 = 8000 | 8000 * .01 = 80 or 80k



TC RATE
For voice, TC should be 10ms, set TC time with BC as 1/100th of CIR.

So CIR / 100 = BC

Ex. CIR = 64k | 64000 /100 = 640 | BC = 640



LLC EXAMPLE

access-list 101 permit udp any any range 16384 32767



class-map match-all VOICEDATA

  match access-group 101



policy-map VOICECONTROL

  class VOICEDATA

    priority 32

  class class-default

   fair-queue



map-class frame-relay MYVOICE

 frame-relay cir 64000

 frame-relay bc 640

 frame-relay be 0

 frame-relay mincir 64000

 no frame-relay adaptive-shaping

 service-policy output VOICECONTROL

 frame-relay fragment 80



interface Serial0

 bandwidth 128

 no ip address

 encapsulation frame-relay

 shutdown

 frame-relay traffic-shaping

 frame-relay lmi-type cisco



interface Serial0.1 multipoint

 bandwidth 64

 ip address 10.1.1.2 255.255.255.0

 frame-relay class MYVOICE

 frame-relay map ip 10.1.1.4 101 broadcast

 frame-relay map ip 10.1.1.5 102 broadcast



interface Serial0.2 point-to-point

 bandwidth 64

 ip address 11.1.1.2 255.255.255.0

 frame-relay class MYVOICE

 frame-relay interface-dlci 103


----- Original Message ----- 
From: "Tasuka Amano Hsu" <tasuka@xxxxxxx>
To: "ccielab Groupstudy" <ccielab@xxxxxxxxxxxxxx>
Sent: Wednesday, November 19, 2003 4:14 AM
Subject: FRTS Be rate


> Hi,
> I have problem when doing IPExpert WB 4.0
>
> Using the minimum configuration passible in applying the map-class,
> make sure it is applied to all PVCs. Use the following guidelines in
> defining Bc, Be, CIR, and MinCIR within your map-class:
>
> a.The Frame Relay service provider is guaranteeing 32Kbps of traffic.
> b. The Frame Relay access being provided by the service provider has a
> link capacity of 128Kbps.
> c. Set the excess burst value by comparing CIR and total link capacity.
> d. Set the Bc to 1/8 of the locally configured CIR.
>
> Configure Frame-Relay traffic shaping:
>
> a. The PVC should adapt to received BECNs and if enough BECNs are
> received, the eventual traffic rate should be 16Kbps.
> b. Set Bc to 8Kbps and Be to 64Kbps.
> c. Considering the value of Bc, set the appropriate value of the CIR.
>
> Ensure that all routers can ping their own Frame-Relay interfaces.
>
> My Configuration here:
>
> R2
> !
> interface Serial0
>   no ip address
>   encapsulation frame-relay IETF
>   no fair-queue
>   frame-relay class R2_ts
>   frame-relay traffic-shaping
>   frame-relay lmi-type ansi
> !
> interface Serial0.2 multipoint
>   ip address 150.50.100.2 255.255.255.224
>   frame-relay map ip 150.50.100.2 105
>   frame-relay map ip 150.50.100.5 105 broadcast
>   frame-relay map ip 150.50.100.6 106 broadcast
>   no frame-relay inverse-arp
> !
> map-class frame-relay R2_ts
>   no frame-relay adaptive-shaping
>   frame-relay cir 128000
>   frame-relay bc 16000
>   frame-relay be 48000
>   frame-relay mincir 32000
> !
>
> sh frame traffic-shaping
>
> Interface   Se0.2
>         Access Target    Byte   Sustain   Excess    Interval  Increment
> Adapt
> VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)
> Active
> 105           128000    8000   16000     48000     125       2000      -
> 106           128000    8000   16000     48000     125       2000      -
>
> R4
> !
> interface Serial0
>   ip address 150.50.24.4 255.255.255.0
>   encapsulation frame-relay IETF
>   no fair-queue
>   frame-relay class R4_ts
>   frame-relay traffic-shaping
>   frame-relay map ip 150.50.24.2 401 broadcast
>   frame-relay map ip 150.50.24.4 401
>   no frame-relay inverse-arp
>   frame-relay lmi-type ansi
> !
> map-class frame-relay R4_ts
>   frame-relay adaptive-shaping becn
>   frame-relay cir 64000
>   frame-relay bc 8000
>   frame-relay be 64000
>   frame-relay mincir 16000
> !
>
> sh traffic-shape
>
> Interface   Se0
>         Access Target    Byte   Sustain   Excess    Interval  Increment
> Adapt
> VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)
> Active
> 405           64000     9000   8000      64000     125       1000
> BECN
> 401           64000     9000   8000      64000     125       1000
> BECN
>
>
> My problem is the Be is correct ?
>
> Sincerely,
> Tasuka
>
> _______________________________________________________________________
> Please help support GroupStudy by purchasing your study materials from:
> http://shop.groupstudy.com
>
> Subscription information may be found at:
> http://www.groupstudy.com/list/CCIELab.html