GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: ISIS - Not getting routes posted 11/01/2003
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


R4 is missing the broadcast keyword for CLNS.

<config>
interface Serial0
 ip address 136.10.24.4 255.255.255.248
 ip router isis
 encapsulation frame-relay
 frame-relay map clns 401 <-- missing broadcast keyword
</config>

Brian Dennis, CCIE #2210 (R&S/ISP-Dial/Security)
bdennis@xxxxxxxxxxxxxxxxxxxxxx 
Toll Free: 877-224-8987
Direct: 775-745-6404 (Outside the US and Canada)
Internetwork Expert, Inc.
http://www.InternetworkExpert.com


-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of Charles T. Alexander
Sent: Saturday, November 01, 2003 11:27 AM
To: ccielab@xxxxxxxxxxxxxx
Subject: ISIS - Not getting routes

Having problem with ISIS.  Can't get isis routes from r4 (ethernet and
loopback) to show up in r2.

r2 ---frame relay--- r4

Configs below.

r2#r
Building configuration...

Current configuration : 2805 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
logging buffered 10000 debugging
enable password radnor
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 136.10.2.2 255.255.255.0
!
interface Ethernet0
 ip address 136.10.12.2 255.255.255.0
!
interface Serial0
 no ip address
 encapsulation frame-relay
 frame-relay lmi-type ansi
!
interface Serial0.4 multipoint
 ip address 136.10.24.2 255.255.255.248
 ip router isis
 frame-relay map clns 104 broadcast
 frame-relay map ip 136.10.24.2 104
 frame-relay map ip 136.10.24.4 104 broadcast
 no frame-relay inverse-arp
!
interface Serial0.56 multipoint
 ip address 136.10.100.2 255.255.255.224
 ip ospf priority 10
 frame-relay map ip 136.10.100.2 105
 frame-relay map ip 136.10.100.5 105 broadcast
 frame-relay map ip 136.10.100.6 106 broadcast
 no frame-relay inverse-arp
!
interface Serial1
 no ip address
 shutdown
!
interface BRI0
 ip address 136.10.25.1 255.255.255.252
 shutdown
!
router ospf 1
 router-id 136.10.2.2
 log-adjacency-changes
 redistribute connected subnets route-map c2o
 redistribute rip subnets route-map r2o
 network 136.10.2.0 0.0.0.255 area 0
 network 136.10.100.0 0.0.0.31 area 0
 neighbor 136.10.100.6
 neighbor 136.10.100.5
!
router isis
 net 49.0024.2222.2222.2222.00
 is-type level-2-only
!
router rip
 version 2
 redistribute connected metric 1 route-map c2r
 redistribute ospf 1 metric 2 route-map o2r
 passive-interface default
 no passive-interface Ethernet0
 network 136.10.0.0
 no auto-summary
!
ip classless
ip http server
ip pim bidir-enable
!
!
ip access-list standard e-rts
 permit 136.10.69.0 0.0.0.15
 permit 136.10.9.0 0.0.0.255
 permit 192.168.90.0 0.0.0.255
ip access-list standard o-rts
 permit 136.10.56.0 0.0.0.15
 permit 136.10.6.0 0.0.0.255
 permit 136.10.5.0 0.0.0.255
ip access-list standard r-rts-n
 permit 136.10.1.0 0.0.0.255
 permit 192.168.10.0 0.0.0.255
ip access-list standard r-rts-s
 permit 136.10.70.0 0.0.0.255
 permit 136.10.7.0 0.0.0.255
 permit 136.10.8.0 0.0.0.255
 permit 136.10.78.0 0.0.0.128
 permit 192.168.80.0 0.0.0.255
ip access-list standard sw-rts
 permit 136.10.10.0 0.0.0.255
 permit 136.10.20.0 0.0.0.255
route-map c2r permit 10
 match interface Loopback0 BRI0
!
route-map r2o permit 10
 match ip address r-rts sw-rts
!
route-map o2r permit 10
 match ip address o-rts e-rts r-rts-s sw-rts
!
route-map c2o permit 10
 match interface Ethernet0
!
!
alias exec r show run
alias exec c config t
alias exec i show ip route
alias exec u undebug all
alias exec b show ip bgp
alias exec w write
alias exec bs show ip bgp summary
alias exec s show ip int brief
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line aux 0
line vty 0 4
 password bp
 login
!
end

r2#
bb1>4
[Resuming connection 4 to r4 ... ]

r4#r
Building configuration...

Current configuration : 1234 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
logging buffered 10000 debugging
enable password radnor
!
ip subnet-zero
no ip domain-lookup
!
!
!
!
interface Loopback0
 ip address 136.10.4.4 255.255.255.0
!
interface Ethernet0
 ip address 136.10.40.4 255.255.255.0
 ip router isis
!
interface Serial0
 ip address 136.10.24.4 255.255.255.248
 ip router isis
 encapsulation frame-relay
 frame-relay map clns 401
 frame-relay map ip 136.10.24.2 401 broadcast
 frame-relay map ip 136.10.24.4 401
 no frame-relay inverse-arp
!
interface Serial1
 no ip address
 shutdown
!
router isis
 redistribute connected level-1-2
 redistribute isis ip level-1 into level-2 distribute-list 100
 net 49.0042.4444.4444.4444.00
!
ip classless
ip http server
ip pim bidir-enable
!
access-list 100 permit ip any any
!
alias exec r show run
alias exec c config t
alias exec i show ip route
alias exec u undebug all
alias exec b show ip bgp
alias exec w write
alias exec bs show ip bgp summary
alias exec s show ip int brief
!
line con 0
 exec-timeout 0 0
 logging synchronous
 escape-character 27
line 1 8
 flush-at-activation
line aux 0
line vty 0 4
 password bp
 login
!
end

r4#

_______________________________________________________________________
Please help support GroupStudy by purchasing your study materials from:
http://shop.groupstudy.com

Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html