GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: native vlan and port config for IP phone. posted 09/03/2003
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Why do you say that a packet from an IP Phone is "ALWAYS" tagged? What type
of phone eq is this?

I know that I have hard coded ports for IP Phones to our voice vlan and it
worked fine. 

Its critical that that you realize that switchport voice vlan XXX is only
useful with CISCO IP PHONES.

The Switch will send this info over CDP to the phone, so that the phone
knows how to tag its voice packets. That is all that command does.



Thanks

Larry 

-----Original Message-----
From: Chen Kwong Wai William [mailto:kwchen@xxxxxxxxxxxxxx] 
Sent: Tuesday, September 02, 2003 6:51 PM
To: Roberts, Larry; navaid@xxxxxxxxxx; ccielab@xxxxxxxxxxxxxx
Subject: Re: native vlan and port config for IP phone.


    I think the port is not permanent access port, it is actually a dynamic
port. There is not command "switchport mode access". I also wonder if we put
a port in permanent access mode will prohibit the IP phone from working. It
is because, the packet from an IP phone is always tagged (either you use
"switchport voice vlan vlan_id" or "switchport voice vlan dot1p"), and a
permanent access port will always drop tagged packets.

    I've not practice IP phone and would like to be confirmed.

-- William

----- Original Message ----- 
From: "Roberts, Larry" <Larry.Roberts@xxxxxxxxxxxx>
To: <navaid@xxxxxxxxxx>; <ccielab@xxxxxxxxxxxxxx>
Sent: Wednesday, September 03, 2003 2:13 AM
Subject: RE: native vlan and port config for IP phone.


> The switchport trunk voice vlan 101 is used to pass the voice vlan 
> onto a Cisco phone. If your using a non-cisco IP phone you will need 
> to manually tell the phone what the voice vlan is, and this is 
> assuming that the phone is trunking.
>
> The switchport trunk native vlan 102 is not needed below, because your
port
> is hard-coded for access mode, not trunk mode. Native VLAN really only 
> applies to trunk ports
>
> A typical voice port, with a cisco IP phone migth look like this ( and 
> Im doing this for memory so pardon any typos )
>
> Interface f0/16
> Description IP Phone
> Switchport mode trunk
> Switchport trunk encapsulation dot1q
> Switchport trunk native vlan 102
> Switchport voice vlan 101
> Spanning-tree portfast
>
> Here is a breakdown of what each command doesn:
>
> Interface f0/16 = go into the F0/16 interface and apply the 
> configuration there Description IP Phone = adds a description to the 
> port so you can look
though
> the config and figure out what it is used by
> Switchport mode trunk = force the port to be a trunk port Switchport 
> trunk encapsulation dot1q = use 802.1q packet tagging ( as opposed to 
> ISL ) Switchport trunk native vlan 102 = Any untagged packets are 
> considered to
be
> in this VLAN. On cisco Phones, the ethernet port would be in this VLAN 
> Switchport voice vlan 101 = used to tell a cisco IP Phone how to tag 
> voice packets, ie tag voice packets in vlan 101 ( I believe that CDP 
> passes this info along to the phone ) Spanning-tree portfast = skip 
> the normal stp startup procedure, and immediately start forwarding 
> packets.
>
> If your using a phone that can't do trunking, you can just hard code 
> the port to access mode and set the access vlan to what you need
>
> Interface f0/16
> Description Hard-coded IP Phone
> Switchport mode access
> Switchport access vlan 101
>
> This just tells the switch that don't vlan tag packets and just put 
> all traffic you receive into vlan 101.
>
> Does this help ?
>
> Thanks
>
> Larry
>
> -----Original Message-----
> From: navaid@xxxxxxxxxx [mailto:navaid@xxxxxxxxxx]
> Sent: Tuesday, September 02, 2003 12:38 PM
> To: ccielab@xxxxxxxxxxxxxx
> Subject: Re: native vlan and port config for IP phone.
>
>
> What if we have following config ?
>
> interface FastEthernet0/16
>  switchport access vlan 40
>  switchport trunk encapsulation dot1q
>  switchport trunk native vlan 102
>  switchport voice vlan 101
>  no ip address
>  spanning-tree portfast
> end
>
> >
> > From: <navaid@xxxxxxxxxx>
> > Date: 2003/09/02 Tue PM 01:31:05 EDT
> > To: <ccielab@xxxxxxxxxxxxxx>
> > Subject: native vlan and port config for IP phone.
> >
> > What is the correct method of configuring native vlan ? Fa0/15 is 
> > using "switchport access vlan" command. fa0/16 is using "switchport 
> > trunk native vlan" command.
> >
> > interface FastEthernet0/15
> >  switchport access vlan 102
> >  switchport trunk encapsulation dot1q
> >  switchport voice vlan 101
> >  no ip address
> >  spanning-tree portfast
> > interface FastEthernet0/16
> >  switchport trunk encapsulation dot1q
> >  switchport trunk native vlan 102
> >  switchport voice vlan 101
> >  no ip address
> >  spanning-tree portfast
> >
> > Thanks,
> >
> > Navaid
> >
> >
>
> 1
>
>
> ______________________________________________________________________
> _
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at: 
> http://www.groupstudy.com/list/CCIELab.html
>
>
> ______________________________________________________________________
> _
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at: 
> http://www.groupstudy.com/list/CCIELab.html