GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: cat3550 cannot establish ospf nei with router/s posted 08/17/2003
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


I would agree...  Before an RMA, do a 'write erase' and 'del vlan.dat'
then reload the sucker and see what happens.

Karma?  :)

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
Mustafa M Bayramov
Sent: Sunday, August 17, 2003 1:13 PM
To: 'seonghui'; 'Scott Morris'; ccielab@xxxxxxxxxxxxxx
Subject: RE: cat3550 cannot establish ospf nei with router/s


Make delete vlan.dat and you will see switch will set default MTU 1518

To fix this you can change system MTU ( need restart switch ) Adjust MTU
per VLAN. Adjust MTU for SWI interface. Set ip ospf mtu-ignore for ospf
on both routers.

Regards


Mustafa M Bayramov

CISSP
CCNP,CCDP,Cisco Security Specialist
Network engineer and security analyst

Azercell Telecom J.V. 
 
"I know nothing except the fact of my ignorance." Socrates

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
seonghui
Sent: Saturday, August 16, 2003 11:20 PM
To: 'Scott Morris'; ccielab@xxxxxxxxxxxxxx
Subject: RE: cat3550 cannot establish ospf nei with router/s

Hi Scott,

OK, this sounds reasonable. But I have tried the same setting and
config. on another identical cat3550 switch, running the same IOS code
(flash:c3550-i5q3l2-mz.121-13.EA1a/c3550-i5q3l2-mz.121-13.EA1a.bin) and
it works! OSPF nei adj formed almost instantly with the router...this
puzzles me. can i just send the switch for RMA?

anyway, thanks group for your help. I better leave this problem alone,
else i'll be wasting too much time and never move on.

regards-SH

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
Scott Morris
Sent: Sunday, August 17, 2003 3:04 AM
To: 'John Matijevic'; 'MMoniz'; 'seonghui'; ccielab@xxxxxxxxxxxxxx
Subject: RE: cat3550 cannot establish ospf nei with router/s


It's not an MTU issue at all...  Check out the IOS release you have. Bug
CSCdv61151 mentions this.

I just set it up on a 3550 and three different routers (2610 and two
different 3620's) and ospf came up immediately.  No MTU playing, nothing
funky, nothing bizarre, just simple network command and *POOF* there
were neighbors and routes and reachability!

The switch is wholly aware of different things because it's a switch.
:)  Looking at show interface, the MTU should be 1500 on everything.
1518 is allowed, but that's not a L3 MTU, that's the L3 MTU + L2 header.
Even doing show interface on a trunk port, you'll see the same MTU even
though it now expects 18 additional bytes plus some extra for the
trunking (depending on your protocol).  SO....  There shouldn't be a
need in this instance to change MTU at all.

If you did, that's what's messed up.  If you didn't, look at the bug id
referenced above.  Try a different IOS.

HTH,

Scott

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
John Matijevic
Sent: Saturday, August 16, 2003 2:25 PM
To: MMoniz; seonghui; ccielab@xxxxxxxxxxxxxx
Subject: Re: cat3550 cannot establish ospf nei with router/s


MMoniz,
MTU on router int fa0/0 is of course 1500 while MTU on vlan 10 is 1518.
This looks like a mtu mismatch, I was having him change the mtu on vlan
10 to 1500 to match. We are still waiting for the results. Sincerely,
Matijevic
----- Original Message -----
From: "MMoniz" <ccie2002@xxxxxxxxxxxxxxx>
To: "seonghui" <seonghui@xxxxxxxx>; "'John Matijevic'"
<matijevi@xxxxxxxxxxxxx>; <ccielab@xxxxxxxxxxxxxx>
Sent: Saturday, August 16, 2003 2:19 PM
Subject: RE: cat3550 cannot establish ospf nei with router/s


> It should be 1500. It looked like an MTU mismatch except the debugs 
> would normally show it.
>
>
> 22:38:05: OSPF: Send DBD to 133.5.5.5 on Serial0 seq 0xF5F opt 0x42 
> flag
0x7
> len 32
> 22:38:05: OSPF: Retransmitting DBD to 133.5.5.5 on Serial0 [11]
> 22:38:05: OSPF: Rcv DBD from 133.5.5.5 on Serial0 seq 0x2122 opt 0x42 
> flag 0x7 len 32  mtu 1500 state EXSTART
> 22:38:05: OSPF: Nbr 133.5.5.5 has larger interface MTU
> R3#
>
>
> This is default on my 3550
>
> VDL-CAT#sho in vlan 2
> Vlan2 is up, line protocol is up
>   Hardware is EtherSVI, address is 000b.fdf0.ba00 (bia 000b.fdf0.ba00)
>   Internet address is 133.5.23.8/24
>   MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec,
>
> What code are you running on your Cat?
>
>
>
>
> -----Original Message-----
> From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of

> seonghui
> Sent: Saturday, August 16, 2003 2:05 PM
> To: 'John Matijevic'; ccielab@xxxxxxxxxxxxxx
> Subject: RE: cat3550 cannot establish ospf nei with router/s
>
>
> Hi Matijevic,
>
> MTU on router int fa0/0 is of course 1500 while MTU on vlan 10 is 
> 1518. I tried changing them but router doesn't allow me to do so.
>
> any clue?
>
> regards - SH
>
> -----Original Message-----
> From: John Matijevic [mailto:matijevi@xxxxxxxxxxxxx]
> Sent: Sunday, August 17, 2003 1:55 AM
> To: seonghui; ccielab@xxxxxxxxxxxxxx
> Subject: Re: cat3550 cannot establish ospf nei with router/s
>
>
> Hello Seong,
> Please check the mtu on the interface on the vlan interface as well as

> the interface on the router to make sure that the mtu is the same. ex.

> sh ip
int
> e0, or sh ip int vlan 20.
> Please post results.
> Sincerely,
> Matijevic
> ----- Original Message -----
> From: "seonghui" <seonghui@xxxxxxxx>
> To: "'John Matijevic'" <matijevi@xxxxxxxxxxxxx>; 
> <ccielab@xxxxxxxxxxxxxx>
> Sent: Saturday, August 16, 2003 1:42 PM
> Subject: RE: cat3550 cannot establish ospf nei with router/s
>
>
> > Hi Matijevic,
> >
> > I tried that earlier, but the result is the same.
> >
> > regards - SH
> >
> > -----Original Message-----
> > From: John Matijevic [mailto:matijevi@xxxxxxxxxxxxx]
> > Sent: Sunday, August 17, 2003 1:36 AM
> > To: seonghui; ccielab@xxxxxxxxxxxxxx
> > Subject: Re: cat3550 cannot establish ospf nei with router/s
> >
> >
> > Hello Seong,
> > Could you try putting ip ospf priority 0 under vlan interface on 
> > switch. Please post results. Sincerely, Matijevic
> > ----- Original Message -----
> > From: "seonghui" <seonghui@xxxxxxxx>
> > To: <ccielab@xxxxxxxxxxxxxx>
> > Sent: Saturday, August 16, 2003 1:00 PM
> > Subject: cat3550 cannot establish ospf nei with router/s
> >
> >
> > > Hi group,
> > >
> > > I have been 'haunted' by this problem for the past two days. Here 
> > > the problem goes...
> > >
> > > I have a router conneted to a Cat3550. router fa0/0 (ip address
> > > 10.10.10.1/24) is connected to port fas0/1 (vlan 10) on cat3550. I
would
> > > like cat3550 to establish ospf neighbour with the router and 
> > > hence, I created an Interface vlan 10 with ip address 
> > > 10.10.10.2/24. However,
the
> > > router and the cat3550 just cannot form adjacency. Below is the 
> > > debug
> > > message:
> > >
> > > 07:28:30: OSPF: rcv. v:2 t:1 l:48 rid:10.10.10.1 aid:0.0.0.10 
> > > chk:7E15
> > aut:0
> > > auk: from Vlan10
> > > 07:28:30: OSPF: Rcv hello from 10.10.10.1 area 11 from Vlan10
10.10.10.2
> > > 07:28:30: OSPF: End of hello processing
> > > 07:28:31: OSPF: rcv. v:2 t:2 l:32 rid:10.10.10.1 aid:0.0.0.10 
> > > chk:21B2
> > aut:0
> > > auk: from Vlan10
> > > 07:28:31: OSPF: Rcv DBD from 10.10.10.1 on Vlan10 seq 0x2D3 opt 
> > > 0x42
> flag
> > > 0x7 len 32  mtu 1500 state EXSTART
> > > 07:28:31: OSPF: First DBD and we are not SLAVE
> > > 07:28:31: OSPF: Retransmitting DBD to 10.10.10.1 on Vlan10
> > > 07:28:31: OSPF: 10.10.10.1 address 10.10.10.2 on Vlan10 is dead, 
> > > state
> > DOWN
> > > 07:28:31: %OSPF-5-ADJCHG: Process 1, Nbr 10.10.10.1 on Vlan10 from
> EXSTART
> > > to DOWN, Neighb or Down: Too many DBD retransmitions
> > > 07:28:31: OSPF: Neighbor change Event on interface Vlan10
> > > 07:28:36: OSPF: Rcv DBD from 10.10.10.1 on Vlan10 seq 0x2D3 opt 
> > > 0x42
> flag
> > > 0x7 len 32  mtu
> > > 1500 state DOWN
> > > 07:28:36: OSPF: Nbr state is less than INIT
> > >
> > > I tried running other routing protocol between the switch and the
> router,
> > it
> > > worked fine. Can some body please tell me what's the problem with
ospf?
> > >
> > > Thanks,
> > > SH
> > >
> > >
> > >
_______________________________________________________________________
> > > You are subscribed to the GroupStudy.com CCIE R&S Discussion 
> > > Group.
> > >
> > > Subscription information may be found at: 
> > > http://www.groupstudy.com/list/CCIELab.html
> >
> >
> > ____________________________________________________________________
> > ___
> > You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
> >
> > Subscription information may be found at: 
> > http://www.groupstudy.com/list/CCIELab.html
>
>
> ______________________________________________________________________
> _
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at: 
> http://www.groupstudy.com/list/CCIELab.html
>
>
> ______________________________________________________________________
> _
> You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.
>
> Subscription information may be found at: 
> http://www.groupstudy.com/list/CCIELab.html


_______________________________________________________________________
You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.

Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html


_______________________________________________________________________
You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.

Subscription information may be found at:
http://www.groupstudy.com/list/CCIELab.html


_______________________________________________________________________
You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.

Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html


_______________________________________________________________________
You are subscribed to the GroupStudy.com CCIE R&S Discussion Group.

Subscription information may be found at: 
http://www.groupstudy.com/list/CCIELab.html