GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: RE: RE: Re: Re: BGP & PBR (Policy Based Routing)'s query..!!! posted 08/05/2003
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Brian !! Thanks for your kind reply.

But, my case is a little different to your reply..

1> R1 has no route to the R3's Lo(3.3.3.3) 
   => so, i use a local policy routing to the R3's Lo on R1
   => there is no longer match than zero to the destination(3.3.3.3)
2> R3 has only  Default Routing to the R1.
   => 0.0.0.0/0 via R1'e0(2.2.2.1)
   => there is no longer match than zero to the destination(1.1.1.1)
     (** i don't config a local policy-routing on R3 **)      
 
By 1> & 2>, 
IS the EBGP-session not established between R1 & R3 , inspite of the
Default-Routing in R3 ? => it's right?

So These methods are one of the soutions ??

 1> config a static-routing to the R3's Lo(3.3.3.3)
    => There is a longer match than zero to the destination on R1
 2> I put the R3's Lo(3.3.3.3) in pre-existing IGP-Domain (OSPF,RIP..)
    => There is a longer match than zero to the destination on R1

               
---------------------------------------------------------  
From: "Brian McGahan" <bmcgahan@xxxxxxxxxxxxxxxxxxxxxx> 
To: <wwwjjang@xxxxxxxx>, <ccielab@xxxxxxxxxxxxxx> 
Subject: RE: RE: Re: Re: BGP & PBR (Policy Based Routing)'s query..!!! 
Date: Mon, 4 Aug 2003 22:07:04 -0500 
Reply-to: "Brian McGahan" <bmcgahan@xxxxxxxxxxxxxxxxxxxxxx> 

In order to establish an EBGP peering session, at least one side
of the link must have a longer match than zero to the destination. A
match longer than zero is defined as is a route with a mask of /1 or
greater. Since policy routing is a completely separate process from the
IP routing table, policy routing on both sides of an EBGP peering
session will not be sufficient to establish a connection.

HTH,

Brian McGahan, CCIE #8593
bmcgahan@xxxxxxxxxxxxxxxxxxxxxx 
Cell: 708-362-1418 

Internetwork Expert, Inc. 
http://www.InternetworkExpert.com


-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
wwwjjang@xxxxxxxx
Sent: Monday, August 04, 2003 9:39 PM
To: ccielab@xxxxxxxxxxxxxx
Subject: Re: RE: Re: Re: BGP & PBR (Policy Based Routing)'s query..!!!

I config a policy route-map you suggests on R1
but the ebgp-session is not established yet..!!

How can i fix the problem !!

-----------
R1>
-----------
ip local policy route-map POL
access-list 111 ip any host 3.3.3.3
route-map POL permit 10
match ip address 111
set interface 2.2.2.2
----------------------------------------------------------------
RE: Re: Re: BGP & PBR (Policy Based Routing)'s query..!!! MMoniz
Reply to sender to list 

From: "MMoniz" <ccie2002@xxxxxxxxxxxxxxx> 
To: <wwwjjang@xxxxxxxx>, <ccielab@xxxxxxxxxxxxxx> 
Subject: RE: Re: Re: BGP & PBR (Policy Based Routing)'s query..!!! 
Date: Mon, 4 Aug 2003 20:47:02 -0400 
Reply-to: "MMoniz" <ccie2002@xxxxxxxxxxxxxxx> 

Try not limit your policy from host to host. Try any to host!!

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
wwwjjang@xxxxxxxx
Sent: Monday, August 04, 2003 8:37 PM
To: ccielab@xxxxxxxxxxxxxx
Subject: Re: Re: Re: BGP & PBR (Policy Based Routing)'s query..!!!


But
If i config a static-routing on R1,(ip route 3.3.3.3 255.255.255.255
2.2.2.2),
The EBGP-Session is established !!! (It's trivial !!)

=> Why don't the local-policy route-map configuration oprate well ??
Who know the reason ????


-------------------------------
Thanks for your reply..

But in the Assumtion..

R3 has a D/R to the R1's E0(2.2.2.1)
so, R3 has a route to the R1's L0(1.1.1.1) with a source ip 3.3.3.3
=> If R3 sends a ping to the R1's Lo(1.1.1.1) with a source R3's
Lo(3.3.3.3),
it's OK!!!

Further more, even if i config the local-policy route-map in R3 as you
suggested, the ebgp-session is not established..yet..

How can i fix this problom !!!!

R3>
----
router bgp 1
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 2
neighbor 1.1.1.1 ebgp-multihop 255
neighbor 1.1.1.1 update-source Loopback0
!

ip local policy route-map POL
!
access-list 111 permit icmp host 3.3.3.3 host 1.1.1.1
access-list 111 permit tcp host 3.3.3.3 host 1.1.1.1
!
route-map POL permit 10
match ip address 111
set ip next-hop 2.2.2.1

R3#debug ip bgp
BGP debugging is on
R3#
1d11h: BGP: 1.1.1.1 multihop open delayed 14192ms (no route) **


----------------------------------------------------

>From: wwwjjang@xxxxxxxx
>Reply-To: wwwjjang@xxxxxxxx
>To: ccielab@xxxxxxxxxxxxxx
>Subject: BGP & PBR (Policy Based Routing)'s query..!!!
>Date: Mon, 4 Aug 2003 09:53:41 -0400
>MIME-Version: 1.0
>Received: from mc8-f22.law1.hotmail.com ([65.54.253.158]) by
>mc8-s7.law1.hotmail.com with Microsoft SMTPSVC(5.0.2195.5600); Mon, 4
Aug
>2003 06:53:54 -0700
>Received: from lists.groupstudy.com ([207.44.210.9]) by
>mc8-f22.law1.hotmail.com with Microsoft SMTPSVC(5.0.2195.5600); Mon, 4
Aug
>2003 06:53:54 -0700
>Received: (from sympa@xxxxxxxxx)by lists.groupstudy.com (8.11.6/8.11.6)
id
>h74DroF09405;Mon, 4 Aug 2003 09:53:50 -0400
>Received: from groupstudy.com (groupstudy.com [66.220.63.9])by
>lists.groupstudy.com (8.11.6/8.11.6) with ESMTP id h74Drj509378for ;
Mon, 4
>Aug 2003 09:53:45 -0400
>Received: from groupstudy.com (localhost [127.0.0.1])by groupstudy.com
>(8.12.8p1/8.12.8) with ESMTP id h74DriKp018268GroupStudy Mailer; Mon, 4
Aug
>2003 13:53:44 GMT
>Received: (from listserver@xxxxxxxxx)by groupstudy.com
>(8.12.8p1/8.12.8/Submit) id h74Drica018267GroupStudy Submission Server;
Mon,
>4 Aug 2003 13:53:44 GMT
>Received: from lists.groupstudy.com (lists.groupstudy.com
[207.44.210.9])
by
>groupstudy.com (8.12.8p1/8.12.8) with ESMTP id h74DrfKp018242
GroupStudy
>Mailer; Mon, 4 Aug 2003 13:53:41 GMT
>Received: (from sympa@xxxxxxxxx) by lists.groupstudy.com
(8.11.6/8.11.6) id
>h74DrfF09375 for ccielab@xxxxxxxxxxxxxx; Mon, 4 Aug 2003 09:53:41 -0400
>X-Message-Info: y838B63spjxdTeo25fa/DX6H3cglIS4RK2ox3uAz7co=
>X-Sympa-From: sympa@xxxxxxxxxxxxxx
>Message-ID:
>X-ASK-Info: Whitelist match
>Sender: nobody@xxxxxxxxxxxxxx
>X-Loop: ccielab@xxxxxxxxxxxxxx
>X-Sequence: 2947
>Errors-to: ccielab-owner@xxxxxxxxxxxxxx
>Precedence: bulk
>X-no-archive: yes
>List-Id:
>List-Help:
>List-Subscribe:
>List-Unsubscribe:
>List-Post:
>List-Owner:
>Return-Path: ccielab-owner@xxxxxxxxxxxxxx
>X-OriginalArrivalTime: 04 Aug 2003 13:53:54.0373 (UTC)
>FILETIME=[D7CAEF50:01C35A8F]
>
>This is my diagram
>
>(L0 1.1.1.1)--R1-(e0 2.2.2.1)--(e0 2.2.2.2)-R3-(L0 3.3.3.3)
> |
> (s1 4.4.4.1)
>
>Assumtion>
>-R3 has a only D/R to the 2.2.2.1
>-R1 has no routing to the R3's L0 (3.3.3.3)
>-R1 has a D/R to the S1(4.4.4.1)
>-R1 is in BGP-AS2
>-R3 is in BGP-AS1
>
>Question>
>-when i config the EBGP between R1 & R2, use loopbacks as the
update-source
> on both routers R1 & F2
>
>------------
>My solution
>------------
>i use a Local Policy Based Routing to make a route to the R3's
L0(3.3.3.3)
>
>R1>
>---
>
>router bgp 2
> bgp log-neighbor-changes
> neighbor 3.3.3.3 remote-as 1
> neighbor 3.3.3.3 ebgp-multihop 255
> neighbor 3.3.3.3 update-source Loopback0
>!
>
>ip local policy route-map POL
>!
>access-list 111 permit icmp host 1.1.1.1 host 3.3.3.3
>access-list 111 permit tcp host 1.1.1.1 host 3.3.3.3
>!
>route-map POL permit 10
> match ip address 111
> set ip next-hop 2.2.2.2
>
>-----
>R2
>-----
>
>router bgp 1
> bgp log-neighbor-changes
> neighbor 1.1.1.1 remote-as 2
> neighbor 1.1.1.1 ebgp-multihop 255
> neighbor 1.1.1.1 update-source Loopback0
>!
>
>==>When i send a ping to the R3's L0(3.3.3.3) with a source ip R1's
>Lo(1.1.1.1)
> , it's OK !!
> but the EBGP-session is not established..
> How should i do ????
>
>R1#sh ip bgp summ
>BGP table version is 1, main routing table version 1
>
>Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
>3.3.3.3 4 1 0 0 0 0 0 never Active
>
>R3#sh ip bgp summ
>BGP table version is 1, main routing table version 1
>
>Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
>1.1.1.1 4 2 0 1 0 0 0 never Active
>
>Wheh i do "debug ip bgp" on R1..****
>=>R1# 1d02h: BGP: 3.3.3.3 multihop open delayed 17632ms (no route)
>
>Person who knows the solution...Please Help me!!!
>
>Thanks..