GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: Classful and classless posted 04/26/2003
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hi Tim,

I think really the CCIE is getting to me :-o

Thanks.

--- Tim Fletcher <tim@xxxxxxxxxxxxxx> wrote:
> Kashif,
> 
> RIP v2 is classless, so there are no
> classful/classless boundaries here. 
> The problem with your config is that your OSPF
> process is 100, but you're 
> redistributing ospf 1 in your RIP config. Fix that
> and everything should 
> work fine.
> 
> -Tim Fletcher #11406
> 
> At 04:00 AM 4/25/2003 -0700, Kash wrote:
> >Hi All,
> >
> >One of my friends has come up with this
> >problem/question. What is the best way(s) for
> >redistribution between classful and classless?
> >
> >I am also a bit confused on this, I have checked
> the
> >books and one of the way that they say is using
> static
> >routes, I am quite sure we cant use that one as
> static
> >routes till allowed cant be used(in the lab).
> >
> >Particularly its the problem below. router r1 is
> able
> >to ping the other routes, and r2 being having rip
> is
> >not.
> >
> >Kashif
> >
> >r1#sr
> >interface Loopback0
> >  ip address 10.7.7.7 255.255.255.0
> >!
> >interface Ethernet0
> >  ip address 172.31.200.7 255.255.255.128
> >  ip ospf authentication-key cisco
> >!
> >interface Serial0
> >  ip address 172.31.78.7 255.255.255.240
> >  no fair-queue
> >!
> >!
> >router ospf 100
> >  log-adjacency-changes
> >  area 567 authentication
> >  redistribute connected subnets
> >  redistribute rip subnets
> >  network 172.31.200.0 0.0.0.127 area 567
> >!
> >router rip
> >  version 2
> >  redistribute connected metric 1
> >  redistribute ospf 1
> >  passive-interface Ethernet0
> >  network 172.31.0.0
> >  default-metric 2
> >  no auto-summary
> >!
> >router bgp 700
> >  no synchronization
> >  bgp log-neighbor-changes
> >  redistribute ospf 1 match external 2
> >  neighbor 172.31.78.8 remote-as 800
> >  neighbor 172.31.200.5 remote-as 96
> >!
> >end
> >
> >r1#sir
> >Codes: C - connected, S - static, I - IGRP, R -
> RIP, M
> >- mobile, B - BGP
> >        D - EIGRP, EX - EIGRP external, O - OSPF,
> IA -
> >OSPF inter area
> >        N1 - OSPF NSSA external type 1, N2 - OSPF
> NSSA
> >external type 2
> >        E1 - OSPF external type 1, E2 - OSPF
> external
> >type 2, E - EGP
> >        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
> >level-2, ia - IS-IS inter area
> >        * - candidate default, U - per-user static
> >route, o - ODR
> >        P - periodic downloaded static route
> >
> >Gateway of last resort is not set
> >
> >      172.31.0.0/16 is variably subnetted, 5
> subnets, 4
> >masks
> >C       172.31.200.0/25 is directly connected,
> >Ethernet0
> >O IA    172.31.12.0/24 [110/84] via 172.31.200.5,
> >05:56:50, Ethernet0
> >                        [110/84] via 172.31.200.6,
> >05:56:50, Ethernet0
> >O IA    172.31.100.0/29 [110/74] via 172.31.200.5,
> >05:56:50, Ethernet0
> >                         [110/74] via 172.31.200.6,
> >05:56:50, Ethernet0
> >O E2    172.31.69.0/24 [110/20] via 172.31.200.6,
> >05:56:50, Ethernet0
> >C       172.31.78.0/28 is directly connected,
> Serial0
> >      10.0.0.0/8 is variably subnetted, 7 subnets,
> 3
> >masks
> >O IA    10.2.2.2/32 [110/75] via 172.31.200.5,
> >05:56:52, Ethernet0
> >                     [110/75] via 172.31.200.6,
> >05:56:52, Ethernet0
> >O E2    10.9.9.0/24 [110/20] via 172.31.200.6,
> >05:37:59, Ethernet0
> >O E2    10.5.5.0/24 [110/20] via 172.31.200.5,
> >05:56:46, Ethernet0
> >O E2    10.1.1.0/24 [110/20] via 172.31.200.5,
> >05:56:52, Ethernet0
> >                     [110/20] via 172.31.200.6,
> >05:56:52, Ethernet0
> >O E2    10.6.6.0/24 [110/20] via 172.31.200.6,
> >05:56:52, Ethernet0
> >R       10.0.0.0/8 [120/1] via 172.31.78.8,
> 00:00:03,
> >Serial0
> >C       10.7.7.0/24 is directly connected,
> Loopback0
> >R    150.50.0.0/16 [120/1] via 172.31.78.8,
> 00:00:03,
> >Serial0
> >
> >r1#ping 10.1.1.1
> >
> >Type escape sequence to abort.
> >Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout
> is
> >2 seconds:
> >!!!!!
> >Success rate is 100 percent (5/5), round-trip
> >min/avg/max = 68/72/81 ms
> >r1#
> >
> >
>
>__________________________________________________________________
> >r2#sr
> >interface Loopback0
> >  ip address 10.8.8.8 255.255.255.0
> >!
> >interface Serial0
> >  ip address 172.31.78.8 255.255.255.240
> >  no fair-queue
> >  clockrate 64000
> >!
> >router rip
> >  version 2
> >  network 10.0.0.0
> >  network 172.31.0.0
> >!
> >router bgp 800
> >  bgp log-neighbor-changes
> >  neighbor 172.31.78.7 remote-as 700
> >!
> >r2#sir
> >Codes: C - connected, S - static, I - IGRP, R -
> RIP, M
> >- mobile, B - BGP
> >        D - EIGRP, EX - EIGRP external, O - OSPF,
> IA -
> >OSPF inter area
> >        N1 - OSPF NSSA external type 1, N2 - OSPF
> NSSA
> >external type 2
> >        E1 - OSPF external type 1, E2 - OSPF
> external
> >type 2, E - EGP
> >        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
> >level-2, ia - IS-IS inter area
> >        * - candidate default, U - per-user static
> >route, o - ODR
> >        P - periodic downloaded static route
> >
> >Gateway of last resort is not set
> >
> >      172.31.0.0/16 is variably subnetted, 2
> subnets, 2
> >masks
> >R       172.31.200.0/25 [120/1] via 172.31.78.7,
> >00:00:20, Serial0
> >C       172.31.78.0/28 is directly connected,
> Serial0
> >      10.0.0.0/24 is subnetted, 2 subnets
> >R       10.7.7.0 [120/1] via 172.31.78.7, 00:00:20,
> >Serial0
> >C       10.8.8.0 is directly connected, Loopback0
> >      150.50.0.0/24 is subnetted, 1 subnets
> 
=== message truncated ===


__________________________________
Do you Yahoo!?
The New Yahoo! Search - Faster. Easier. Bingo.
http://search.yahoo.com