GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: RIP to OSPF redistribution posted 12/31/2002
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Kym,
I have tried the 2nd option you have suggested 

I have the following setup.

R4(to)------(t0/0)R6(s0/0-FR) ------(s5/1-FR) R2

R4 and R6 is running OSPF
R6 and R2 is running RIP v1.

Interface information:
R6 s0/0 ---> 148.9.100.1/24
R6 t0/0 --->  148.9.1.2/30
R4 t0 --->     148.9.1.1/30
R2 s5/1--->   148.9.100.2/24

The following are the configs for each router.

R6
router ospf 54
 log-adjacency-changes
 summary-address 130.0.0.0 255.0.0.0
 redistribute rip metric 10 subnets
 network 148.9.1.2 0.0.0.0 area 0

router rip
 redistribute ospf 54 metric 2
 network 148.9.0.0

R2
router rip
 network 148.9.0.0

R4
r4-ccie#sh run | be router ospf
router ospf 54
 log-adjacency-changes
 network 148.9.1.0 0.0.0.3 area 0
 network 148.9.1.8 0.0.0.3 area 0
 network 148.9.4.0 0.0.0.255 area 0
 network 160.1.1.0 0.0.0.255 area 0


R6#sh ip route ospf
     160.1.0.0/32 is subnetted, 1 subnets
O       160.1.1.1 [110/7] via 148.9.1.1, 00:06:14, TokenRing0/0
     148.9.0.0/16 is variably subnetted, 7 subnets, 2 masks
O       148.9.1.8/30 [110/7] via 148.9.1.1, 00:06:14, TokenRing0/0
O       148.9.4.0/24 [110/7] via 148.9.1.1, 00:06:14, TokenRing0/0
O    130.0.0.0/8 is a summary, 01:03:53, Null0
R6#


R2 learns rip updates from R6  matching subnet /24, others (such as 160.1.1.0) only major network address itself is included in the advertisement.

R2#sh ip route rip
R    160.1.0.0/16 [120/2] via 148.9.100.1, 00:00:11, Serial5/1
     148.9.0.0/24 is subnetted, 5 subnets
R       148.9.4.0 [120/2] via 148.9.100.1, 00:00:11, Serial5/1
R       148.9.6.0 [120/1] via 148.9.100.1, 00:00:11, Serial5/1
R2#

Now to learn other networks with different subnets (such as 148.9.1.0/30 and 148.9.1.8/30) I have added the secondary address to the R2(s5/1) and R6 (s0/0)

R6 (s0/0)
interface Serial0/0
 ip address 148.9.1.65 255.255.255.252 secondary
 ip address 148.9.100.1 255.255.255.0

R2 (s5/1)
interface Serial5/1
 description to (FR s1/6)
 ip address 148.9.1.66 255.255.255.252 secondary
 ip address 148.9.100.2 255.255.255.0    

This is (bolded entries) what happens.
**148.9.1.0/30 and 148.9.1.8/30) did not show up in the rip routing table.

R2#sh ip route rip
R    160.1.0.0/16 [120/2] via 148.9.100.1, 00:00:15, Serial5/1
     148.9.0.0/16 is variably subnetted, 8 subnets, 2 masks
R       148.9.4.0/30 [120/2] via 148.9.100.1, 00:00:15, Serial5/1
R       148.9.4.0/24 [120/2] via 148.9.100.1, 00:01:10, Serial5/1
R       148.9.6.0/30 [120/1] via 148.9.100.1, 00:00:15, Serial5/1
R       148.9.6.0/24 [120/1] via 148.9.100.1, 00:01:10, Serial5/1
R2#

Using "ip summary-address rip 148.9.1.0 255.255.255.0" on the R6(s0/0) adds 148.9.1.0/30 but not the 148.9.1.8/30. Actually summary is not allowed.

Any idea ?

Thanks 
Kafkaf

-----Original Message-----

From: kym blair [mailto:kymblair@xxxxxxxxxxx]

Sent: Sunday, December 29, 2002 4:05 AM

To: dragain@xxxxxxxxxxx

Cc: ccielab@xxxxxxxxxxxxxx

Subject: Re: RIP to OSPF redistribution

 

Jay and Yong,

When you are doing mutual redistribution between OSPF and RIP, there are 

several ways to get the OSPF routes into RIP:

(1) Use RIP version 2

(2) Create a /30 secondary address on the R2-R3 link so R3 will learn the 

/24 AND /30 routes (repeat for other masks)

(3) Create a tunnel between R2 and R3 with a /30 mask (repeat for other 

masks)

(4) My favorite if you can't use RIPv2: Create another OSPF process on R2; 

redistribute OSPF 1 into OSPF 2; add summary-address statements under OSPF 

2; redistribute OSPF 1 and OSPF 2 into RIP.

HTH, Kym



---------------------------------
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now
.
__________________________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab