GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: RE:ISIS posted 10/23/2002
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hello,

As I understand, ISIS treat multipoint subinterface or FR physical interface
both as LAN.  So seems not necessary to change all interfaces to be
multipoint subinterface.  But I got the same problem, too, i.e., spoke
router can't install the route of the other spoke's interface, though it is
in the ISIS database (172.16.2.0).  Anyone explain this?  In which scenarios
ISIS will not install a route from its database?   /Henry


houlab-2611c#sh is da de

IS-IS Level-2 Link State Database:
LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime      ATT/P/OL
houlab-2611c.00-00  * 0x00000016   0x31A2        814               0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: houlab-2611c
  IP Address:   172.16.1.1
  Metric: 10         IP 172.16.123.0 255.255.255.0
  Metric: 10         IS houlab-2611a.01
  Metric: 0          IP 172.16.1.0 255.255.255.0
houlab-2610xm.00-00   0x0000000D   0x64F0        463               0/0/0
  Area Address: 49.0002
  NLPID:        0xCC
  Hostname: houlab-2610xm
  IP Address:   172.16.2.2
  Metric: 10         IP 172.16.123.0 255.255.255.0
  Metric: 10         IS houlab-2611a.01
  Metric: 0          IP 172.16.2.0 255.255.255.0
houlab-2611a.00-00    0x00000010   0x705F        1064              0/0/0
  Area Address: 49.0001
  NLPID:        0xCC
  Hostname: houlab-2611a
  IP Address:   172.16.4.4
  Metric: 10         IP 172.16.123.0 255.255.255.0
  Metric: 10         IP 172.16.123.0 255.255.255.0
  Metric: 0          IP 172.16.4.0 255.255.255.0
houlab-2611a.01-00    0x0000000E   0x1525        609               0/0/0
  Metric: 0          IS houlab-2611a.00
  Metric: 0          IS houlab-2611c.00
  Metric: 0          IS houlab-2610xm.00
houlab-2611c#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 172.17.79.254 to network 0.0.0.0

     172.17.0.0/24 is subnetted, 1 subnets
C       172.17.79.0 is directly connected, Ethernet0/0
     172.16.0.0/24 is subnetted, 3 subnets
i L2    172.16.4.0 [115/10] via 172.16.123.4, Serial0/0
C       172.16.1.0 is directly connected, Loopback0
C       172.16.123.0 is directly connected, Serial0/0
S*   0.0.0.0/0 [1/0] via 172.17.79.254
houlab-2611c#


----- Original Message -----
From: "Hung, Sing-Yu" <Sing-Yu.Hung@xxxxxxxx>
To: "LoizosCisco" <david_steven2001@xxxxxxxxx>; <ccielab@xxxxxxxxxxxxxx>
Sent: Tuesday, October 22, 2002 9:45 AM
Subject: RE:ISIS


> Hi,
>
> I have changed the followings:
> 1. change r3 s0 to s0.1 multipoint
> 2. Change r5 s0 to s0.1 multipoint
> 3. set priority at r3 s0.1 and r5 s0.1 to 0
>
> However at r5 I can see the r3 lo 10 by "sho isis da detail" but why it
can
> not show up at routing table?
>
> **************************************************************
> r5#sho isis da l1 r3.00-00 de
>
>
> IS-IS Level-1 LSP r3.00-00
> LSPID                 LSP Seq Num  LSP Checksum  LSP Holdtime
ATT/P/OL
> r3.00-00              0x0000001B   0x3384        1175              0/0/0
>   Area Address: 47
>   NLPID:        0xCC
>   Hostname: r3
>   IP Address:   172.16.30.3
>   Metric: 10         IP 172.16.30.0 255.255.255.128
>   Metric: 10         IP 172.16.100.0 255.255.255.224
>   Metric: 10         IS r3.01
>   Metric: 10         IS r6.01
> **************************************************************
>
>
> Bradford Hung
>
>  Pacific Century CyberWorks
>  Tel: 288 33125
>
>
> -----Original Message-----
> From: LoizosCisco [mailto:david_steven2001@xxxxxxxxx]
> Sent: Monday, October 21, 2002 10:21 PM
> To: Hung, Sing-Yu; ccielab@xxxxxxxxxxxxxx
> Subject: RE: Redistribution
>
>
> Why are you using ISIS and ip ospf network commands
> together? Since you are using ISIS you do not need the
> ip ospf network commands.
>
>
http://www.cisco.com/en/US/customer/tech/tk472/tk474/technologies_tech_note0
> 9186a008009445a.shtml
>
>
> --- "Hung, Sing-Yu" <Sing-Yu.Hung@xxxxxxxx> wrote:
> > Hi,
> >
> > Below is my config.
> >
> > (lo10)r3(s0)-------r6(s0.2)-----------(s0)r5
> >
> > r6 is the hub and r3 and r5 is the spoke in the
> > frame-relay
> > network.And isis is enable in r3, r6 and r5.
> >
> > In the begining, r5 can see r3 lo10, however after
> > few mins r3 lo10 will
> > disappear in r5. Can anyone tell me why? And why it
> > is L2 not L1?
> >
> ############################################################
> > r3 config:
> > clns routing
> > interface Loopback10
> >  ip address 172.16.30.3 255.255.255.128
> >  ip router isis
> >  ip ospf network point-to-point
> > interface Serial0
> >  ip address 172.16.100.3 255.255.255.224
> >  ip router isis
> >  encapsulation frame-relay
> >  ip ospf message-digest-key 100 md5 ccie100
> >  ip ospf network point-to-multipoint
> >  no fair-queue
> >  frame-relay map clns 103 broadcast
> >  frame-relay map dlsw 103
> >  frame-relay map ip 172.16.100.5 103 broadcast
> >  frame-relay map ip 172.16.100.6 103 broadcast
> >  frame-relay interface-dlci 103
> >  clns router isis
> > !
> > router isis
> >  net 01.0000.0000.0003.00
> >
> ############################################################
> > r6 config:
> > interface Serial0.2 multipoint
> >  ip address 172.16.100.6 255.255.255.224
> >  ip router isis
> >  ip pim sparse-dense-mode
> >  ip ospf message-digest-key 100 md5 ccie100
> >  ip ospf network point-to-multipoint
> >  frame-relay map clns 103 broadcast
> >  frame-relay map clns 101 broadcast
> >  frame-relay map dlsw 103
> >  frame-relay map ip 172.16.100.3 103 broadcast
> >  frame-relay map ip 172.16.100.5 101 broadcast
> >  frame-relay interface-dlci 101
> >   class 12k
> >  frame-relay interface-dlci 103
> >   class 24k
> >  clns router isis
> >  crypto map sec-1
> > !
> > router isis
> >  net 01.0000.0000.0006.00
> > !
> >
> ############################################################
> > r5 config:
> > !
> > interface Serial0
> >  ip address 172.16.100.5 255.255.255.224
> >  ip router isis
> >  encapsulation frame-relay
> >  ip ospf message-digest-key 100 md5 ccie100
> >  ip ospf network point-to-multipoint
> >  ip igmp join-group 224.1.1.1
> >  frame-relay map clns 101 broadcast
> >  frame-relay map ip 172.16.100.3 101 broadcast
> >  frame-relay map ip 172.16.100.6 101 broadcast
> >  frame-relay interface-dlci 101
> >  frame-relay lmi-type cisco
> >  clns router isis
> > !
> > router isis
> >  net 01.0000.0000.0005.00
> > !
> >
> ############################################################
> >
> >
> >
> > r5#r
> > Codes: C - connected, S - static, I - IGRP, R - RIP,
> > M - mobile, B - BGP
> >        D - EIGRP, EX - EIGRP external, O - OSPF, IA
> > - OSPF inter area
> >        N1 - OSPF NSSA external type 1, N2 - OSPF
> > NSSA external type 2
> >        E1 - OSPF external type 1, E2 - OSPF external
> > type 2, E - EGP
> >        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
> > level-2, ia - IS-IS inter
> > area
> >        * - candidate default, U - per-user static
> > route, o - ODR
> >        P - periodic downloaded static route
> >
> > Gateway of last resort is not set
> >
> >      172.16.0.0/16 is variably subnetted, 6 subnets,
> > 5 masks
> > C       172.16.135.0/28 is directly connected,
> > Ethernet0
> > C       172.16.56.0/29 is directly connected,
> > Dialer0
> > i L2    172.16.30.0/25 [115/30] via 172.16.100.6,
> > Serial0
> > C       172.16.5.0/24 is directly connected,
> > Loopback0
> > C       172.16.100.0/27 is directly connected,
> > Serial0
> > i L1    172.16.86.0/24 [115/20] via 172.16.100.6,
> > Serial0
> > r5#
> > r5#r
> > Codes: C - connected, S - static, I - IGRP, R - RIP,
> > M - mobile, B - BGP
> >        D - EIGRP, EX - EIGRP external, O - OSPF, IA
> > - OSPF inter area
> >        N1 - OSPF NSSA external type 1, N2 - OSPF
> > NSSA external type 2
> >        E1 - OSPF external type 1, E2 - OSPF external
> > type 2, E - EGP
> >        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
> > level-2, ia - IS-IS inter
> > area
> >        * - candidate default, U - per-user static
> > route, o - ODR
> >        P - periodic downloaded static route
> >
> > Gateway of last resort is not set
> >
> >      172.16.0.0/16 is variably subnetted, 5 subnets,
> > 4 masks
> > C       172.16.135.0/28 is directly connected,
> > Ethernet0
> > C       172.16.56.0/29 is directly connected,
> > Dialer0
> > C       172.16.5.0/24 is directly connected,
> > Loopback0
> > C       172.16.100.0/27 is directly connected,
> > Serial0
> > i L1    172.16.86.0/24 [115/20] via 172.16.100.6,
> > Serial0
> >
> > Bradford Hung
> >
> >  Pacific Century CyberWorks
> >  Tel: 288 33125
>
>
> __________________________________________________
> Do you Yahoo!?
> Y! Web Hosting - Let the expert host your web site
> http://webhosting.yahoo.com/