GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: Multicast problem posted 08/07/2002
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Without your actual configs it's pretty hard to find your
mistake (other than pointing out the obvious). 

Anyway, this config works with R2 as the RP, R1 as the mapping
agent, and R4 as the source.

R2-------R1-------R4

R1 config:

interface Loopback0
 ip address 192.168.100.1 255.255.255.0
 ip pim sparse-dense-mode
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 ip pim sparse-dense-mode
!
interface FastEthernet0/1
 ip address 192.168.14.1 255.255.255.0
 ip pim sparse-dense-mode
!
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
!
ip pim send-rp-discovery Loopback0 scope 10


R2 Config:

ip multicast-routing
!
interface Loopback0
 ip address 192.168.200.1 255.255.255.0
 ip pim sparse-dense-mode
!
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
 ip pim sparse-dense-mode
 ip igmp join-group 239.255.255.255
 ip igmp join-group 238.255.255.255
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
!
ip pim send-rp-announce Loopback0 scope 10

R4:

ip multicast-routing
!
interface Loopback10
 ip address 192.168.40.1 255.255.255.0
 ip pim sparse-dense-mode
!
interface Ethernet1/0
 ip address 192.168.14.4 255.255.255.0
 ip pim sparse-dense-mode
!
router ospf 1
 log-adjacency-changes
 network 192.168.0.0 0.0.255.255 area 0
!

Testing this:

Make sure R4 sees the RP:

r4#sho ip pim rp-hash 239.255.255.255
  RP 192.168.200.1 (?), v2v1
    Info source: 192.168.100.1 (?), via Auto-RP
         Uptime: 00:11:18, expires: 00:02:33
r4#

So we see R2 as the RP, and we learned that from R1.

r4#ping 239.255.255.255

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 239.255.255.255, timeout is 2 seconds:

Reply to request 0 from 192.168.12.2, 4 ms
r4#

Changing the source interface:

r4#ping
Protocol [ip]:
Target IP address: 239.255.255.255
Repeat count [1]: 5
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Interface [All]: loopback10
Time to live [255]:
Source address:
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 239.255.255.255, timeout is 2 seconds:

Reply to request 0 from 192.168.12.2, 4 ms
Reply to request 1 from 192.168.12.2, 1 ms
Reply to request 2 from 192.168.12.2, 1 ms
Reply to request 3 from 192.168.12.2, 1 ms
Reply to request 4 from 192.168.12.2, 1 ms
r4#


And ping works.

"Krucker, Louis" wrote:
> 
> Thanks for your mail, i was a bit "overloaded" yesterday
> but in the meantime i put the correct addresses on it.
> 
> I already configure the lo 0 as sp-de mode otherwise you will an error
> message.
> 
> Its a bit funny for me, two guys correct me cause i put the wrong
> addresses on to the interface, thats fine but nobody can tell
> me why i can ping my two multicast addresses from the RP but not
> from R4 which is one hop behind the RP.
> 
> I ask a few guys but nowbody can give me a locically answer. I can
> ask 5 guys and i get 5 different answers even from ccie's........
> 
> cheers
> Louis
> 
> 
> 
> -----Original Message-----
> From: CCIE FUN
> To: Edmund Roche-Kelly; Krucker, Louis
> Cc: 'ccielab@xxxxxxxxxxxxxx'
> Sent: 07.08.2002 20:09
> Subject: Re: Multicast problem
> 
> First of all the multicast address range is from
> 
> 224.0.0.0 through 239.255.255.255
> 
> second thing, once you correct the Multicast address,
> make sure you have Multicast enabled on the LOOPback 0
> of R1 with the command ip pim sparse-dense mode.
> 
> --- Edmund Roche-Kelly <edr9007@xxxxxxx> wrote:
> > What makes you think 240.0.0.1 and 241.0.0.2 are
> > multicast addresses?
> >
> >
> > "Krucker, Louis" wrote:
> > >
> > > Hi folks
> > >
> > > I play around with a simple multicast lab and run
> > in some troubles
> > >
> > > |-R2-------------R1---------------R4--|
> > >
> > > R2 is the multicast source, R1 is the mapping
> > agent and R4 is connected
> > > to multicast receivers. I use sparse-dense mode on
> > all interfaces, R2 is the
> > > RP.
> > >
> > > My idea was to simulate two multicast groups on R2
> > which i can ping from
> > > R4 to test it.
> > >
> > > On R2 i use ip igmp join-group 240.0.0.1
> > >             ip igmp join-group 241.0.0.2
> > > and on the ethernet "ip pim send-rp-announce
> > Loopback0 scope 10"
> > > to announce the rp to the cloud.
> > >
> > > On R1 i have configure ip pim send-rp-discovery lo
> > 0 scope 10 to
> > > set up a mapping agent. On R4 i configured only
> > multicast-routing and
> > > sparse-dense mode on the interfaces which route
> > multicast.
> > >
> > > The problem I can ping those groups from the MA
> > but not from R4, does
> > > somebody know where is the mistake ? IP routing is
> > OK because i can ping
> > > from R4 the ethernet interface where thos two
> > sourced are connected.
> > >
> > > Thanks for help
> > >
> > > Louis
> > >
> >
> _________________________________________________________________
> > > Commercial lab list:
> > http://www.groupstudy.com/list/commercial.html
> > > Please discuss commercial lab solutions on this
> > list.
> >
> _________________________________________________________________
> > Commercial lab list:
> > http://www.groupstudy.com/list/commercial.html
> > Please discuss commercial lab solutions on this
> > list.
> >
> __________________________________________________________________
> > To unsubscribe from the CCIELAB list, send a message
> > to
> > majordomo@xxxxxxxxxxxxxx with the body containing:
> > unsubscribe ccielab
> 
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Health - Feel better, live better
> http://health.yahoo.com
> _________________________________________________________________
> Commercial lab list: http://www.groupstudy.com/list/commercial.html
> Please discuss commercial lab solutions on this list.
_________________________________________________________________
Commercial lab list: http://www.groupstudy.com/list/commercial.html
Please discuss commercial lab solutions on this list.
__________________________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab