GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: BGP MED - again posted 04/06/2002
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


If you want to influence the route when leaving R3 then use a route map to
change the local pref on the learned route from R1/R2. If you want to influence
R1/R2 on which way they will come in then modify the MED. This is what I know,
let me know if someone disagrees.

Thanks,
Greg




ying chang wrote:

> Well, "bgp always compared Med" would not work help in this case as they
> both come from AS1.
>
> There are two web pages are helpful:
>
> http://www.cisco.com/warp/public/459/bgp-med.html
> http://www.cisco.com/warp/public/459/37.html
>
> Here's my question, if we stick on the original problem, which is we are
> trying to tell AS1 to prefer R1-R3 route instead of R2-R3 route, how can we
> do it without changing anything on either R1 or R2? Can it be done? In
> simple term, R1 and R2 are proctor's routers, and you have to work on R3 to
> make R1 and R2 always prefer R1-R3 route.
>
> Thanks,
> Chang
>
> >From: Muhamamd Durrani <dan_schaw@xxxxxxxxx>
> >Reply-To: Muhamamd Durrani <dan_schaw@xxxxxxxxx>
> >To: Jason <jgraun@xxxxxxxxx>, "'Peter Dostal'" <pdostal@xxxxxxx>,
> >ccielab@xxxxxxxxxxxxxx
> >Subject: RE: BGP MED
> >Date: Fri, 5 Apr 2002 23:00:57 -0800 (PST)
> >
> >you should use "bgp always compared Med " command to
> >force BGP to compare MED for destination from
> >Different AS systems . By default BGP donot compare
> >MED for same destinations from neighbors from
> >different AS.
> >
> >So R2 must have this command and than verify ur result
> >....
> >
> >Regards,
> >Muhammad
> >
> >
> >--- Jason <jgraun@xxxxxxxxx> wrote:
> > > Well iBGP as an Admin distance of 200 while eBGP has
> > > an admin distance
> > > of 20
> > >
> > > -----Original Message-----
> > > From: nobody@xxxxxxxxxxxxxx
> > > [mailto:nobody@xxxxxxxxxxxxxx] On Behalf Of
> > > Peter Dostal
> > > Sent: Friday, April 05, 2002 6:58 PM
> > > To: ccielab@xxxxxxxxxxxxxx
> > > Subject: BGP MED
> > >
> > > I have a problem with BGP path selection process.
> > > Based on the BGP path
> > > selection process I would say that router R2 should
> > > choose iBGP path
> > > over
> > > eBGP (because of lower MED). Any suggestions?
> > > Thanks,
> > >
> > > Peter
> > >
> > >
> > > R1----FrameRelay----R2
> > > |                    |
> > > ------Ethernet-------
> > >           |
> > >           R3
> > >
> > > *********************************************
> > > hostname R1
> > > !
> > > interface FastEthernet1/1
> > >  ip address 192.168.2.3 255.255.255.0
> > > !
> > > interface Serial1/0
> > >  ip address 192.168.1.1 255.255.255.0
> > >  encapsulation frame-relay
> > >  no keepalive
> > >  no fair-queue
> > >  frame-relay interface-dlci 100
> > > !
> > > router bgp 2
> > >  bgp log-neighbor-changes
> > >  neighbor 192.168.1.2 remote-as 2
> > >  neighbor 192.168.1.2 next-hop-self
> > >  neighbor 192.168.2.1 remote-as 1
> > >  neighbor 192.168.2.1 route-map BGP_MAP in
> > >  no auto-summary
> > > !
> > > route-map BGP_MAP permit 10
> > >  set local-preference 100
> > >
> > > *********************************************
> > > hostname R2
> > > !
> > > interface FastEthernet0/0
> > >  ip address 192.168.2.2 255.255.255.0
> > > !
> > > interface Serial0/0
> > >  ip address 192.168.1.2 255.255.255.252
> > >  encapsulation frame-relay
> > >  no keepalive
> > >  no fair-queue
> > >  frame-relay interface-dlci 100
> > > !
> > > router bgp 2
> > >  bgp log-neighbor-changes
> > >  neighbor 192.168.1.1 remote-as 2
> > >  neighbor 192.168.1.1 next-hop-self
> > >  neighbor 192.168.2.1 remote-as 1
> > >  neighbor 192.168.2.1 route-map BGP_MAP in
> > >  no auto-summary
> > > !
> > > route-map BGP_MAP permit 10
> > >  set local-preference 100
> > > !
> > > *********************************************
> > > hostname R3
> > > !
> > > interface FastEthernet0/1
> > >  ip address 192.168.2.1 255.255.255.0
> > > !
> > > interface Loopback0
> > >  ip address 170.2.1.1 255.255.255.240
> > > !
> > > router bgp 1
> > >  bgp log-neighbor-changes
> > >  network 170.2.1.0 mask 255.255.255.240
> > >  neighbor 192.168.2.2 remote-as 2
> > >  neighbor 192.168.2.2 route-map BGP_MAP out
> > >  neighbor 192.168.2.3 remote-as 2
> > >  no auto-summary
> > > !
> > > route-map BGP_MAP permit 10
> > >  set metric 20
> > >
> > > *********************************************
> > > R1#sh ip bgp
> > > BGP table version is 8, local router ID is
> > > 172.10.1.1
> > > Status codes: s suppressed, d damped, h history, *
> > > valid, > best, i -
> > > internal
> > > Origin codes: i - IGP, e - EGP, ? - incomplete
> > >
> > >    Network          Next Hop            Metric
> > > LocPrf Weight Path
> > > *> 170.2.1.0/28     192.168.2.1              0
> > > 100      0 1 i
> > > * i                 192.168.1.2             20
> > > 100      0 1 i
> > > *********************************************
> > > R2#sh ip bgp
> > > BGP table version is 8, local router ID is
> > > 192.168.2.2
> > > Status codes: s suppressed, d damped, h history, *
> > > valid, > best, i -
> > > internal
> > > Origin codes: i - IGP, e - EGP, ? - incomplete
> > >
> > >    Network          Next Hop            Metric
> > > LocPrf Weight Path
> > > * i170.2.1.0/28     192.168.1.1              0
> > > 100      0 1 i
> > > *>                  192.168.2.1             20
> > > 100      0 1 i
> > > *********************************************
> > >
> >_________________________________________________________________
> > > Commercial lab list:
> > > http://www.groupstudy.com/list/commercial.html
> > > Please discuss commercial lab solutions on this
> > > list.
> > >
> >_________________________________________________________________
> > > Commercial lab list:
> > > http://www.groupstudy.com/list/commercial.html
> > > Please discuss commercial lab solutions on this
> > > list.
> > >
> >__________________________________________________________________
> > > To unsubscribe from the CCIELAB list, send a message
> > > to
> > > majordomo@xxxxxxxxxxxxxx with the body containing:
> > > unsubscribe ccielab
> >
> >
> >__________________________________________________
> >Do You Yahoo!?
> >Yahoo! Tax Center - online filing with TurboTax
> >http://taxes.yahoo.com/
> >_________________________________________________________________
> >Commercial lab list: http://www.groupstudy.com/list/commercial.html
> >Please discuss commercial lab solutions on this list.
> _________________________________________________________________
> MSN Photos is the easiest way to share and print your photos:
> http://photos.msn.com/support/worldwide.aspx
> _________________________________________________________________
> Commercial lab list: http://www.groupstudy.com/list/commercial.html
> Please discuss commercial lab solutions on this list.
_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com
_________________________________________________________________
Commercial lab list: http://www.groupstudy.com/list/commercial.html
Please discuss commercial lab solutions on this list.
__________________________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab