GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: RE: BPG and NAT issues posted 02/11/2002
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


In NAT can u please remove the keyword "overload"
So the router can translate exactly to the same BGP tcp port..... i think
this is the pointer here.

-Mamoor
----- Original Message -----
From: <RSiddappa@xxxxxxxxxx>
To: <armreg@xxxxxxxxxxxx>; <jamartinez@xxxxxxxxxxxxxxxx>;
<ccielab@xxxxxxxxxxxxxx>
Sent: Tuesday, February 12, 2002 12:54 AM
Subject: RE: RE: BPG and NAT issues


> Hi,
>
> It looks good for me.
>
> But what is the status of u r BGP neighbor.
>
> Pls send the o/p of Debug BGP events, and clear the BGP process and see
> where it stops.
>
> And can u try to take out ur OSPF our for while and see will the BGP makes
a
> neighbor relation.
>
> R.
>
>
> -----Original Message-----
> From: armreg@xxxxxxxxxxxx [mailto:armreg@xxxxxxxxxxxx]
> Sent: Monday, February 11, 2002 12:37 PM
> To: Siddappa, Rajeev; jamartinez@xxxxxxxxxxxxxxxx;
> ccielab@xxxxxxxxxxxxxx
> Subject: RE: RE: BPG and NAT issues
>
>
>
> Sorry Guy,
>
> these are the configurations for R1 and R2.
>
>
>
> R1#sh run
> Building configuration...
>
> Current configuration : 1645 bytes
> !
> version 12.1
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname R1
> !
> !
> !
> !
> !
> !
> ip subnet-zero
> no ip finger
> ip tcp synwait-time 5
> no ip domain-lookup
> !
> ipx routing 0001.0001.0001
> !
> !
> !
> !
> !
> interface Loopback0
>  ip address 15.15.1.1 255.255.255.0
>  ipx network 11
> !
> interface Ethernet0
>  no ip address
>  shutdown
> !
> interface Serial0
>  ip address 10.1.11.1 255.255.255.0
>  ip nat inside
>  encapsulation frame-relay
>  ip ospf network point-to-multipoint
>  ipx network 1401
>  frame-relay map ipx 1401.0014.0014.0014 301 broadcast
>  frame-relay map ip 10.1.11.1 301 broadcast
>  frame-relay map ipx 1401.0001.0001.0001 301 broadcast
>  frame-relay map ipx 1401.0003.0003.0003 301 broadcast
>  frame-relay map ip 10.1.11.14 301 broadcast
>  frame-relay lmi-type cisco
> !
> interface Serial1
>  ip address 200.200.200.1 255.255.255.0
>  ip nat outside
> !
> router ospf 1
>  log-adjacency-changes
>  redistribute static subnets
>  network 10.1.11.0 0.0.0.255 area 0
>  network 15.15.1.0 0.0.0.255 area 0
>  network 200.200.200.0 0.0.0.255 area 20
> !
> router ospf 100
>  log-adjacency-changes
> !
> router bgp 100
>  bgp log-neighbor-changes
>  network 200.200.200.0
>  neighbor 200.200.200.2 remote-as 200
> !
> ip nat inside source list 10 interface Serial1 overload
> ip classless
> ip route 15.15.2.0 255.255.255.0 200.200.200.2
> ip http server
> !
> access-list 10 permit any
> !
> !
> !
> ipx router eigrp 20
>  network 1401
>  network 11
> !
> !
> ipx router rip
>  no network 11
>  no network 1401
> !
> !
> ipx sap 4 f1server 11.000e.000e.000e 1 1
> ipx sap 7 p1server 11.000e.000e.000e 1 1
> !
> !
> line con 0
>  logging synchronous
>  transport input none
> line aux 0
> line vty 0 4
>  login
> !
> end
>
>
>
>
>
>
> R2
>
> R2#sh run
> Building configuration...
>
> Current configuration:
> !
> version 11.3
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname R2
> !
> !
> !
> !
> interface Loopback0
>  ip address 15.15.2.2 255.255.255.0
> !
> interface Loopback1
>  ip address 1.1.1.1 255.255.255.0
> !
> interface Loopback2
>  ip address 1.1.2.1 255.255.255.0
> !
> interface Loopback3
>  ip address 1.1.3.1 255.255.255.0
> !
> interface Serial0
>  no ip address
>  no ip mroute-cache
>  shutdown
>  no fair-queue
> !
> interface Serial1
>  ip address 200.200.200.2 255.255.255.0
>  clockrate 125000
> !
> interface TokenRing0
>  no ip address
>  shutdown
> !
> router odr
> !
> router ospf 1
>  network 15.15.2.0 0.0.0.255 area 20
>  network 200.200.200.0 0.0.0.255 area 20
>  distribute-list 11 in Serial1
> !
> router bgp 200
>  no synchronization
>  network 1.1.1.0 mask 255.255.255.0
>  network 1.1.2.0 mask 255.255.255.0
>  network 1.1.3.0 mask 255.255.255.0
>  network 200.200.200.0
>  neighbor 200.200.200.1 remote-as 100
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 200.200.200.1
> !
> access-list 11 deny   any
> !
> line con 0
> line aux 0
> line vty 0 4
>  login
> !
> end
>
>
>
> RSiddappa@xxxxxxxxxx wrote:
>
> >
> >Antonio,
> >
> >Can you send me the full configs.
> >
> >R.
> >
> >
> >
> >
> >-----Original Message-----
> >From: JOSE ANGEL MARTINEZ DE LA VARA
> >[mailto:jamartinez@xxxxxxxxxxxxxxxx]
> >Sent: Monday, February 11, 2002 10:20 AM
> >To: 'armreg@xxxxxxxxxxxx'; ccielab@xxxxxxxxxxxxxx
> >Subject: RE: BPG and NAT issues
> >
> >
> >Your TCP connections are not broken since you are in Open state. Halabi
> book
> >says in page 110 that in openSent or openConfirm the TCP connection IS
> >stablished and the BGP OPEN message has been sent.
> >
> >I think your problem comes from the reuirements from BGP not from IP
> >conectivity.
> >
> >I cannot see where your ASES start and end so I cannot give you more
> >details.
> >
> >Funny work
> >
> >Jose Angel
> >
> >-----Mensaje original-----
> >De: armreg@xxxxxxxxxxxx [mailto:armreg@xxxxxxxxxxxx]
> >Enviado el: lunes, 11 de febrero de 2002 16:54
> >Para: ccielab@xxxxxxxxxxxxxx
> >Asunto: BPG and NAT issues
> >
> >
> >Guys,
> >
> >I am having some problems with BGP and NAT configuration.
> >
> >
> >        Nat inside      Nat outside
> >
> >        10.1.11.x/24     .1   .1     200.200.200.x /24        .2
> >FR Cloud-------------------R1-----------------------------------R2
> >              BGP 100                      BGP200
> >
> >BGP neighbors relationship stay in  Open State,  they never establish the
> >full TCP connection.  The Nat translation is breaking my TCP connections
> for
> >BGP neighbor.  When I remove Nat Bgp neighbors between R1 and R2 get
> >established.  I have been trying any possible configuration for Nat but
> keep
> >breaking my TCP connections needed for BGP.  Has somebody face this
problem
> >before?
> >
> >
> >Thanks
> >
> >Antonio
> >
> >
> >--
> >
> >
> >
> >
> >__________________________________________________________________
> >Your favorite stores, helpful shopping tools and great gift ideas.
> >Experience the convenience of buying online with Shop@xxxxxxxx!
> >http://shopnow.netscape.com/
> >
> >Get your own FREE, personal Netscape Mail account today at
> >http://webmail.netscape.com/
> >_________________________________________________________________
> >CCIE Security list: http://www.groupstudy.com/list/security.html
> >_________________________________________________________________
> >CCIE Security list: http://www.groupstudy.com/list/security.html
> --
>
>
>
>
> __________________________________________________________________
> Your favorite stores, helpful shopping tools and great gift ideas.
> Experience the convenience of buying online with Shop@xxxxxxxx!
> http://shopnow.netscape.com/
>
> Get your own FREE, personal Netscape Mail account today at
> http://webmail.netscape.com/
> _________________________________________________________________
> CCIE Security list: http://www.groupstudy.com/list/security.html
_________________________________________________________________
CCIE Security list: http://www.groupstudy.com/list/security.html
__________________________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab