GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: Another Redistribution Question posted 12/04/2001
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


IGRP and EIGRP will perform automatic redistribution only when they share
the same AS number.  All other protocols must be manually configured to
redistribute their routes.  Try your example again using IGRP 12 and EIGRP
12.

r1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
I    3.0.0.0/8 [100/10976] via 10.10.10.2, 00:00:02, Serial0.1
     10.0.0.0/30 is subnetted, 3 subnets
I       10.10.10.8 [100/8576] via 10.10.10.2, 00:00:02, Serial0.1
C       10.10.10.0 is directly connected, Serial0.1
I       10.10.10.4 [100/10476] via 10.10.10.2, 00:00:02, Serial0.1
r1#

Xyplex -012- LAB:6 session 3 resumed

r2#sh ip pro
Routing Protocol is "ospf 6"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 6.6.6.6
  It is an area border router
  Number of areas in this router is 2. 2 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    2.2.2.2 0.0.0.0 area 2
    10.10.10.8 0.0.0.3 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    6.6.6.6              110      00:06:12
    216.248.176.253      110      00:06:12
  Distance: (default is 110)

Routing Protocol is "igrp 12"
  Sending updates every 90 seconds, next due in 51 seconds
  Invalid after 270 seconds, hold down 280, flushed after 630
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  IGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  IGRP maximum hopcount 100
  IGRP maximum metric variance 1
  Redistributing: igrp 12, eigrp 12
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
  Passive Interface(s):
    Ethernet0
    Serial0.3
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.10.10.1           100      00:00:53
  Distance: (default is 100)

Routing Protocol is "eigrp 12"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: igrp 12, eigrp 12
  Automatic network summarization is not in effect
  Maximum path: 4
  Routing for Networks:
    10.10.10.4/30
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.10.10.5            90      00:05:07
  Distance: internal 90 external 170

r2#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

I    1.0.0.0/8 [100/8976] via 10.10.10.1, 00:00:27, Serial0.1
     2.0.0.0/32 is subnetted, 1 subnets
C       2.2.2.2 is directly connected, Loopback0
     3.0.0.0/32 is subnetted, 1 subnets
D       3.3.3.3 [90/2297856] via 10.10.10.5, 00:01:51, Serial0.3
     4.0.0.0/32 is subnetted, 1 subnets
O IA    4.4.4.4 [110/11] via 10.10.10.10, 00:02:59, Ethernet0
     10.0.0.0/30 is subnetted, 3 subnets
C       10.10.10.8 is directly connected, Ethernet0
C       10.10.10.0 is directly connected, Serial0.1
C       10.10.10.4 is directly connected, Serial0.3
r2#

Xyplex -012- LAB:5 session 2 resumed

r3#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

D EX 1.0.0.0/8 [170/2809856] via 10.10.10.6, 00:01:43, Serial0.1
     3.0.0.0/32 is subnetted, 1 subnets
C       3.3.3.3 is directly connected, Loopback0
     10.0.0.0/30 is subnetted, 3 subnets
D EX    10.10.10.8 [170/2195456] via 10.10.10.6, 00:01:43, Serial0.1
D EX    10.10.10.0 [170/2681856] via 10.10.10.6, 00:01:43, Serial0.1
C       10.10.10.4 is directly connected, Serial0.1
r3#

Xyplex -012- LAB:7 session 4 resumed

r4#sh ip pro
Routing Protocol is "ospf 7"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 216.248.176.253
  It is an area border router
  Number of areas in this router is 2. 2 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
    4.4.4.4 0.0.0.0 area 4
    10.10.10.8 0.0.0.3 area 0
  Routing Information Sources:
    Gateway         Distance      Last Update
    6.6.6.6              110      00:06:18
    216.248.176.253      110      00:06:18
  Distance: (default is 110)

r4#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     2.0.0.0/32 is subnetted, 1 subnets
O IA    2.2.2.2 [110/11] via 10.10.10.9, 00:04:49, Ethernet0
     4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback0
     10.0.0.0/30 is subnetted, 1 subnets
C       10.10.10.8 is directly connected, Ethernet0
r4#


Stephen Feldberg
e ^ deltacom
phone: 678.835.5437
sfeldberg@xxxxxxxxxxxxx


                                                                                                                   
                    "Michael                                                                                       
                    Brady"               To:     <ccielab@xxxxxxxxxxxxxx>                                          
                    <cisco@xxxxxxx       cc:                                                                       
                    om>                  Subject:     Another Redistribution Question                              
                    Sent by:                                                                                       
                    nobody@xxxxxxx                                                                                 
                    udy.com                                                                                        
                                                                                                                   
                                                                                                                   
                    12/03/2001                                                                                     
                    11:31 PM                                                                                       
                    Please respond                                                                                 
                    to "Michael                                                                                    
                    Brady"                                                                                         
                                                                                                                   
                                                                                                                   




I have a question regarding redistribution.  I've searched the archives,
and
I can't find
what I'm looking for.  I have a simple network like the one below.  We will
say that the
connections between R1, R2 & R3 are serial connections and R2 & R4 is
ethernet.  The
network between R1 and R2 and a loopback on R1 is in IGRP 12, the network
between
R2 and R3 and a loopback on R3 is in EIGRP 23, and the network between R2
and R4
a loopback on each are running OSPF.  On R2, I redistribute between IGRP
and
OSPF,
and between OSPF and EIGRP (not EIGRP and IGRP).  My question is why don't
the
EIGRP routes show up on R1, and the IGRP routes on R3?  I only see the OSPF
routes.
If I look at the OSPF database on R2, I see all of the routes.  I would
think that since R2
has the routes in its OSPF database, they would be redistributed into the
other protocols.
Do I have to redistribute between EIGRP and IGRP too for this to work?  Is
this supposed
to work this way, or am I missing something?  Any assistance understanding
this would
be greatly appreciated.

Thanks!
Michael


R1-------R2-------R3
             |
           R4


CONFIGS:
R1
hostname R1
!
no ip domain-lookup
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0
 no ip address
 shutdown
!
interface Serial0
 no ip address
 shutdown
!
interface Serial1
 ip address 12.12.12.1 255.255.255.0
 clockrate 64000
!
router igrp 12
 network 1.0.0.0
 network 12.0.0.0
!
line con 0
line aux 0
line vty 0 4
 login
!
end

R2
hostname R2
!
no ip domain-lookup
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0
 ip address 24.24.24.2 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 ip address 23.23.23.2 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
 clockrate 64000
!
interface Serial1
 ip address 12.12.12.2 255.255.255.0
 no ip directed-broadcast
!
router eigrp 23
 redistribute ospf 1 metric 64000 100 255 1 1500
 network 23.0.0.0
!
router ospf 1
 redistribute eigrp 23 metric 20 subnets
 redistribute igrp 12 metric 20 subnets
 network 2.2.2.2 0.0.0.0 area 2
 network 24.24.24.0 0.0.0.255 area 0
!
router igrp 12
 redistribute ospf 1 metric 64000 100 255 1 1500
 network 12.0.0.0
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

R3
hostname R3
!
no ip domain-lookup
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
 no ip directed-broadcast
!
interface Serial0
 ip address 23.23.23.3 255.255.255.0
 no ip directed-broadcast
 no ip mroute-cache
!
router eigrp 23
 network 3.0.0.0
 network 23.0.0.0
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end

R4
hostname R4
!
no ip domain-lookup
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
 no ip directed-broadcast
 ip ospf network point-to-point
!
interface Ethernet0
 ip address 24.24.24.4 255.255.255.0
 no ip directed-broadcast
!
router ospf 1
 network 4.4.4.4 0.0.0.0 area 1
 network 24.24.24.0 0.0.0.255 area 0
!
line con 0
 transport input none
line aux 0
line vty 0 4
!
end
__________________________________________________________________
Trouble posting? Read: http://www.groupstudy.com/list/posting.html
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab