GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Mystery of BGP Backdoor posted 09/27/2001
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hi Group,

Has anyone successfully test the Jeff Doyle's BGP backdoor case study?  Routing TCP/IP IIPage 234

I set up the lab  and tested his configuration, it doesn't work.

After discussion with my study mate, I used Eigrp instead of rip between Meribel and Lillehammer.  Guess what, it workes.

Then I turned on bgp auto summary, the backdoor command only work on Lillehammer router not Meribel.  I tried different things, turned off bgp auto summary,used network command instead of redistriburion, reload the router, couldn't get work any more.

Did I missed something, 

here is my config

Daniel

==============================================================================

Meribel#sh run


!
interface Loopback0
 ip address 10.50.250.1 255.255.255.255
!
interface Loopback1
 ip address 172.17.0.1 255.255.0.0 secondary
 ip address 10.20.0.1 255.255.0.0
!
interface Loopback3
 ip address 172.29.2.1 255.255.255.0
!
interface Loopback4
 ip address 192.168.50.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.0.1 255.255.255.0
 duplex auto
 speed auto
!
!
interface Serial0/1
 bandwidth 64
 ip address 192.168.1.1 255.255.255.0
!
router eigrp 100
 network 10.20.0.0 0.0.255.255
 network 172.17.0.0
 network 172.29.2.0 0.0.0.255
 network 192.168.1.0
 network 192.168.50.0
 auto-summary
 no eigrp log-neighbor-changes
!
router bgp 50
 bgp log-neighbor-changes
 network 172.18.0.0 backdoor
 redistribute eigrp 100
 neighbor 10.75.100.1 remote-as 75
 neighbor 10.75.100.1 ebgp-multihop 2
 neighbor 10.75.100.1 update-source Loopback0
 neighbor 10.100.83.1 remote-as 100
 neighbor 10.100.83.1 ebgp-multihop 2
 neighbor 10.100.83.1 update-source Loopback0
 neighbor 10.200.60.1 remote-as 200
 neighbor 10.200.60.1 ebgp-multihop 2
 neighbor 10.200.60.1 update-source Loopback0
 no auto-summary
!
ip kerberos source-interface any
ip classless
ip route 10.75.100.1 255.255.255.255 FastEthernet0/0
ip route 10.100.83.1 255.255.255.255 FastEthernet0/0
ip route 10.200.60.1 255.255.255.255 FastEthernet0/0
no ip http server
!

end

Meribel#
Meribel#sh ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

B    192.168.75.0/24 [20/0] via 10.75.100.1, 00:06:24
C    172.17.0.0/16 is directly connected, Loopback1
D    172.18.0.0/16 [90/40640000] via 192.168.1.2, 00:01:49, Serial0/1
     172.29.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.29.0.0/16 is a summary, 00:09:28, Null0
C       172.29.2.0/24 is directly connected, Loopback3
     10.0.0.0/8 is variably subnetted, 6 subnets, 3 masks
D       10.0.0.0/8 is a summary, 00:09:28, Null0
C       10.20.0.0/16 is directly connected, Loopback1
S       10.75.100.1/32 is directly connected, FastEthernet0/0
S       10.100.83.1/32 is directly connected, FastEthernet0/0
C       10.50.250.1/32 is directly connected, Loopback0
S       10.200.60.1/32 is directly connected, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/0
C    192.168.50.0/24 is directly connected, Loopback4
C    192.168.1.0/24 is directly connected, Serial0/1
Meribel#

==============================================================================
Lillehammer#sh run

!
!
interface Loopback0
 ip address 10.75.100.1 255.255.255.255
!
interface Loopback1
 ip address 172.18.0.1 255.255.0.0
!
interface Loopback2
 ip address 192.168.75.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Serial0/1
 bandwidth 64
 ip address 192.168.1.2 255.255.255.0
 clockrate 64000
!
router eigrp 100
 network 172.18.0.0
 network 192.168.1.0
 network 192.168.75.0
 auto-summary
 no eigrp log-neighbor-changes
!
router bgp 75
 bgp log-neighbor-changes
 network 172.17.0.0 backdoor
 network 172.18.0.0
 network 192.168.75.0
 neighbor 10.50.250.1 remote-as 50
 neighbor 10.50.250.1 ebgp-multihop 2
 neighbor 10.50.250.1 update-source Loopback0
 neighbor 10.100.83.1 remote-as 100
 neighbor 10.100.83.1 ebgp-multihop 2
 neighbor 10.100.83.1 update-source Loopback0
 neighbor 10.200.60.1 remote-as 200
 neighbor 10.200.60.1 ebgp-multihop 2
 neighbor 10.200.60.1 update-source Loopback0
 no auto-summary
!
ip classless
ip route 10.50.250.1 255.255.255.255 FastEthernet0/0
ip route 10.100.83.1 255.255.255.255 FastEthernet0/0
ip route 10.200.60.1 255.255.255.255 FastEthernet0/0
ip http server
!
!
end

Lillehammer#
Lillehammer#sh ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.75.0/24 is directly connected, Loopback2
B    172.17.0.0/16 [20/0] via 10.50.250.1, 00:06:15
C    172.18.0.0/16 is directly connected, Loopback1
B    172.29.0.0/16 [20/0] via 10.50.250.1, 00:05:47
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
B       10.0.0.0/8 [20/0] via 10.50.250.1, 00:05:47
C       10.75.100.1/32 is directly connected, Loopback0
S       10.100.83.1/32 is directly connected, FastEthernet0/0
S       10.50.250.1/32 is directly connected, FastEthernet0/0
S       10.200.60.1/32 is directly connected, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/0
B    192.168.50.0/24 [20/0] via 10.50.250.1, 00:05:18
C    192.168.1.0/24 is directly connected, Serial0/1
Lillehammer#



=============================================================================

stoped working -- turned on  auto summary 


tried --- without any luck
turned off auto summary again 
used network command instead of  eigrp redistribution 
relaod the router
                                        

=============================================================================

Meribel#sh run
Building configuration...

Current configuration : 2212 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Meribel
!
logging rate-limit console 10 except errors
enable password cisco
!
memory-size iomem 10
ip subnet-zero
!
!
no ip finger
no ip domain-lookup
!
call rsvp-sync
cns event-service server
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 10.50.250.1 255.255.255.255
!
interface Loopback1
 ip address 172.17.0.1 255.255.0.0 secondary
 ip address 10.20.0.1 255.255.0.0
!
interface Loopback3
 ip address 172.29.2.1 255.255.255.0
!
interface Loopback4
 ip address 192.168.50.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.0.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface BRI0/0
 no ip address
 shutdown
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/1
 bandwidth 64
 ip address 192.168.1.1 255.255.255.0
!
router eigrp 100
 network 10.20.0.0 0.0.255.255
 network 172.17.0.0
 network 172.29.2.0 0.0.0.255
 network 192.168.1.0
 network 192.168.50.0
 no auto-summary
 no eigrp log-neighbor-changes
!
router bgp 50
 bgp log-neighbor-changes
 network 10.20.0.0 mask 255.255.0.0
 network 172.17.0.0
 network 172.18.0.0 backdoor
 network 172.29.2.0 mask 255.255.255.0
 network 192.168.50.0
 neighbor 10.75.100.1 remote-as 75
 neighbor 10.75.100.1 ebgp-multihop 2
 neighbor 10.75.100.1 update-source Loopback0
 neighbor 10.100.83.1 remote-as 100
 neighbor 10.100.83.1 ebgp-multihop 2
 neighbor 10.100.83.1 update-source Loopback0
 neighbor 10.200.60.1 remote-as 200
 neighbor 10.200.60.1 ebgp-multihop 2
 neighbor 10.200.60.1 update-source Loopback0
 no auto-summary
!
ip kerberos source-interface any
ip classless
ip route 10.75.100.1 255.255.255.255 FastEthernet0/0
ip route 10.100.83.1 255.255.255.255 FastEthernet0/0
ip route 10.200.60.1 255.255.255.255 FastEthernet0/0
no ip http server
!
!
!
voice-port 3/0/0
!
voice-port 3/0/1
!
voice-port 3/1/0
!
voice-port 3/1/1
!
dial-peer cor custom
!
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
 transport input none
line aux 0
line vty 0 4
 password cisco
 login
!
end

Meribel# sh ip bgp
BGP table version is 7, local router ID is 192.168.50.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.20.0.0/16     0.0.0.0                  0         32768 i
*> 172.17.0.0       0.0.0.0                  0         32768 i
*  172.18.0.0       10.200.60.1                            0 200 75 i
*                   10.100.83.1                            0 100 75 i
*>                  10.75.100.1              0             0 75 i
*> 172.29.2.0/24    0.0.0.0                  0         32768 i
*> 192.168.50.0     0.0.0.0                  0         32768 i
*  192.168.75.0     10.100.83.1                            0 100 75 i
*                   10.200.60.1                            0 200 75 i
*>                  10.75.100.1              0             0 75 i
Meribel#sh ip rout
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

B    192.168.75.0/24 [20/0] via 10.75.100.1, 00:10:32
C    172.17.0.0/16 is directly connected, Loopback1
B    172.18.0.0/16 [20/0] via 10.75.100.1, 00:02:27
     172.29.0.0/24 is subnetted, 1 subnets
C       172.29.2.0 is directly connected, Loopback3
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
C       10.20.0.0/16 is directly connected, Loopback1
S       10.75.100.1/32 is directly connected, FastEthernet0/0
S       10.100.83.1/32 is directly connected, FastEthernet0/0
C       10.50.250.1/32 is directly connected, Loopback0
S       10.200.60.1/32 is directly connected, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/0
C    192.168.50.0/24 is directly connected, Loopback4
C    192.168.1.0/24 is directly connected, Serial0/1


Meribel#
Meribel#sh ip eig to
IP-EIGRP Topology Table for AS(100)/ID(192.168.50.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.20.0.0/16, 1 successors, FD is 128256
         via Connected, Loopback1
P 192.168.75.0/24, 0 successors, FD is Inaccessible
         via 192.168.1.2 (40640000/128256), Serial0/1
P 192.168.50.0/24, 1 successors, FD is 128256
         via Connected, Loopback4
P 192.168.1.0/24, 1 successors, FD is 40512000
         via Connected, Serial0/1
P 172.29.2.0/24, 1 successors, FD is 128256
         via Connected, Loopback3
P 172.17.0.0/16, 1 successors, FD is 128256
         via Connected, Loopback1
P 172.18.0.0/16, 0 successors, FD is Inaccessible
         via 192.168.1.2 (40640000/128256), Serial0/1
Meribel#

======================================================================================
Lillehammer#sh run
Building configuration...

Current configuration : 1573 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Lillehammer
!
enable password cisco
!
!
!
!
!
memory-size iomem 15
ip subnet-zero
no ip domain-lookup
!
!
!
!
!
!
interface Loopback0
 ip address 10.75.100.1 255.255.255.255
!
interface Loopback1
 ip address 172.18.0.1 255.255.0.0
!
interface Loopback2
 ip address 192.168.75.1 255.255.255.0
!
interface FastEthernet0/0
 ip address 192.168.0.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 no ip address
 shutdown
 no fair-queue
!
interface Serial0/1
 bandwidth 64
 ip address 192.168.1.2 255.255.255.0
 clockrate 64000
!
router eigrp 100
 network 172.18.0.0
 network 192.168.1.0
 network 192.168.75.0
 no auto-summary
 no eigrp log-neighbor-changes
!
router bgp 75
 bgp log-neighbor-changes
 network 172.17.0.0 backdoor
 network 172.18.0.0
 network 192.168.75.0
 neighbor 10.50.250.1 remote-as 50
 neighbor 10.50.250.1 ebgp-multihop 2
 neighbor 10.50.250.1 update-source Loopback0
 neighbor 10.100.83.1 remote-as 100
 neighbor 10.100.83.1 ebgp-multihop 2
 neighbor 10.100.83.1 update-source Loopback0
 neighbor 10.200.60.1 remote-as 200
 neighbor 10.200.60.1 ebgp-multihop 2
 neighbor 10.200.60.1 update-source Loopback0
 no auto-summary
!
ip classless
ip route 10.50.250.1 255.255.255.255 FastEthernet0/0
ip route 10.100.83.1 255.255.255.255 FastEthernet0/0
ip route 10.200.60.1 255.255.255.255 FastEthernet0/0
ip http server
!
!
!
line con 0
 exec-timeout 0 0
 logging synchronous
line aux 0
line vty 0 4
 password cisco
 login
!
end

Lillehammer# sh ip bgp
BGP table version is 85, local router ID is 192.168.75.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*  10.20.0.0/16     10.200.60.1                            0 200 50 i
*                   10.100.83.1                            0 100 50 i
*>                  10.50.250.1              0             0 50 i
*  172.17.0.0       10.200.60.1                            0 200 50 i
*                   10.100.83.1                            0 100 50 i
*>                  10.50.250.1              0             0 50 i
*> 172.18.0.0       0.0.0.0                  0         32768 i
*  172.29.2.0/24    10.200.60.1                            0 200 50 i
*                   10.100.83.1                            0 100 50 i
*>                  10.50.250.1              0             0 50 i
*  192.168.50.0     10.200.60.1                            0 200 50 i
*                   10.100.83.1                            0 100 50 i
*>                  10.50.250.1              0             0 50 i
*> 192.168.75.0     0.0.0.0                  0         32768 i


Lillehammer#sh ip eigr to
IP-EIGRP Topology Table for AS(100)/ID(192.168.75.1)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.20.0.0/16, 0 successors, FD is Inaccessible
         via 192.168.1.1 (40640000/128256), Serial0/1
P 192.168.75.0/24, 1 successors, FD is 128256
         via Connected, Loopback2
P 192.168.50.0/24, 0 successors, FD is Inaccessible
         via 192.168.1.1 (40640000/128256), Serial0/1
P 192.168.1.0/24, 1 successors, FD is 40512000
         via Connected, Serial0/1
P 172.29.2.0/24, 0 successors, FD is Inaccessible
         via 192.168.1.1 (40640000/128256), Serial0/1
P 172.17.0.0/16, 1 successors, FD is 40640000
         via 192.168.1.1 (40640000/128256), Serial0/1
P 172.18.0.0/16, 1 successors, FD is 128256
         via Connected, Loopback1

Lillehammer#sh ip rout
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

C    192.168.75.0/24 is directly connected, Loopback2
D    172.17.0.0/16 [90/40640000] via 192.168.1.1, 00:16:51, Serial0/1
C    172.18.0.0/16 is directly connected, Loopback1
     172.29.0.0/24 is subnetted, 1 subnets
B       172.29.2.0 [20/0] via 10.50.250.1, 00:11:54
     10.0.0.0/8 is variably subnetted, 5 subnets, 2 masks
B       10.20.0.0/16 [20/0] via 10.50.250.1, 00:11:54
C       10.75.100.1/32 is directly connected, Loopback0
S       10.100.83.1/32 is directly connected, FastEthernet0/0
S       10.50.250.1/32 is directly connected, FastEthernet0/0
S       10.200.60.1/32 is directly connected, FastEthernet0/0
C    192.168.0.0/24 is directly connected, FastEthernet0/0
B    192.168.50.0/24 [20/0] via 10.50.250.1, 00:07:10
C    192.168.1.0/24 is directly connected, Serial0/1
Lillehammer#
**Please read:http://www.groupstudy.com/list/posting.html
_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab