GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: bridging between serial and ethernet posted 09/25/2001
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Got me there Mark ;-)! But the ECP question he was working on here is meant to be solved with IRB. The IP address isn't only
for management.

Cheers,

Greg

Greg Schmitt, CCIE #8105

Internetwork Solutions Engineer
ThruPoint, Inc.
Voice: 410-349-9772
Cell:  443-822-5183
Pager: 888-773-0423 or pager.gschmitt@xxxxxxxxxxxxx
e-mail: GSchmitt@xxxxxxxxxxxxx



-----Original Message-----
From: Beck, Mark [mailto:Mark.Beck@xxxxxxxxxxxxx]
Sent: Tuesday, September 25, 2001 5:13 AM
To: Schmitt, Greg; kym blair; Brian.Diehm@xxxxxxxxxx;
ccielab@xxxxxxxxxxxxxx
Subject: RE: bridging between serial and ethernet


Normally when using no ip routing, I would configure the same IP address
on each interface that needed to be managed.  Both configs look ok - but
I would test them first before given my seal of approval ;p

Incidently you never seen a ethernet switch with an ip addresses on it?

Thanks,
Mark Beck
CCIE:6906



> -----Original Message-----
> From: Schmitt, Greg [mailto:gschmitt@xxxxxxxxxxxxx]
> Sent: 24 September 2001 18:08
> To: 'kym blair'; Brian.Diehm@xxxxxxxxxx; ccielab@xxxxxxxxxxxxxx
> Subject: RE: bridging between serial and ethernet
>
>
> Kym,
>
> Your first example should work fine, but the second will not
> bridge. An IP bridged interface cannot have an IP address
> assigned to it. This makes sense because you are treating the
> router as a bridge, and bridges do not have layer 3 addresses.
>
> Cheers,
>
> Greg
>
> Greg Schmitt, CCIE #8105
>
> Internetwork Solutions Engineer
> ThruPoint, Inc.
> Voice: 410-349-9772
> Cell:  443-822-5183
> Pager: 888-773-0423 or pager.gschmitt@xxxxxxxxxxxxx
> e-mail: GSchmitt@xxxxxxxxxxxxx
>
>
>
> -----Original Message-----
> From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
> kym blair
> Sent: Monday, September 24, 2001 7:32 AM
> To: Brian.Diehm@xxxxxxxxxx; ccielab@xxxxxxxxxxxxxx
> Subject: Re: bridging between serial and ethernet
>
>
> Brian,
>
> You have two choices:
>
> 1) IRB (in which case you need interface BVI2 to handle the routing)
>
> bridge irb
> !
> bridge 2 protocol ieee
>   bridge 2 route ip
> !
> int BVI2
>   ip address 192.168.7.1 255.255.255.0
> !
> interface Ethernet3/0
>   no ip address
>   bridge-group 2
> !
> interface Serial4/0
>   no ip address
>   encapsulation frame-relay
>   clockrate 56000
>   frame-relay map bridge 201 broadcast
>   bridge-group 2
>
> 2) Transparent Bridging (without routing capability)
>
> no ip routing
> !
> bridge 2 protocol ieee
> !
> interface Ethernet3/0
>   ip address 192.168.7.1 255.255.255.0
>   bridge-group 2
> !
> interface Serial4/0
>   ip unnumbered Ethernet 0
>   encapsulation frame-relay
>   clockrate 56000
>   frame-relay map bridge 201 broadcast
>   bridge-group 2
> !
> ip default-gateway 192.168.7.2
>
> Kym
>
>
> >From: "Diehm, Brian" <Brian.Diehm@xxxxxxxxxx>
> >Reply-To: "Diehm, Brian" <Brian.Diehm@xxxxxxxxxx>
> >To: "Ccielab (E-mail)" <ccielab@xxxxxxxxxxxxxx>
> >Subject: bridging between serial and ethernet
> >Date: Sun, 23 Sep 2001 17:15:09 -0500
> >
> >I have been working on ECP1 exercise 7.  I have set up
> bridging on most
> >of my routers.  I am trying to get the router to bridge
> between a serial
> >and ethernet port.  What I see is that the packets are reaching the
> >Ethernet interface but the refuse to leave the serial interface.  Any
> >ideas on what could be causing this?
> >
> >r2#sh bridge
> >
> >Total of 300 station blocks, 296 free
> >Codes: P - permanent, S - self
> >
> >Bridge Group 2:
> >
> >     Address       Action   Interface       Age   RX count   TX count
> >0010.7b38.5fc4   forward   Serial4/0         0          1          0
> >0010.7bec.8420   forward   Ethernet3/0       1        107          0
> >0002.4b03.0ba1   forward   Serial4/0         0         37          0
> >0000.8107.ac7c   forward   Ethernet3/0       0        272          0
> >
> >
> >
> >
> >
> >hostname r2
> >!
> >!
> >ip subnet-zero
> >no ip finger
> >!
> >ip audit notify log
> >ip audit po max-events 100
> >!
> >!
> >bridge irb
> >!
> >!
> >interface Ethernet3/0
> >  no ip address
> >  bridge-group 2
> >!
> >interface Serial4/0
> >  no ip address
> >  encapsulation frame-relay
> >  clockrate 56000
> >  frame-relay map bridge 201 broadcast
> >  bridge-group 2
> >!
> >ip classless
> >no ip http server
> >!
> >!
> >bridge 2 protocol ieee
> >
> >
> >r2#sh int irb
> >
> >Ethernet3/0
> >
> >  Bridged protocols on Ethernet3/0:
> >   appletalk  clns       decnet     ip
> >   vines      apollo     ipx        xns
> >
> >  Software MAC address filter on Ethernet3/0
> >   Hash Len    Address      Matches  Act      Type
> >   0x00:  0 ffff.ffff.ffff       247 RCV Physical broadcast
> >   0x25:  0 0030.717d.8854         0 RCV Interface MAC address
> >   0x2A:  0 0900.2b01.0001         0 RCV DEC spanning tree
> >   0xC0:  0 0100.0ccc.cccc        28 RCV CDP
> >   0xC2:  0 0180.c200.0000        86 RCV IEEE spanning tree
> >   0xC2:  1 0180.c200.0000         0 RCV IBM spanning tree
> >   0xC2:  2 0100.0ccd.cdce         0 RCV VLAN Bridge STP
> >
> >Serial4/0
> >
> >  Bridged protocols on Serial4/0:
> >   appletalk  clns       decnet     ip
> >   vines      apollo     ipx        xns
> >
> >  Software MAC address filter on Serial4/0
> >   Hash Len    Address      Matches  Act      Type
> >   0x00:  0 ffff.ffff.ffff         0 RCV Physical broadcast
> >   0x2A:  0 0900.2b01.0001         0 RCV DEC spanning tree
> >   0x71:  0 0030.717d.8800         0 RCV Interface MAC address
> >   0xC2:  0 0180.c200.0000         0 RCV IEEE spanning tree
> >   0xC2:  1 0180.c200.0000         0 RCV IBM spanning tree
> >   0xC2:  2 0100.0ccd.cdce         0 RCV VLAN Bridge STP
> >
> >r2#sh spanning-tree
> >
> >  Bridge group 2 is executing the IEEE compatible Spanning
> Tree protocol
> >   Bridge Identifier has priority 32768, address 0030.717d.8854
> >   Configured hello time 2, max age 20, forward delay 15
> >   We are the root of the spanning tree
> >   Port Number size is 12
> >   Topology change flag not set, detected flag not set
> >   Times:  hold 1, topology change 35, notification 2
> >           hello 2, max age 20, forward delay 15
> >   Timers: hello 0, topology change 0, notification 0
> >   bridge aging time 300
> >
> >Port 6 (Ethernet3/0) of Bridge group 2 is forwarding
> >    Port path cost 100, Port priority 128
> >    Designated root has priority 32768, address 0030.717d.8854
> >    Designated bridge has priority 32768, address 0030.717d.8854
> >    Designated port is 6, path cost 0
> >    Timers: message age 0, forward delay 0, hold 0
> >    BPDU: sent 2, received 86
> >
> >Port 14 (Serial4/0 Frame Relay) of Bridge group 2 is forwarding
> >    Port path cost 488, Port priority 128
> >    Designated root has priority 32768, address 0030.717d.8854
> >    Designated bridge has priority 32768, address 0030.717d.8854
> >    Designated port is 14, path cost 0
> >    Timers: message age 0, forward delay 0, hold 0
> >    BPDU: sent 0, received 0
> >
> >
> >
> >Brian D
> >**Please read:http://www.groupstudy.com/list/posting.html
> _________________________________________________________________
> Get your FREE download of MSN Explorer at
> http://explorer.msn.com/intl.asp
> **Please read:http://www.groupstudy.com/list/posting.html
> **Please read:http://www.groupstudy.com/list/posting.html

[GroupStudy.com removed an attachment of type application/ms-tnef which had a name of winmail.dat]
**Please read:http://www.groupstudy.com/list/posting.html
_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab