GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: OSPF summarizing IA routes posted 09/21/2001
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


okay, I made a mistake in the area range command - I used the wrong area.
with the correct area range command, this is what I get

(on R4)
router ospf 1
 area 0 authentication
 area 1 virtual-link 212.1.22.33
 area 4 range 200.100.100.0 255.255.255.0  ! made this correction
 area 10 authentication message-digest
 network 172.17.1.0 0.0.0.255 area 10
 network 200.100.100.16 0.0.0.7 area 4
 network 212.1.22.0 0.0.0.15 area 0
 network 212.1.22.64 0.0.0.63 area 1

termsrv#sh ip ro
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is 24.21.8.193 to network 0.0.0.0

     1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback100
     20.0.0.0/16 is subnetted, 1 subnets
O IA    20.20.0.0 [110/1792] via 172.17.1.1, 01:32:30, Serial0
     200.100.100.0/24 is variably subnetted, 3 subnets, 3 masks
O IA    200.100.100.8/29 [110/2655] via 172.17.1.1, 01:32:30, Serial0
O IA    200.100.100.0/24 [110/1786] via 172.17.1.1, 00:03:36, Serial0  !
got this change
O IA    200.100.100.1/32 [110/2655] via 172.17.1.1, 01:32:30, Serial0
     172.17.0.0/24 is subnetted, 3 subnets
C       172.17.50.0 is directly connected, Loopback0
S       172.17.4.0 is directly connected, Null0
C       172.17.1.0 is directly connected, Serial0
     24.0.0.0/26 is subnetted, 1 subnets
C       24.21.8.192 is directly connected, Ethernet0
     192.168.1.0/32 is subnetted, 1 subnets
C       192.168.1.2 is directly connected, Loopback101
     212.1.22.0/24 is variably subnetted, 3 subnets, 3 masks
O IA    212.1.22.64/26 [110/1791] via 172.17.1.1, 01:32:30, Serial0
O IA    212.1.22.0/28 [110/2654] via 172.17.1.1, 01:32:30, Serial0
O IA    212.1.22.33/32 [110/1792] via 172.17.1.1, 01:32:30, Serial0
S*   0.0.0.0/0 [1/0] via 24.21.8.193

----- Original Message -----
From: "routerjocky" <elouie@xxxxxxxxx>
To: <ccielab@xxxxxxxxxxxxxx>
Sent: Friday, September 21, 2001 10:33 AM
Subject: OSPF summarizing IA routes


> I haven't thought about it fully yet, but I'm wondering...how would one
> summarize a bunch of Inter-Area routes in OSPF?  Using a different routing
> protocol is not the solution I'm looking for (unless it's the only way)
>
> I've extended FatKid 401 to add another router off R4's serial interface
in
> area 10.  Without realizing that 200.100.100.0/24 is in 3 different areas,
I
> config'ed an area 0 range command, and that didn't work.  No time to think
> about it now, so I figured I'd toss it out there for you guru's to help me
> with it.   Nothing comes to mind right off the bat.
>
> Thoughts from anyone who's tried this and succeeded?  or failed?  ;-)
>
> -e-
>
> from R4:
> router ospf 1
>  area 0 authentication
>  area 0 range 200.100.100.0 255.255.255.0
>  area 1 virtual-link 212.1.22.33
>  area 10 authentication message-digest
>  network 172.17.1.0 0.0.0.255 area 10
>  network 200.100.100.16 0.0.0.7 area 4
>  network 212.1.22.0 0.0.0.15 area 0
>  network 212.1.22.64 0.0.0.63 area 1
>
> R4# sh ip ro
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
>        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
>        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
> area
>        * - candidate default, U - per-user static route, o - ODR
>        P - periodic downloaded static route
>
> Gateway of last resort is 172.17.1.2 to network 0.0.0.0
>
>      20.0.0.0/16 is subnetted, 1 subnets
> O IA    20.20.0.0 [110/7] via 212.1.22.66, 00:15:06, TokenRing0
>      200.100.100.0/24 is variably subnetted, 3 subnets, 2 masks
> O IA    200.100.100.8/29 [110/870] via 212.1.22.2, 00:15:06, Serial4
> O IA    200.100.100.1/32 [110/870] via 212.1.22.1, 00:15:06, Serial4
> C       200.100.100.16/29 is directly connected, Loopback0
>      172.17.0.0/24 is subnetted, 1 subnets
> C       172.17.1.0 is directly connected, Serial5
>      212.1.22.0/24 is variably subnetted, 3 subnets, 3 masks
> C       212.1.22.64/26 is directly connected, TokenRing0
> C       212.1.22.0/28 is directly connected, Serial4
> O IA    212.1.22.33/32 [110/7] via 212.1.22.66, 00:15:07, TokenRing0
> O*E1 0.0.0.0/0 [110/1786] via 172.17.1.2, 00:15:07, Serial5
> R4#
>
> on the other side of the serial link:
>
> termsrv#sh ip ro
> Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
>        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
>        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
> area
>        * - candidate default, U - per-user static route, o - ODR
>        P - periodic downloaded static route
>
> Gateway of last resort is 24.21.8.193 to network 0.0.0.0
>
>      1.0.0.0/32 is subnetted, 1 subnets
> C       1.1.1.1 is directly connected, Loopback100
>      20.0.0.0/16 is subnetted, 1 subnets
> O IA    20.20.0.0 [110/1792] via 172.17.1.1, 00:03:19, Serial0
>      200.100.100.0/24 is variably subnetted, 3 subnets, 2 masks
> O IA    200.100.100.8/29 [110/2655] via 172.17.1.1, 00:03:19, Serial0
> O IA    200.100.100.1/32 [110/2655] via 172.17.1.1, 00:03:19, Serial0
> O IA    200.100.100.16/29 [110/1786] via 172.17.1.1, 00:03:19, Serial0
>      172.17.0.0/24 is subnetted, 3 subnets
> C       172.17.50.0 is directly connected, Loopback0
> S       172.17.4.0 is directly connected, Null0
> C       172.17.1.0 is directly connected, Serial0
>      24.0.0.0/26 is subnetted, 1 subnets
> C       24.21.8.192 is directly connected, Ethernet0
>      192.168.1.0/32 is subnetted, 1 subnets
> C       192.168.1.2 is directly connected, Loopback101
>      212.1.22.0/24 is variably subnetted, 3 subnets, 3 masks
> O IA    212.1.22.64/26 [110/1791] via 172.17.1.1, 00:03:21, Serial0
> O IA    212.1.22.0/28 [110/2654] via 172.17.1.1, 00:03:21, Serial0
> O IA    212.1.22.33/32 [110/1792] via 172.17.1.1, 00:03:21, Serial0
> S*   0.0.0.0/0 [1/0] via 24.21.8.193
> termsrv#
> **Please read:http://www.groupstudy.com/list/posting.html
_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com
**Please read:http://www.groupstudy.com/list/posting.html
_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab