GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: sis over frame relay posted 08/23/2001
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hans,

The only way I have got this to work is to set the hubs to L1 and the spoke
to L1-2. This then enable me to see the two spoke loopbacks on the hub.

I will send the config shortly.

Regards,

Jason Sinclair
Team Leader - NSG
POWERTEL Limited
Level 11, 55 Clarence Street, SYDNEY
Phone:			61-2-8264-3820
Mobile:			0416 105 858
jasons@xxxxxxxxxxxxxxx



		-----Original Message-----
		From:	Jason Sinclair [mailto:sinclairj@xxxxxxxxxxxxxxx]
		Sent:	Thursday, 23 August 2001 09:23
		To:	hans
		Cc:	ccielab@xxxxxxxxxxxxxx
		Subject:	RE: sis over frame relay

		Hans,

		Forget my past post - DR is not elected on p2p. (I'm an
idiot!). I think
		however you are running into the issue of ISIS only knowing
about p2p and
		broadcast network types. I think you will need to set this
up as 2 p2p links
		for it to work correctly. I am looking into exactly why it
will only send
		PDU's to one neighbor, however when I have set this up using
p2p it works
		fine. Will read the RFC and advise my findings.

		Regards,

		Jason Sinclair
		Team Leader - NSG
		POWERTEL Limited
		Level 11, 55 Clarence Street, SYDNEY
		Phone:			61-2-8264-3820
		Mobile:			0416 105 858
		jasons@xxxxxxxxxxxxxxx



				-----Original Message-----
				From:	hans [mailto:yyao@xxxxxxxxxxxx]
				Sent:	Wednesday, 22 August 2001 17:02
				To:	Jason Sinclair
				Cc:	ccielab@xxxxxxxxxxxxxx
				Subject:	re: sis over frame relay

				Jason,


				Your configuration  is correct. However, if
the scenario has
		two spokes,
				problem arise.

				Here it is:


				R2/s0---302/203---s0/R1/s0---204/402---s0/R3

				Where 302 is dlci on R2, 203 is dlci on R1,
204 is dlci on
		R1 402 is dlci on
				R3.

				On the s0 of R1, there are two DLCIs
connecting to R2 and R3
		respectively.
				R1 is the frame relay hub, R2 and R2 are
spokes.
				Assume all the loopbacks of the three
routers have been
		included in ISIS.
				I also have clns map configured.

				Before I turned up R3(or before I type in
"frame relay map
		clns 402
				broadcast" on R3)

				R1and R2 can see each other's loopback.

				But the minute I turned up R3(put in frame
map clns command
		on R3), on R1, I
				lost R2's loopback. On R2, I lost R1's
loopback.
				However, R1 and R3 can see each other's
loopbacks now.

				Following is my config:

				R1:

				interface Loopback0
				 ip address 11.0.0.1 255.0.0.0
				 ip router isis
				!
				interface Serial0
				 ip address 2.2.2.1 255.255.255.248
				  ip router isis
				 encapsulation frame-relay
				 frame-relay map clns 204 broadcast
				 frame-relay map clns 203 broadcast
				 frame-relay map ip 2.2.2.2 203 broadcast
				 frame-relay map ip 2.2.2.3 204 broadcast
				 no frame-relay inverse-arp
				 frame-relay lmi-type cisco
				!
				router isis
				 net 00.0002.1111.1111.1111.00

				R2:

				interface Loopback0
				 ip address 22.0.0.1 255.255.255.0
				 ip router isis
				!
				interface Serial0
				 ip address 2.2.2.2 255.255.255.248
				 ip router isis
				 encapsulation frame-relay
				 frame-relay map clns 302 broadcast
				 frame-relay map ip 2.2.2.1 302 broadcast
				 frame-relay map ip 2.2.2.3 302 broadcast
				 no frame-relay inverse-arp
				 frame-relay lmi-type cisco
				!
				router isis
				 net 00.0002.2222.2222.2222.00
				!


				R3:

				interface Loopback0
				 ip address 33.0.0.1 255.255.0.0
				 ip router isis
				!

				interface Serial0
				 ip address 2.2.2.3 255.255.255.248
				 ip router isis
				 encapsulation frame-relay
				 frame-relay map clns 402 broadcast
				 frame-relay map ip 2.2.2.1 402 broadcast
				 frame-relay map ip 2.2.2.2 402 broadcast
				 no frame-relay inverse-arp
				!

				router isis
				 net 00.0002.3333.3333.3333.00


				show ip route on R1 before turning up R3:
				i L1    22.0.0.0 [115/20] via 2.2.2.2,
Serial0

				show ip route on R1 after turning up R3:
				i L1    33.0.0.0 [115/20] via 2.2.2.3,
Serial0

				We can see R2's loopback disappear from R1's
routing table.

				Need your help on that.

				Hans





				----- Original Message -----
				From: "Jason Sinclair"
<sinclairj@xxxxxxxxxxxxxxx>
				To: "'hans'" <yyao@xxxxxxxxxxxx>
				Sent: Tuesday, August 21, 2001 11:07 PM
				Subject: RE: isis over frame relay


				> Hans,
				>
				> I have set this up using the following:
				>
				>
				> RouterA--------------------F/R
		Switch--------------------------RouterB
				>                  DLCI 117
DLCI 118
				>
				> On routerA
				>
				> Router isis
				> Net 77.0000.7777.7777.7777.00
				>
				> Int s0
				> Ip address 172.16.1.1 255.255.255.252
				> Encaps frame-relay
				> Frame-relay lmi-type ansi
				> Frame-relay map clns 117 broad
				> Ip router isis
				>
				> On routerB
				>
				> Router isis
				> Net 88.0000.8888.8888.8888.00
				>
				> Int s0
				> Ip address 172.16.1.2 255.255.255.252
				> Encaps frame-relay
				> Frame-relay lmi-type ansi
				> Frame-relay map clns 118 broad
				> Ip router isis
				>
				>
				> I then get an adjacency formed. I can also
get an adj on
		multipoint ints,
				> however NOT on point-to-point ints.
				>
				> Try this config without the rest of the
config on your
		router and see if
				it
				> is OK.
				>
				> Regards,
				>
				> Jason Sinclair
				> Team Leader - NSG
				> POWERTEL Limited
				> Level 11, 55 Clarence Street, SYDNEY
				> Phone: 61-2-8264-3820
				> Mobile: 0416 105 858
				> jasons@xxxxxxxxxxxxxxx
				>
				>
				>
				> -----Original Message-----
				> From: hans [mailto:yyao@xxxxxxxxxxxx]
				> Sent: Tuesday, 21 August 2001 17:50
				> To: Jason Sinclair
				> Subject: Re: isis over frame relay
				>
				> << File: config.zip >> Hi Jason,
				>
				> Here is my config.
				>
				>
				> Hans
				>
				>
				>
				>
				> ----- Original Message -----
				> From: "Jason Sinclair"
<sinclairj@xxxxxxxxxxxxxxx>
				> To: "'hans'" <yyao@xxxxxxxxxxxx>
				> Sent: Tuesday, August 21, 2001 3:07 AM
				> Subject: RE: isis over frame relay
				>
				>
				> > Hans,
				> >
				> > Do you want to send me your configs on
each router and I
				> will lab it this
				> > evening. I have done this over ATM which
is also NBMA
		and
				> have had no
				> > problems.
				> >
				> > Regards,
				> >
				> > Jason Sinclair
				> > Team Leader - NSG
				> > POWERTEL Limited
				> > Level 11, 55 Clarence Street, SYDNEY
				> > Phone: 61-2-8264-3820
				> > Mobile: 0416 105 858
				> > jasons@xxxxxxxxxxxxxxx
				> >
				> >
				> >
				> > -----Original Message-----
				> > From: hans [mailto:yyao@xxxxxxxxxxxx]
				> > Sent: Tuesday, 21 August 2001 17:11
				> > To: Jason Sinclair
				> > Subject: Re: isis over frame relay
				> >
				> > Hi Jason,
				> >
				> > I tried that, still not working.
				> >
				> > Any clues?
				> >
				> > Hans
				> >
				> > ----- Original Message -----
				> > From: "Jason Sinclair"
<sinclairj@xxxxxxxxxxxxxxx>
				> > To: "'hans'" <yyao@xxxxxxxxxxxx>
				> > Sent: Tuesday, August 21, 2001 2:40 AM
				> > Subject: RE: isis over frame relay
				> >
				> >
				> > > Hans,
				> > >
				> > > You need to do the following:
				> > >
				> > > Frame relay map clns
				> > >
				> > > As you need to be able to transport
CLNS PDU's to
				> > establish the peers.
				> > >
				> > > Let me know how you go.
				> > >
				> > > Regards,
				> > >
				> > > Jason Sinclair
				> > > Team Leader - NSG
				> > > POWERTEL Limited
				> > > Level 11, 55 Clarence Street, SYDNEY
				> > > Phone: 61-2-8264-3820
				> > > Mobile: 0416 105 858
				> > > jasons@xxxxxxxxxxxxxxx
				> > >
				> > >
				> > >
				> > > -----Original Message-----
				> > > From: hans [mailto:yyao@xxxxxxxxxxxx]
				> > > Sent: Tuesday, 21 August 2001 16:27
				> > > To: ccielab@xxxxxxxxxxxxxx
				> > > Subject: isis over frame relay
				> > >
				> > > Hi all,
				> > >
				> > > Does anyone know how to configure ISIS
over frame
		relay?
				> > >
				> > >
R2/s0----------s0/R1/s0------------s0.1/R3
				> > >
				> > > R1 is the hub, it use int s0 (2 DLCI)
to connect with
		R2
				> > and
				> > > R3.
				> > >
				> > > I have router isis and net xxxxxx
configured on all
				> three
				> > > routers.
				> > > I also have all the interfaces
configured with ip
		router
				> > > isis.
				> > >
				> > > When I do show clns is-neighbors, I
can not find
				> neighbors
				> > > at all.
				> > >
				> > >
				> > > Need your help on it.
				> > >
				> > >
				> > > Thanks,
				> > >
				> > > Hans
				> > > **Please
				


	
**********************************************************************
		This email (including all attachments) is intended solely
for the named
		addressee. It is confidential and may contain commercially
sensitive
		information. If you receive it in error, please let us know
by reply email,
		delete it from your system and destroy any copies.

		This email is also subject to copyright. No part of it
should be reproduced,
		adapted or transmitted without the prior written consent of
the copyright owner.

		Emails may be interfered with, may contain computer viruses
or other defects
		and may not be successfully replicated on other systems. We
give no
		warranties in relation to these matters. If you have any
doubts about
		the authenticity of an email purportedly sent by us, please
contact us
		immediately.

	
**********************************************************************
		**Please read:http://www.groupstudy.com/list/posting.html
**********************************************************************
This email (including all attachments) is intended solely for the named
addressee. It is confidential and may contain commercially sensitive
information. If you receive it in error, please let us know by reply email,
delete it from your system and destroy any copies.

This email is also subject to copyright. No part of it should be reproduced,
adapted or transmitted without the prior written consent of the copyright owner.

Emails may be interfered with, may contain computer viruses or other defects
and may not be successfully replicated on other systems. We give no
warranties in relation to these matters. If you have any doubts about
the authenticity of an email purportedly sent by us, please contact us
immediately.

**********************************************************************
**Please read:http://www.groupstudy.com/list/posting.html
_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab