GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: Redistribution Question posted 05/17/2001
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Scott,
I would be very interested in how you summarize a shorter VLSM to a longer
FLSM.

Johnny Dedon
Senior Staff Consultant
Exodus Professional Services
johnny.dedon@xxxxxxxxxx
www.exodus.net
----- Original Message -----
From: "Scott Young" <syoung@xxxxxxx>
To: "Wei Man" <mandraw1@xxxxxxxxx>; <ccielab@xxxxxxxxxxxxxx>
Sent: Thursday, May 17, 2001 12:08 PM
Subject: RE: Redistribution Question


> Jim,
>
> Good tip on the hosts routes, but I think you may have your VLSMs and
FLSMs
> mixed up in the paragraph below.
>
> You certainly can summarize shorter VLSM to longer FLSM...
>
> SY
>
>
> -----Original Message-----
> From: Jim Graves [mailto:jtg@xxxxxxxxxx]
> Sent: Thursday, May 17, 2001 10:38 AM
> To: Wei Man; ccielab@xxxxxxxxxxxxxx
> Subject: Re: Redistribution Question
>
>
> You're able to reach R3 and R5 because R6 has host routes for them.  That
> happens when using ip ospf network point-to-multipoint; the hub puts in
> host routes for the other spokes so the spokes can reach each other.
These
> host routes are injected into RIP.  R9 accepts them because a mask isn't
> needed when the address is obviously a host address (as .3 and .5 are).
>
> R9 isn't seeing 170.150.43.0/28 because of a classic VLSM/FLSM
> redistribution problem.  RIP is a classful protocol.  So it only
> understands full classful networks, host routes, and subnets of a network
> with the same mask as its interface (in other words, if a RIP router has
> 170.150.69.4/30, it will assume that any other subnet of the class B
> 170.150.0.0 is also a /30).
>
> If the VLSM (OSPF) network mask is longer than the FLSM (RIP) mask, the
> usual solution is to summarize the VLSM route to the FLSM's mask
> length.  But you have the opposite situation.  The FLSM mask is longer
than
> the VLSM mask.  When that happens, you can't use summarization.  When the
> FLSM mask is longer than the VLSM mask, your only options are (a) static
> routes, or (b) injecting a default route.
>
> Jim
>
> At 11:22 PM 5/16/2001 -0700, Wei Man wrote:
> >Hi,
> >I am running problem using redistribute connected
> >under router rip
> >
> >Whatever I did, the connected route never come up
> >under rip
> >
> >here is diagram
> >
> >                   R3
> >                   |
> >                   |
> >R4<----------Frame Relay Cloud <----------->R6
> >                   |                          |
> >                   |                          |
> >                   R5                        R9
> >
> >where R4 is Hub and using mask 28 and R6,R3 and R9 is
> >spoke using mask 28 and using OSPF as routing protocol
> >
> >R4 serial 0 connect to Frame-Relay Switch and
> >R6 serial 0 connect to Frame-Relay Switch
> >R3 serial 0 connect to Frame-Relay Switch
> >R5 serial 0 connect to Frame-Relay Switch
> >
> >R6 and R9 running RIP and link between R6 and R9
> >using mask 30
> >
> >I am be able to ping serial 0 of R5 and serial 0 of
> >R3 from R9 and the route to reach it appear on R9
> >
> >I am NOT be able to ping R6 Serial 0 and
> >R4 serial 0 from R9, even though I already put
> >redistribute connected under router rip (No Route to
> >Serial 0 of R6 and Serial 0 of R4)
> >
> >here is the complete config form R4, R6 and R9
> >
> >R9 Config
> >R9#sh run
> >Building configuration...
> >
> >Current configuration:
> >!
> >version 12.0
> >no service pad
> >service timestamps debug uptime
> >service timestamps log uptime
> >no service password-encryption
> >!
> >hostname R9
> >!
> >!
> >ip subnet-zero
> >no ip domain-lookup
> >!
> >!
> >controller T1 0
> >!
> >!
> >interface Loopback120
> >  ip address 199.1.0.9 255.255.255.0
> >  no ip directed-broadcast
> >!
> >interface Loopback121
> >  ip address 199.1.1.9 255.255.255.0
> >  no ip directed-broadcast
> >!
> >interface Loopback122
> >  ip address 199.1.2.9 255.255.255.0
> >  no ip directed-broadcast
> >!
> >interface Loopback123
> >  ip address 199.1.3.9 255.255.255.0
> >  no ip directed-broadcast
> >!
> >interface Loopback124
> >  ip address 199.1.4.9 255.255.255.0
> >  no ip directed-broadcast
> >!
> >interface Loopback125
> >  ip address 199.1.5.9 255.255.255.0
> >  no ip directed-broadcast
> >!
> >interface Loopback126
> >  ip address 199.1.6.9 255.255.255.0
> >  no ip directed-broadcast
> >!
> >interface Loopback127
> >  ip address 199.1.7.9 255.255.255.0
> >  no ip directed-broadcast
> >!
> >interface Loopback128
> >  ip address 199.1.8.9 255.255.255.0
> >  no ip directed-broadcast
> >!
> >interface Loopback129
> >  ip address 199.1.9.9 255.255.255.0
> >  no ip directed-broadcast
> >!
> >interface Ethernet0
> >  no ip address
> >  no ip directed-broadcast
> >  shutdown
> >!
> >interface Serial0
> >  ip address 170.150.69.5 255.255.255.252
> >  no ip directed-broadcast
> >!
> >interface Serial1
> >  no ip address
> >  no ip directed-broadcast
> >  shutdown
> >!
> >interface FR-ATM20
> >  no ip address
> >  no ip directed-broadcast
> >  shutdown
> >!
> >router rip
> >  timers basic 180 360 360 420
> >  network 170.150.0.0
> >  network 199.1.0.0
> >  network 199.1.1.0
> >  network 199.1.2.0
> >  network 199.1.3.0
> >  network 199.1.4.0
> >  network 199.1.5.0
> >  network 199.1.6.0
> >  network 199.1.7.0
> >  network 199.1.8.0
> >  network 199.1.9.0
> >!
> >ip classless
> >!
> >alias exec c conf t
> >alias exec ir show ip route
> >alias exec x show ipx route
> >alias exec o show ip ospf
> >alias exec e show ip eigrp
> >alias exec b show ip bgp
> >alias exec ib show ip int brief
> >alias exec xb show ipx int brief
> >alias exec xs show ipx servers
> >alias exec d clear ip route *
> >alias exec q clear ip bgp *
> >alias exec crs copy run start
> >!
> >line con 0
> >  transport input none
> >line aux 0
> >line vty 0 4
> >  privilege level 15
> >  login
> >!
> >!
> >voice-port 1/1
> >  timeouts call-disconnect 0
> >!
> >voice-port 1/2
> >  timeouts call-disconnect 0
> >!
> >voice-port 1/3
> >  timeouts call-disconnect 0
> >!
> >voice-port 1/4
> >  timeouts call-disconnect 0
> >!
> >voice-port 1/6
> >  timeouts call-disconnect 0
> >  timing dialout-delay 1000
> >!
> >end
> >
> >R9#sh ip ro
> >Codes: C - connected, S - static, I - IGRP, R - RIP, M
> >- mobile, B - BGP
> >        D - EIGRP, EX - EIGRP external, O - OSPF, IA -
> >OSPF inter area
> >        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA
> >external type 2
> >        E1 - OSPF external type 1, E2 - OSPF external
> >type 2, E - EGP
> >        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
> >level-2, * - candidate default
> >        U - per-user static route, o - ODR
> >
> >Gateway of last resort is not set
> >
> >      170.150.0.0/16 is variably subnetted, 8 subnets,
> >2 masks
> >R       170.150.58.4/30 [120/7] via 170.150.69.6,
> >00:01:04, Serial0
> >R       170.150.43.5/32 [120/7] via 170.150.69.6,
> >00:01:04, Serial0
> >R       170.150.43.3/32 [120/7] via 170.150.69.6,
> >00:01:04, Serial0
> >R       170.150.45.4/30 [120/7] via 170.150.69.6,
> >00:01:04, Serial0
> >R       170.150.7.7/32 [120/7] via 170.150.69.6,
> >00:01:04, Serial0
> >R       170.150.3.3/32 [120/7] via 170.150.69.6,
> >00:01:04, Serial0
> >R       170.150.78.7/32 [120/7] via 170.150.69.6,
> >00:01:04, Serial0
> >C       170.150.69.4/30 is directly connected, Serial0
> >C    199.1.9.0/24 is directly connected, Loopback129
> >C    199.1.8.0/24 is directly connected, Loopback128
> >C    199.1.3.0/24 is directly connected, Loopback123
> >C    199.1.2.0/24 is directly connected, Loopback122
> >R    160.60.0.0/16 [120/7] via 170.150.69.6, 00:01:05,
> >Serial0
> >C    199.1.1.0/24 is directly connected, Loopback121
> >C    199.1.0.0/24 is directly connected, Loopback120
> >C    199.1.7.0/24 is directly connected, Loopback127
> >C    199.1.6.0/24 is directly connected, Loopback126
> >C    199.1.5.0/24 is directly connected, Loopback125
> >C    199.1.4.0/24 is directly connected, Loopback124
> >R9#
> >
> >
> >R6 Config
> >
> >R6#sh run
> >Building configuration...
> >
> >Current configuration:
> >!
> >version 12.1
> >service timestamps debug uptime
> >service timestamps log uptime
> >no service password-encryption
> >!
> >hostname R6
> >!
> >!
> >!
> >!
> >!
> >!
> >ip subnet-zero
> >no ip domain-lookup
> >!
> >cns event-service server
> >!
> >!
> >!
> >!
> >!
> >interface Loopback10
> >  ip address 170.150.60.6 255.255.255.0
> >  ip ospf network point-to-point
> >!
> >interface Loopback20
> >  ip address 170.150.6.6 255.255.255.192
> >  ip ospf network point-to-point
> >!
> >interface Loopback100
> >  ip address 217.1.6.1 255.255.255.0
> >!
> >interface Serial0
> >  ip address 170.150.43.6 255.255.255.240
> >  encapsulation frame-relay
> >  ip ospf message-digest-key 1 md5 cisco
> >  ip ospf network point-to-multipoint
> >  ip ospf hello-interval 20
> >  ip ospf priority 0
> >  frame-relay map ip 170.150.43.3 604 broadcast
> >  frame-relay map ip 170.150.43.4 604 broadcast
> >  frame-relay map ip 170.150.43.5 604 broadcast
> >  frame-relay map ip 170.150.43.6 604 broadcast
> >  frame-relay lmi-type ansi
> >!
> >interface Serial1
> >  ip address 170.150.69.6 255.255.255.252
> >  clockrate 2000000
> >!
> >interface TokenRing0
> >  ip address 170.150.67.6 255.255.255.0
> >  ring-speed 4
> >!
> >router ospf 10
> >  area 0 authentication message-digest
> >  area 0 range 170.150.6.0 255.255.255.192
> >  area 0 range 170.150.43.0 255.255.255.0
> >  area 6 range 170.150.60.0 255.255.255.0
> >  redistribute connected metric-type 1 subnets
> >route-map inject_conn_rip_to_ospf
> >  redistribute rip metric 65 metric-type 1 subnets
> >route-map inject_rip_to_ospf
> >  passive-interface Serial1
> >  passive-interface TokenRing0
> >  network 170.150.6.0 0.0.0.63 area 0
> >  network 170.150.43.6 0.0.0.0 area 0
> >  network 170.150.60.0 0.0.0.255 area 6
> >!
> >router rip
> >  timers basic 180 360 360 420
> >  redistribute connected route-map
> >inject_conn_ospf_to_rip
> >  redistribute ospf 10 metric 7 route-map
> >inject_ospf_to_rip
> >  passive-interface Loopback10
> >  passive-interface Loopback20
> >  passive-interface Serial0
> >  network 170.150.0.0
> >  default-metric 1
> >  distribute-list 20 in Serial1
> >!
> >ip classless
> >no ip http server
> >!
> >!
> >ip access-list standard inject_conn_ospf_to_rip
> >ip access-list standard inject_conn_rip_to_ospf
> >  permit 170.150.69.4 0.0.0.3
> >ip access-list standard rdr_rip_ospf
> >  permit 199.1.0.0 0.0.255.255
> >access-list 20 deny   199.1.1.0 0.0.254.255
> >access-list 20 permit any
> >route-map inject_rip_to_ospf permit 10
> >  match ip address rdr_rip_ospf
> >!
> >route-map inject_ospf_to_rip deny 10
> >  match ip address rdr_rip_ospf
> >!
> >route-map inject_ospf_to_rip permit 20
> >!
> >route-map inject_conn_rip_to_ospf permit 10
> >  match ip address inject_conn_rip_to_ospf
> >!
> >route-map inject_conn_ospf_to_rip permit 10
> >  match interface Serial0
> >!
> >!
> >alias exec c conf t
> >alias exec ir show ip route
> >alias exec x show ipx route
> >alias exec o show ip ospf
> >alias exec e show ip eigrp
> >alias exec b show ip bgp
> >alias exec ib show ip int brief
> >alias exec xb show ipx int brief
> >alias exec xs show ipx servers
> >alias exec d clear ip route *
> >alias exec q clear ip bgp *
> >alias exec crs copy run start
> >!
> >line con 0
> >  transport input none
> >line aux 0
> >line vty 0 4
> >  privilege level 15
> >  login
> >!
> >end
> >
> >R6#sh ip ro
> >Codes: C - connected, S - static, I - IGRP, R - RIP, M
> >- mobile, B - BGP
> >        D - EIGRP, EX - EIGRP external, O - OSPF, IA -
> >OSPF inter area
> >        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA
> >external type 2
> >        E1 - OSPF external type 1, E2 - OSPF external
> >type 2, E - EGP
> >        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
> >level-2, ia - IS-IS inter area
> >        * - candidate default, U - per-user static
> >route, o - ODR
> >        P - periodic downloaded static route
> >
> >Gateway of last resort is not set
> >
> >      170.150.0.0/16 is variably subnetted, 21 subnets,
> >5 masks
> >C       170.150.60.0/24 is directly connected,
> >Loopback10
> >O IA    170.150.58.4/30 [110/192] via 170.150.43.4,
> >00:13:00, Serial0
> >O       170.150.43.5/32 [110/128] via 170.150.43.4,
> >00:13:00, Serial0
> >O IA    170.150.47.0/24 [110/65] via 170.150.43.4,
> >00:13:00, Serial0
> >O       170.150.43.4/32 [110/64] via 170.150.43.4,
> >00:13:00, Serial0
> >O       170.150.43.3/32 [110/128] via 170.150.43.4,
> >00:13:00, Serial0
> >O       170.150.45.4/30 [110/1849] via 170.150.43.4,
> >00:13:01, Serial0
> >C       170.150.43.0/28 is directly connected, Serial0
> >O IA    170.150.33.0/24 [110/129] via 170.150.43.4,
> >00:13:01, Serial0
> >O IA    170.150.30.0/24 [110/138] via 170.150.43.4,
> >00:13:01, Serial0
> >O IA    170.150.14.0/24 [110/89] via 170.150.43.4,
> >00:13:01, Serial0
> >O IA    170.150.8.0/24 [110/193] via 170.150.43.4,
> >00:13:01, Serial0
> >O       170.150.4.0/26 [110/65] via 170.150.43.4,
> >00:13:02, Serial0
> >O       170.150.5.0/26 [110/129] via 170.150.43.4,
> >00:13:02, Serial0
> >C       170.150.6.0/26 is directly connected,
> >Loopback20
> >O IA    170.150.7.7/32 [110/194] via 170.150.43.4,
> >00:13:02, Serial0
> >O       170.150.3.3/32 [110/129] via 170.150.43.4,
> >00:13:02, Serial0
> >O IA    170.150.78.7/32 [110/193] via 170.150.43.4,
> >00:13:02, Serial0
> >O IA    170.150.78.8/32 [110/192] via 170.150.43.4,
> >00:13:02, Serial0
> >C       170.150.69.4/30 is directly connected, Serial1
> >C       170.150.67.0/24 is directly connected,
> >TokenRing0
> >C    217.1.6.0/24 is directly connected, Loopback100
> >R    199.1.8.0/24 [120/1] via 170.150.69.5, 00:02:30,
> >Serial1
> >R    199.1.2.0/24 [120/1] via 170.150.69.5, 00:02:30,
> >Serial1
> >      160.60.0.0/22 is subnetted, 1 subnets
> >O E1    160.60.60.0 [110/214] via 170.150.43.4,
> >00:13:02, Serial0
> >R    199.1.0.0/24 [120/1] via 170.150.69.5, 00:02:30,
> >Serial1
> >R    199.1.6.0/24 [120/1] via 170.150.69.5, 00:02:30,
> >Serial1
> >R    199.1.4.0/24 [120/1] via 170.150.69.5, 00:02:31,
> >Serial1
> >R6#
> >
> >
> >R4 config
> >
> >R4#sh run
> >Building configuration...
> >
> >Current configuration:
> >!
> >version 12.1
> >service timestamps debug uptime
> >service timestamps log uptime
> >no service password-encryption
> >!
> >hostname R4
> >!
> >no logging console
> >!
> >!
> >!
> >!
> >!
> >ip subnet-zero
> >no ip domain-lookup
> >!
> >cns event-service server
> >!
> >!
> >!
> >!
> >!
> >interface Loopback10
> >  ip address 170.150.47.4 255.255.255.0
> >  ip ospf network point-to-point
> >!
> >interface Loopback20
> >  ip address 170.150.4.2 255.255.255.192
> >  ip ospf network point-to-point
> >!
> >interface Loopback100
> >  ip address 217.1.4.1 255.255.255.0
> >!
> >interface Serial0
> >  ip address 170.150.43.4 255.255.255.240
> >  encapsulation frame-relay
> >  ip ospf message-digest-key 1 md5 cisco
> >  ip ospf network point-to-multipoint
> >  ip ospf hello-interval 20
> >  ip ospf priority 100
> >  no fair-queue
> >  frame-relay map ip 170.150.43.3 403 broadcast
> >  frame-relay map ip 170.150.43.4 403 broadcast
> >  frame-relay map ip 170.150.43.5 405 broadcast
> >  frame-relay map ip 170.150.43.6 406 broadcast
> >  no frame-relay inverse-arp
> >  frame-relay lmi-type ansi
> >!
> >interface Serial1
> >  ip address 170.150.144.2 255.255.255.252
> >!
> >interface TokenRing0
> >  ip address 170.150.14.4 255.255.255.0
> >  ring-speed 4
> >!
> >interface BRI0
> >  no ip address
> >  shutdown
> >!
> >interface Dialer0
> >  ip address 170.150.45.6 255.255.255.252
> >  no cdp enable
> >!
> >router ospf 10
> >  area 0 authentication message-digest
> >  area 0 range 170.150.4.0 255.255.255.192
> >  area 0 range 170.150.43.0 255.255.255.0
> >  area 0 range 170.150.45.4 255.255.255.252
> >  area 4 range 170.150.14.0 255.255.255.0
> >  area 4 range 170.150.47.0 255.255.255.0
> >  network 170.150.4.0 0.0.0.63 area 0
> >  network 170.150.14.0 0.0.0.255 area 4
> >  network 170.150.43.0 0.0.0.15 area 0
> >  network 170.150.45.4 0.0.0.3 area 0
> >  network 170.150.47.0 0.0.0.255 area 4
> >!
> >ip classless
> >no ip http server
> >!
> >!
> >alias exec c conf t
> >alias exec ir show ip route
> >alias exec x show ipx route
> >alias exec o show ip ospf
> >alias exec e show ip eigrp
> >alias exec b show ip bgp
> >alias exec ib show ip int brief
> >alias exec xb show ipx int brief
> >alias exec xs show ipx servers
> >alias exec d clear ip route *
> >alias exec q clear ip bgp *
> >alias exec crs copy run start
> >!
> >line con 0
> >  transport input none
> >line aux 0
> >line vty 0 4
> >  privilege level 15
> >  login
> >!
> >end
> >
> >R4#sh ip ro
> >Codes: C - connected, S - static, I - IGRP, R - RIP, M
> >- mobile, B - BGP
> >        D - EIGRP, EX - EIGRP external, O - OSPF, IA -
> >OSPF inter area
> >        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA
> >external type 2
> >        E1 - OSPF external type 1, E2 - OSPF external
> >type 2, E - EGP
> >        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS
> >level-2, ia - IS-IS inter area
> >        * - candidate default, U - per-user static
> >route, o - ODR
> >        P - periodic downloaded static route
> >
> >Gateway of last resort is not set
> >
> >      170.150.0.0/16 is variably subnetted, 21 subnets,
> >5 masks
> >O IA    170.150.60.0/24 [110/65] via 170.150.43.6,
> >00:36:29, Serial0
> >O IA    170.150.58.4/30 [110/128] via 170.150.43.5,
> >00:36:29, Serial0
> >O       170.150.43.6/32 [110/64] via 170.150.43.6,
> >00:36:29, Serial0
> >O       170.150.43.5/32 [110/64] via 170.150.43.5,
> >00:36:29, Serial0
> >C       170.150.47.0/24 is directly connected,
> >Loopback10
> >O       170.150.43.3/32 [110/64] via 170.150.43.3,
> >00:36:29, Serial0
> >C       170.150.45.4/30 is directly connected, Dialer0
> >C       170.150.43.0/28 is directly connected, Serial0
> >O IA    170.150.33.0/24 [110/65] via 170.150.43.3,
> >00:36:30, Serial0
> >O IA    170.150.30.0/24 [110/74] via 170.150.43.3,
> >00:36:30, Serial0
> >C       170.150.14.0/24 is directly connected,
> >TokenRing0
> >O IA    170.150.8.0/24 [110/129] via 170.150.43.5,
> >00:36:30, Serial0
> >C       170.150.4.0/26 is directly connected,
> >Loopback20
> >O       170.150.5.0/26 [110/65] via 170.150.43.5,
> >00:36:31, Serial0
> >O       170.150.6.0/26 [110/65] via 170.150.43.6,
> >00:36:31, Serial0
> >O IA    170.150.7.7/32 [110/130] via 170.150.43.5,
> >00:36:31, Serial0
> >O       170.150.3.3/32 [110/65] via 170.150.43.3,
> >00:36:31, Serial0
> >O IA    170.150.78.7/32 [110/129] via 170.150.43.5,
> >00:36:31, Serial0
> >O IA    170.150.78.8/32 [110/128] via 170.150.43.5,
> >00:36:31, Serial0
> >O E1    170.150.69.4/30 [110/84] via 170.150.43.6,
> >00:36:31, Serial0
> >C       170.150.144.0/30 is directly connected,
> >Serial1
> >C    217.1.4.0/24 is directly connected, Loopback100
> >O E1 199.1.8.0/24 [110/129] via 170.150.43.6,
> >00:36:31, Serial0
> >O E1 199.1.2.0/24 [110/129] via 170.150.43.6,
> >00:36:31, Serial0
> >      160.60.0.0/22 is subnetted, 1 subnets
> >O E1    160.60.60.0 [110/150] via 170.150.43.5,
> >00:36:31, Serial0
> >O E1 199.1.0.0/24 [110/129] via 170.150.43.6,
> >00:13:45, Serial0
> >O E1 199.1.6.0/24 [110/129] via 170.150.43.6,
> >00:36:32, Serial0
> >O E1 199.1.4.0/24 [110/129] via 170.150.43.6,
> >00:36:32, Serial0
> >R4#
> >
> >
> >
> >Thanks in advance
> >
> >
> >
> >
> >
> >
> >__________________________________________________
> >Do You Yahoo!?
> >Yahoo! Auctions - buy the things you want at great prices
> >http://auctions.yahoo.com/
> >**Please read:http://www.groupstudy.com/list/posting.html
> **Please read:http://www.groupstudy.com/list/posting.html
> **********************************************************************
> This email and any files transmitted with it are confidential and
> intended solely for the use of the individual or entity to whom they
> are addressed. If you have received this email in error please notify
> the system manager.
>
> This footnote also confirms that this email message has been swept by
> MIMEsweeper for the presence of computer viruses.
>
> www.mimesweeper.com
> **********************************************************************
> **Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html
_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab