GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: Cannot get ISDN to work posted 05/01/2001
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Leah,
The call isn't connecting to the other router. You can't troubleshoot PPP if
the ISDN call isn't even connecting. You should wait to troubleshoot PPP
once you're sure that the routers can call each other.

Where did you see indication that layer 3 is trying to come up from the
output?

Brian Dennis
CCIE #2210 (R&S)(ISP/Dial)
CCSI #98640

> -----Original Message-----
> From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
> Leah Lynch
> Sent: Tuesday, May 01, 2001 1:40 PM
> To: 'Brian Dennis'; ccielab@xxxxxxxxxxxxxx
> Cc: rmcneace@xxxxxxxxxx; David.Halaska@xxxxxxxxxxxxx
> Subject: RE: Cannot get ISDN to work
>
>
> Because Layer 2 to the switch was already up, MULTIPLE-FRAMES-ESTABLISHED,
> and 3 was trying to come up. So, I figure, if 3 is trying to come up and
> cannot that there is another issue and ppp is easier, in my opinion, to
> troubleshoot than hdlc.
>
> Leah
>
> -----Original Message-----
> From: Brian Dennis [mailto:brian@xxxxxx]
> Sent: Tuesday, May 01, 2001 1:26 PM
> To: Leah Lynch; ccielab@xxxxxxxxxxxxxx
> Cc: rmcneace@xxxxxxxxxx; David.Halaska@xxxxxxxxxxxxx
> Subject: RE: Cannot get ISDN to work
>
>
> Leah,
> If the call isn't even connecting to the other side how is debugging PPP
> going to help?
>
> Brian Dennis
> CCIE #2210 (R&S)(ISP/Dial)
> CCSI #98640
>
> > -----Original Message-----
> > From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
> > Leah Lynch
> > Sent: Tuesday, May 01, 2001 12:57 PM
> > To: 'Brian Dennis'; 'Mask Of Zorro'; ccielab@xxxxxxxxxxxxxx
> > Cc: rmcneace@xxxxxxxxxx; David.Halaska@xxxxxxxxxxxxx
> > Subject: RE: Cannot get ISDN to work
> >
> >
> > Without using ppp encap you cannot do debug ppp nego with would probably
> > help in indicating what is causing the problem. Also, you may want to
> > consider that basic-5ess and basic-ni1 are both 5ess with
> different specs.
> >
> > Leah Lynch
> >
> > -----Original Message-----
> > From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
> > Brian Dennis
> > Sent: Tuesday, May 01, 2001 11:32 AM
> > To: Mask Of Zorro; ccielab@xxxxxxxxxxxxxx
> > Cc: rmcneace@xxxxxxxxxx; David.Halaska@xxxxxxxxxxxxx
> > Subject: RE: Cannot get ISDN to work
> >
> >
> > No that's incorrect. You don't have to specify an encapsulation.
> > You can use
> > the default for ISDN which is HDLC if you want.
> >
> > It's a lot easier for someone without a lot of dial experience
> to use HDLC
> > when testing out an ISDN issue because it eliminates PPP as a potential
> > cause of the problem. If you suspect an ISDN issue it just could just
> > complicate matters by adding PPP.
> >
> > Brian Dennis
> > CCIE #2210 (R&S)(ISP/Dial)
> > CCSI #98640
> >
> >
> >
> >
> >
> > > -----Original Message-----
> > > From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
> > > Mask Of Zorro
> > > Sent: Tuesday, May 01, 2001 10:22 AM
> > > To: brian@xxxxxx; ccielab@xxxxxxxxxxxxxx
> > > Cc: rmcneace@xxxxxxxxxx; David.Halaska@xxxxxxxxxxxxx
> > > Subject: RE: Cannot get ISDN to work
> > >
> > >
> > > Nevertheless, an encapsulation type must be specified... Use PPP.
> > >
> > > Also, you should look at q.921 as well as q.931.
> > >
> > > Use the service timestamps debug datetime msec global
> > > configuration command
> > > first, then use these commands at the same time:
> > >
> > > debug isdn event
> > > debug isdn q921
> > > debug isdn q931
> > >
> > > This will give you a good picture of what is going on.
> > >
> > > I am assuming you are using a simulator or your own switch, eh? Is the
> > > switch type really basic-5ess?
> > >
> > > Look here for some good info about bringing up ISDN for your lab:
> > > http://www.cisco.com/networkers/nw00/pres/3304/3304_c1_sec7.pdf
> > >
> > > Hope this helps!
> > > Z
> > >
> > > PS - post the results of the debugs above if your still stuck!
> > >
> > > >From: "Brian Dennis" <brian@xxxxxx>
> > > >Reply-To: "Brian Dennis" <brian@xxxxxx>
> > > >To: <ccielab@xxxxxxxxxxxxxx>
> > > >CC: "'Roger McNeace'" <rmcneace@xxxxxxxxxx>,        "Halaska, David"
> > > ><David.Halaska@xxxxxxxxxxxxx>
> > > >Subject: RE: Cannot get ISDN to work
> > > >Date: Tue, 1 May 2001 08:45:10 -0700
> > > >
> > > >This error from the output of the "debug isdn q931" command
> > > isn't referring
> > > >a PPP or HDLC error. It's referring to a D-channel error.
> > > >
> > > >Cause i = 0x80EF - Protocol error, unspecified .....
> > > >
> > > >EF "Protocol error, unspecified"  An unspecified D-channel
> > error with no
> > > >other standard cause.
> > > >
> > > >Brian Dennis
> > > >CCIE #2210 (R&S)(ISP/Dial)
> > > >CCSI #98640
> > > >
> > > >
> > > >
> > > > > -----Original Message-----
> > > > > From: nobody@xxxxxxxxxxxxxx
> > [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
> > > > > Halaska, David
> > > > > Sent: Tuesday, May 01, 2001 7:14 AM
> > > > > To: 'Roger McNeace'; ccielab@xxxxxxxxxxxxxx
> > > > > Subject: RE: Cannot get ISDN to work
> > > > >
> > > > >
> > > > > What protocol do you want use for encapsulation.  The debug says
> > > >"Protocol
> > > > > error, unspecified"
> > > > >
> > > > > Try putting in encap ppp on both routers
> > > > >
> > > > > -----Original Message-----
> > > > > From: Roger McNeace [mailto:rmcneace@xxxxxxxxxx]
> > > > > Sent: Tuesday, May 01, 2001 8:49 AM
> > > > > To: ccielab@xxxxxxxxxxxxxx
> > > > > Subject: Cannot get ISDN to work
> > > > >
> > > > >
> > > > > Can anyone tell me what I am doing wrong. I can not get the
> > following
> > > >ISDN
> > > > > lab configs to work. I also included output from show and debug
> > > >commands.
> > > > > Thanks
> > > > >
> > > > >
> ___________________________________________________________________
> > > > > r5-dal#sh run
> > > > > Building configuration...
> > > > >
> > > > > Current configuration:
> > > > > !
> > > > > version 12.0
> > > > > service timestamps debug uptime
> > > > > service timestamps log uptime
> > > > > no service password-encryption
> > > > > !
> > > > > hostname r5-dal
> > > > > !
> > > > > enable secret 5 $1$q49/$gtgIg.n10IZ/DnYXFhAEq.
> > > > > !
> > > > > ip subnet-zero
> > > > > !
> > > > > isdn switch-type basic-5ess
> > > > > !
> > > > > !
> > > > > !
> > > > > voice-port 1/0/0
> > > > > !
> > > > > voice-port 1/0/1
> > > > > !
> > > > > !
> > > > > interface FastEthernet0/0
> > > > >  no ip address
> > > > >  no ip directed-broadcast
> > > > >  shutdown
> > > > > !
> > > > > interface Serial0/0
> > > > >  no ip address
> > > > >  no ip directed-broadcast
> > > > >  no ip mroute-cache
> > > > >  shutdown
> > > > > !
> > > > > interface BRI0/0
> > > > >  ip address 192.1.1.2 255.255.255.0
> > > > >  no ip directed-broadcast
> > > > >  dialer map ip 192.1.1.1 broadcast 6661000
> > > > >  dialer-group 1
> > > > >  isdn switch-type basic-5ess
> > > > > !
> > > > > interface Serial0/1
> > > > >  no ip address
> > > > >  no ip directed-broadcast
> > > > >  shutdown
> > > > > !
> > > > > ip classless
> > > > > no ip http server
> > > > > !
> > > > > dialer-list 1 protocol ip permit
> > > > > !
> > > > > !
> > > > > line con 0
> > > > >  transport input none
> > > > > line aux 0
> > > > > line vty 0 4
> > > > > !
> > > > > no scheduler allocate
> > > > > end
> > > > > __________________________________________________________________
> > > > > __________
> > > > > _________
> > > > >
> > > > > r3-dal#sh run
> > > > > Building configuration...
> > > > >
> > > > > Current configuration:
> > > > > !
> > > > > version 12.0
> > > > > service timestamps debug uptime
> > > > > service timestamps log uptime
> > > > > no service password-encryption
> > > > > !
> > > > > hostname r3-dal
> > > > > !
> > > > > enable secret 5 $1$8Q6.$kkxMcLc7ofBsPgsZPFrHF0
> > > > > !
> > > > > ip subnet-zero
> > > > > !
> > > > > isdn switch-type basic-5ess
> > > > > !
> > > > > !
> > > > > !
> > > > > voice-port 1/0/0
> > > > > !
> > > > > voice-port 1/0/1
> > > > > !
> > > > > !
> > > > > interface FastEthernet0/0
> > > > >  no ip address
> > > > >  no ip directed-broadcast
> > > > >  shutdown
> > > > > !
> > > > > interface Serial0/0
> > > > >  no ip address
> > > > >  no ip directed-broadcast
> > > > >  no ip mroute-cache
> > > > >  shutdown
> > > > > !
> > > > > interface BRI0/0
> > > > >  ip address 192.1.1.1 255.255.255.0
> > > > >  ip directed-broadcast
> > > > >  dialer map ip 192.1.1.2 broadcast 6663000
> > > > >  dialer-group 1
> > > > >  isdn switch-type basic-5ess
> > > > > !
> > > > > interface Serial0/1
> > > > >  no ip address
> > > > >  no ip directed-broadcast
> > > > >  shutdown
> > > > > !
> > > > > ip classless
> > > > > no ip http server
> > > > > !
> > > > > dialer-list 1 protocol ip permit
> > > > > !
> > > > > !
> > > > > line con 0
> > > > >  transport input none
> > > > > line aux 0
> > > > > line vty 0 4
> > > > > !
> > > > > no scheduler allocate
> > > > > end
> > > > >
> > > > > __________________________________________________________________
> > > > > __________
> > > > >
> > > > > r3-dal#sh isdn stat
> > > > > Global ISDN Switchtype = basic-5ess
> > > > > ISDN BRI0/0 interface
> > > > >         dsl 0, interface ISDN Switchtype = basic-5ess
> > > > >     Layer 1 Status:
> > > > >         ACTIVE
> > > > >     Layer 2 Status:
> > > > >         TEI = 64, Ces = 1, SAPI = 0, State =
> > > MULTIPLE_FRAME_ESTABLISHED
> > > > >     Layer 3 Status:
> > > > >         0 Active Layer 3 Call(s)
> > > > >     Activated dsl 0 CCBs = 0
> > > > >     Total Allocated ISDN CCBs = 0
> > > > > r3-dal#
> > > > >
> > > > >
> > _____________________________________________________________________
> > > > > r3-dal#debug isdn q931
> > > > > ISDN Q931 packets debugging is on
> > > > > r3-dal#ping 192.1.1.2
> > > > >
> > > > > Type escape sequence to abort.
> > > > > Sending 5, 100-byte ICMP Echos to 192.1.1.2, timeout is 2 seconds:
> > > > >
> > > > > 12:11:73014444032: ISDN BR0/0: TX ->  SETUP pd = 8  callref = 0x09
> > > > > 12:11:75179544756:         Bearer Capability i = 0x8890
> > > > > 12:11:73014444032:         Channel ID i = 0x83
> > > > > 12:11:73014444032:         Keypad Facility i = '6663000'
> > > > > 12:11:17: ISDN BR0/0: RX <-  RELEASE_COMP pd = 8  callref = 0x89
> > > > > 12:11:17:         Cause i = 0x80EF - Protocol error,
> > unspecified .....
> > > > > Success rate is 0 percent (0/5)
> > > > > r3-dal#
> > > > > __________________________________________________________________
> > > > > __________
> > > > > _____
> > > > > r3-dal#debug dialer
> > > > > Dial on demand events debugging is on
> > > > > r3-dal#ping 192.1.1.2
> > > > >
> > > > > Type escape sequence to abort.
> > > > > Sending 5, 100-byte ICMP Echos to 192.1.1.2, timeout is 2 seconds:
> > > > > .....
> > > > > Success rate is 0 percent (0/5)
> > > > > r3-dal#
> > > > > 12:12:33: BRI0/0: wait for isdn carrier timeout, call id=0x800A
> > > > > r3-dal#ping 192.1.1.2
> > > > >
> > > > > Type escape sequence to abort.
> > > > > Sending 5, 100-byte ICMP Echos to 192.1.1.2, timeout is 2 seconds:
> > > > >
> > > > > 12:12:57: BRI0/0: Dialing cause ip (s=192.1.1.1, d=192.1.1.2)
> > > > > 12:12:57: BRI0/0: Attempting to dial 6663000.....
> > > > > Success rate is 0 percent (0/5)
> > > > > **Please read:http://www.groupstudy.com/list/posting.html
> > > > > **Please read:http://www.groupstudy.com/list/posting.html
> > > >**Please read:http://www.groupstudy.com/list/posting.html
> > > _________________________________________________________________
> > > Get your FREE download of MSN Explorer at http://explorer.msn.com
> > > **Please read:http://www.groupstudy.com/list/posting.html
> > **Please read:http://www.groupstudy.com/list/posting.html
> > **Please read:http://www.groupstudy.com/list/posting.html
> **Please read:http://www.groupstudy.com/list/posting.html
**Please read:http://www.groupstudy.com/list/posting.html
_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab