GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: OSPF/FR Question ???? posted 01/23/2001
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


The problem is network type mismatch.  R1 is expecting a DR to be selected whle R2 and R4 are not.  So you can not mix the network type (broadcast or non-broadcast) and (point-to-point or point-to-multipoint) between neighboring routers.  However, you can mix  (broadcast and non-broadcast) or (point-to-point and point-to-multipoint) between neighboring routers.  But you will have to manipulate the hello and dead interval if you do mix network type in neighboring routers.

George

>>> "Atif Awan" <atifawan@xxxxxxxxxxx> 01/23/01 04:03PM >>>

For OSPF to function properly all the neighbors should agree on a few 
parameters and the network type is one of them. I think you should put in 
the statememt ip ospf network broadcast on all of the routers and then check 
it.


>From: "Paul Adams" <paul.adams@xxxxxxxxxxxx>
>Reply-To: "Paul Adams" <paul.adams@xxxxxxxxxxxx>
>To: <ccielab@xxxxxxxxxxxxxx>
>Subject: OSPF/FR Question ????
>Date: Tue, 23 Jan 2001 10:50:41 -0500
>
>Greeting All,
>
>While playing around on a few routers last night, I encountered the
>following issue:
>
>
>               ________
>              |             |-----------------R2
>R1----------   FS      |
>              |_______ |-------------R4
>
>The objective was to use Physical -no sub int's on R1 and Point to Point
>ints on R2 & R3.
>Exchange OSPF routes between hub and spokes with one restriction- NO ip
>ospf network multipoint command- on R1 or point to point on R1
>
>Is this doable? or is it a must to use point to multipoint in this
>situation?
>
>Please review the configs when the opportunity permits.
>
>I also tried to set R1 ip ospf priority to zero so no one would
>become the DR since P to P's do not support a DR but the
>neighbors just stayed in INIT mode
>
>In the following config, the neighbors become adjacent but no
>routes are being exchanged......
>
>Thanks for any insight....
>
>
>R1 (HUB)
>interface Serial0
>  ip address 172.16.1.1 255.255.255.0
>  no ip directed-broadcast
>  encapsulation frame-relay
>  no ip mroute-cache
>  frame-relay map ip 172.16.1.4 400 broadcast
>  frame-relay map ip 172.16.1.2 200 broadcast
>  frame-relay lmi-type ansi
>
>R1#sh ip ospf ne
>
>Neighbor ID     Pri   State           Dead Time   Address         Interface
>4.5.5.5           0   FULL/DROTHER    00:01:56    172.16.1.4      Serial0
>8.8.8.8           0   FULL/DROTHER    00:01:42    172.16.1.2      Serial0
>
>R1#sh ip ospf int s0
>Serial0 is up, line protocol is up
>   Internet Address 172.16.1.1/24, Area 0
>   Process ID 1, Router ID 2.2.2.2, Network Type NON_BROADCAST, Cost: 64
>   Transmit Delay is 1 sec, State DR, Priority 1
>   Designated Router (ID) 2.2.2.2, Interface address 172.16.1.1
>   No backup designated router on this network
>   Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
>     Hello due in 00:00:14
>   Neighbor Count is 2, Adjacent neighbor count is 2
>     Adjacent with neighbor 4.5.5.5
>     Adjacent with neighbor 8.8.8.8
>   Suppress hello for 0 neighbor(s)
>
>R1#sh ip route
>Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
>        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
>        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
>default
>        U - per-user static route, o - ODR
>
>Gateway of last resort is not set
>
>      2.0.0.0/24 is subnetted, 3 subnets
>C       2.0.0.0 is directly connected, Loopback32
>C       2.1.1.0 is directly connected, Loopback1
>C       2.2.2.0 is directly connected, Loopback0
>      172.16.0.0/24 is subnetted, 1 subnets
>C       172.16.1.0 is directly connected, Serial0
>****************************************************************************
>****
>
>R2 (spoke)
>interface Serial0
>  no ip address
>  no ip directed-broadcast
>  encapsulation frame-relay
>  no ip mroute-cache
>  frame-relay lmi-type ansi
>!
>interface Serial0.1 point-to-point
>  ip address 172.16.1.2 255.255.255.0
>  no ip directed-broadcast
>  ip ospf hello-interval 30
>  ip ospf priority 0
>  frame-relay interface-dlci 200
>
>R2#sh ip ospf ne   (Note R1 int lo0 is 2.2.2.2 /24)
>
>Neighbor ID     Pri   State           Dead Time   Address         Interface
>2.2.2.2           1   FULL/  -        00:01:45    172.16.1.1      Serial0.1
>
>R2#sh ip ospf int s0.1
>Serial0.1 is up, line protocol is up
>   Internet Address 172.16.1.2/24, Area 0
>   Process ID 1, Router ID 8.8.8.8, Network Type POINT_TO_POINT, Cost: 64
>   Transmit Delay is 1 sec, State POINT_TO_POINT,
>   Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
>     Hello due in 00:00:17
>   Neighbor Count is 1, Adjacent neighbor count is 1
>     Adjacent with neighbor 2.2.2.2
>   Suppress hello for 0 neighbor(s)
>
>R2#sh ip route
>Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
>        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
>        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
>default
>        U - per-user static route, o - ODR
>
>Gateway of last resort is not set
>
>      172.16.0.0/24 is subnetted, 1 subnets
>C       172.16.1.0 is directly connected, Serial0.1
>      7.0.0.0/24 is subnetted, 3 subnets
>C       7.9.9.0 is directly connected, Loopback2
>C       7.8.8.0 is directly connected, Loopback1
>C       7.7.7.0 is directly connected, Loopback0
>      8.0.0.0/24 is subnetted, 1 subnets
>C       8.8.8.0 is directly connected, Loopback5
>
>****************************************************************************
>****************************************
>R4 (spoke)
>interface Serial0
>  no ip address
>  encapsulation frame-relay
>!
>interface Serial0.1 point-to-point
>  ip address 172.16.1.4 255.255.255.0
>  ip ospf hello-interval 30
>  ip ospf priority 0
>  frame-relay interface-dlci 400
>
>R4#sh ip ospf ne
>
>Neighbor ID     Pri   State           Dead Time   Address         Interface
>2.2.2.2           1   FULL/  -        00:01:58    172.16.1.1      Serial0.1
>
>R4#sh ip ospf int s0.1
>Serial0.1 is up, line protocol is up
>   Internet Address 172.16.1.4/24, Area 0
>   Process ID 1, Router ID 4.5.5.5, Network Type POINT_TO_POINT, Cost: 64
>   Transmit Delay is 1 sec, State POINT_TO_POINT,
>   Timer intervals configured, Hello 30, Dead 120, Wait 120, Retransmit 5
>     Hello due in 00:00:08
>   Index 4/4, flood queue length 0
>   Next 0x0(0)/0x0(0)
>   Last flood scan length is 1, maximum is 1
>   Last flood scan time is 0 msec, maximum is 0 msec
>   Neighbor Count is 1, Adjacent neighbor count is 1
>     Adjacent with neighbor 2.2.2.2
>   Suppress hello for 0 neighbor(s)
>
>R4#sh ip route
>Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
>        D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
>        N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
>        E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
>        i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
>area
>        * - candidate default, U - per-user static route, o - ODR
>        P - periodic downloaded static route
>
>Gateway of last resort is not set
>
>      4.0.0.0/24 is subnetted, 3 subnets
>C       4.5.5.0 is directly connected, Loopback2
>C       4.3.3.0 is directly connected, Loopback1
>C       4.4.4.0 is directly connected, Loopback0
>      172.16.0.0/24 is subnetted, 1 subnets
>C       172.16.1.0 is directly connected, Serial0.1
>
>~~~~~~~~~~~~~~~~~~~~~~~~~~
>Paul L. Adams
>Callisma
>Phone:   571-633-9784
>Email:  paul.adams@xxxxxxxxxxxx 
>~~~~~~~~~~~~~~~~~~~~~~~~~~
>Building your network of the future. Today.
>
>_______________________________________________________
>To unsubscribe from the CCIELAB list, send a message to
>majordomo@xxxxxxxxxxxxxx with the body containing:
>unsubscribe ccielab

_________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com.

_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab

_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab