GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: ping a multicast address question posted 01/22/2001
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Yes,


It all works fine, the mroute looks fine, I can join the group from any 
router and see it
at my RP. What I do not get is why when I ping I get so many answers. When 
I ping from the RP -
I get only four answers as expected - 2 from each of routers r1 and r2, 
since both have two interfaces joined into
the group. But when I ping from a spoke - I get varying numbers of replies.

Julie Ann

At 10:14 AM 1/22/2001 -0500, you wrote:
>I was doing almost the exact same scenario last night, and couldn't get the
>other routers to recognize the rp for the group.  However, I was able to
>ping the m-address from every router.  I did not include the rp-discovery
>command on the rp router as you did, but my rp lines were:
>
>
>ip pim rp-address 172.16.129.1 (e0 address)
>ip pim send-rp-announce ethernet0 scope 31
>
>With your scenario, if you did a sho ip pim rp, were you able to see the
>rp's information on each router?
>
>Bill Santarsiero
>Senior Network Engineer
>Greenwich Technology Partners
>
>
>  -----Original Message-----
>From:   Connary, Julie Ann [mailto:jconnary@xxxxxxxxx]
>Sent:   Monday, January 22, 2001 9:04 AM
>To:     ccielab@xxxxxxxxxxxxxx
>Subject:        ping a multicast address question
>
>Hi All,
>
>I have a simple multicast network setup:
>
>
>
>         R3 - S0
>             |
>           |
>             Frame Cloud - with R3 as hub
>          /        \
>       R2        R1
>         E0       E0
>
>I have pim sparse mode configured. R3 is my RP using Auto-rp
>
>Basically all 3 routers are connected into the frame on S0. R1 and R2 has
>E0 configured.
>S0 on all three routers and E0 on R1 and R2 are joined into the multicast
>group 224.2.2.2 using
>the command ip igmp join-group. R3 also has ip pim nbma-mode configured.
>
>So when I ping 224.2.2.2 from R1 I get:
>
>r2#ping 224.2.2.2
>
>Type escape sequence to abort.
>Sending 1, 100-byte ICMP Echos to 224.2.2.2, timeout is 2 seconds:
>
>Reply to request 0 from 170.100.2.2, 12 ms
>Reply to request 0 from 170.100.10.1, 168 ms
>Reply to request 0 from 170.100.10.1, 160 ms
>Reply to request 0 from 170.100.10.1, 148 ms
>Reply to request 0 from 170.100.10.3, 128 ms
>Reply to request 0 from 170.100.10.3, 116 ms
>Reply to request 0 from 170.100.10.1, 68 ms
>Reply to request 0 from 170.100.10.1, 60 ms
>Reply to request 0 from 170.100.10.3, 32 ms
>Reply to request 0 from 170.100.10.3, 20 ms
>
>
>Why do the routers all respond so many times?
>
>I was able to use mcaster and put a pc on both R1 and R2's ethernets and it
>worked great. But I hear
>in the lab you have to be able to ping your RP. So I was trying to
>understand how to do that correctly.
>
>R3:
>
>ip multicast-routing
>ip dvmrp route-limit 20000
>clock timezone est -5
>!
>!
>!interface Ethernet0
>   ip address 170.100.3.3 255.255.255.0
>   no ip directed-broadcast
>   ip pim sparse-mode
>   ip ospf interface-retry 0
>!
>interface Serial0
>   ip address 170.100.10.3 255.255.255.0
>   no ip directed-broadcast
>   ip pim nbma-mode
>   ip pim sparse-mode
>   encapsulation frame-relay
>   ip ospf interface-retry 0
>   ip ospf priority 10
>   ip igmp join-group 224.2.2.2
>   frame-relay map ip 170.100.10.1 301 broadcast
>   frame-relay map ip 170.100.10.2 302 broadcast
>   frame-relay lmi-type ansi
>router ospf 1
>   network 170.100.3.0 0.0.0.255 area 34
>   network 170.100.10.0 0.0.0.255 area 0
>   neighbor 170.100.10.1
>   neighbor 170.100.10.2
>!
>ip classless
>ip pim send-rp-announce Serial0 scope 16
>ip pim send-rp-discovery scope 16
>
>
>R2:
>
>ip subnet-zero
>no ip domain-lookup
>ip multicast-routing
>ip dvmrp route-limit 20000
>!
>!
>!
>interface Ethernet0
>   ip address 170.100.2.2 255.255.255.0
>   no ip directed-broadcast
>   ip pim sparse-mode
>   ip ospf interface-retry 0
>   ip igmp join-group 224.2.2.2
>!
>interface Serial0
>   ip address 170.100.10.2 255.255.255.0
>   no ip directed-broadcast
>   ip pim sparse-mode
>   encapsulation frame-relay
>   ip ospf interface-retry 0
>   ip ospf priority 0
>   ip igmp join-group 224.2.2.2
>   no ip mroute-cache
>   no fair-queue
>   clockrate 2000000
>   frame-relay map ip 170.100.10.1 203 broadcast
>   frame-relay map ip 170.100.10.3 203 broadcast
>   frame-relay lmi-type ansi
>
>
>R1:
>
>ip subnet-zero
>no ip domain-lookup
>ip multicast-routing
>ip dvmrp route-limit 20000
>clock timezone est -5
>!
>!
>!
>interface Ethernet0
>   ip address 170.100.1.1 255.255.255.0
>   no ip directed-broadcast
>   ip pim sparse-mode
>   ip ospf interface-retry 0
>   ip igmp join-group 224.2.2.2
>
>interface Serial0
>   ip address 170.100.10.1 255.255.255.0
>   no ip directed-broadcast
>   ip pim sparse-mode
>   encapsulation frame-relay
>   ip ospf interface-retry 0
>   ip ospf priority 0
>   ip igmp join-group 224.2.2.2
>   no fair-queue
>   clockrate 2000000
>   frame-relay map ip 170.100.10.2 103 broadcastframe-relay map ip
>170.100.10.3 103 broadcast
>   frame-relay lmi-type ansi
>!
>
>
>
>Thanks Julie Ann
>
>------------------------------------------------------------------------
>                                          Julie Ann Connary
>            |           |                  Network Consulting Engineer
>           |||         |||                  Federal Support Program
>         .|||||.     .|||||.                 13635 Dulles Technology Drive,
>Herndon VA 20171
>       .:|||||||||:.:|||||||||:.                Pager: 1-888-642-0551
>      c i s c o S y s t e m s     Email: jconnary@xxxxxxxxx
>
>------------------------------------------------------------------------
>
>_______________________________________________________
>To unsubscribe from the CCIELAB list, send a message to
>majordomo@xxxxxxxxxxxxxx with the body containing:
>unsubscribe ccielab

------------------------------------------------------------------------
                                         Julie Ann Connary
           |           |                  Network Consulting Engineer
          |||         |||                  Federal Support Program
        .|||||.     .|||||.                 13635 Dulles Technology Drive, 
Herndon VA 20171
      .:|||||||||:.:|||||||||:.    	       Pager: 1-888-642-0551
     c i s c o S y s t e m s     Email: jconnary@xxxxxxxxx

------------------------------------------------------------------------

_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab