GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
OSPF/IGRP redistribution and default-network posted 01/17/2001
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Hey all - 
 
I have multiple routers, 1/2 OSPF and 1/2 IGRP.  I want to redistribute OSPF
into IGRP w/o summerization.
 
Caslow say we can redistribute w/summerization or by using default-networks.
 
I'm trying to set up default-networks but am not successful.  Any ideas?
 
Thanks,
 
Steve
 
This is the redistributing router:
 
 
r5#
!
interface Loopback0
 ip address 137.20.5.1 255.255.255.0
!
interface Loopback1
 ip address 137.20.55.1 255.255.255.224
!
interface FastEthernet0/0
 ip address 137.20.168.5 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/1
 ip address 137.20.35.5 255.255.255.240
 encapsulation frame-relay
 ip ospf network point-to-multipoint
 frame-relay map ip 137.20.35.1 205 broadcast
 frame-relay map ip 137.20.35.3 205 broadcast
 frame-relay lmi-type ansi
!
router ospf 10
 log-adjacency-changes
 area 1 range 137.20.5.0 255.255.255.0
 area 1 virtual-link 137.20.1.1
 area 5 range 137.20.55.0 255.255.255.224
 redistribute igrp 100 metric 100 metric-type 1 subnets
 network 137.20.5.0 0.0.0.255 area 1
 network 137.20.35.0 0.0.0.15 area 1
 network 137.20.55.0 0.0.0.63 area 5
!
router igrp 100
 redistribute ospf 10 metric 1000 100 255 1 1500
 passive-interface Serial0/0
 passive-interface FastEthernet0/1
 passive-interface Serial0/1
 passive-interface Loopback0
 passive-interface Loopback1
 network 137.20.0.0
 !
ip classless
ip default-network 137.20.0.0
!
 

r5#sir
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
 *   137.20.0.0/16 is variably subnetted, 26 subnets, 5 masks
I       137.20.188.0/24 [100/610] via 137.20.168.8, 00:00:54,
FastEthernet0/0
C       137.20.168.0/24 is directly connected, FastEthernet0/0
I       137.20.166.0/24 [100/610] via 137.20.168.6, 00:00:34,
FastEthernet0/0
O E1    137.20.29.0/28 [110/228] via 137.20.35.1, 00:29:46, Serial0/1
O IA    137.20.30.0/24 [110/138] via 137.20.35.1, 00:29:46, Serial0/1
O E1    137.20.29.9/32 [110/228] via 137.20.35.1, 00:29:46, Serial0/1
O       137.20.22.0/28 [110/134] via 137.20.35.1, 00:29:47, Serial0/1
O       137.20.12.1/32 [110/64] via 137.20.35.1, 00:29:47, Serial0/1
O E1    137.20.12.0/24 [110/228] via 137.20.35.1, 00:29:47, Serial0/1
O       137.20.12.2/32 [110/128] via 137.20.35.1, 00:29:47, Serial0/1
O E1    137.20.9.0/28 [110/228] via 137.20.35.1, 00:29:47, Serial0/1
O IA    137.20.10.0/24 [110/74] via 137.20.35.1, 00:29:47, Serial0/1
O IA    137.20.4.1/32 [110/193] via 137.20.35.1, 00:29:47, Serial0/1
C       137.20.5.0/24 is directly connected, Loopback0
O       137.20.1.1/32 [110/65] via 137.20.35.1, 00:29:47, Serial0/1
O IA    137.20.3.0/24 [110/129] via 137.20.35.1, 00:29:47, Serial0/1
O       137.20.2.1/32 [110/129] via 137.20.35.1, 00:29:47, Serial0/1
O E1    137.20.2.0/24 [110/228] via 137.20.35.1, 00:29:47, Serial0/1
O       137.20.3.1/32 [110/129] via 137.20.35.1, 00:29:47, Serial0/1
C       137.20.55.0/27 is directly connected, Loopback1
O IA    137.20.44.0/28 [110/198] via 137.20.35.1, 00:29:48, Serial0/1
O IA    137.20.40.0/24 [110/202] via 137.20.35.1, 00:29:48, Serial0/1
O       137.20.35.3/32 [110/128] via 137.20.35.1, 00:29:48, Serial0/1
C       137.20.35.0/28 is directly connected, Serial0/1
O IA    137.20.34.0/29 [110/192] via 137.20.35.1, 00:29:48, Serial0/1
O       137.20.35.1/32 [110/64] via 137.20.35.1, 00:29:48, Serial0/1
 

IGRP router connected to router 5:
 

r8#sir
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter
area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route
 
Gateway of last resort is not set
 
     137.20.0.0/16 is variably subnetted, 11 subnets, 2 masks
C       137.20.189.0/28 is directly connected, Loopback1
C       137.20.188.0/24 is directly connected, Loopback0
C       137.20.168.0/24 is directly connected, FastEthernet0/0
I       137.20.166.0/24 [100/610] via 137.20.168.6, 00:00:17,
FastEthernet0/0
I       137.20.30.0/24 [100/10110] via 137.20.168.5, 00:00:42,
FastEthernet0/0
I       137.20.12.0/24 [100/10110] via 137.20.168.5, 00:00:42,
FastEthernet0/0
I       137.20.10.0/24 [100/10110] via 137.20.168.5, 00:00:43,
FastEthernet0/0
I       137.20.5.0/24 [100/610] via 137.20.168.5, 00:00:43, FastEthernet0/0
I       137.20.3.0/24 [100/10110] via 137.20.168.5, 00:00:43,
FastEthernet0/0
I       137.20.2.0/24 [100/10110] via 137.20.168.5, 00:00:43,
FastEthernet0/0
I       137.20.40.0/24 [100/10110] via 137.20.168.5, 00:00:43,
FastEthernet0/0
 
 
 
OSPF router connected to router 5:
 
 
 
r1#sir
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate
default
       U - per-user static route, o - ODR
 
Gateway of last resort is not set
 
     137.20.0.0/16 is variably subnetted, 26 subnets, 5 masks
O E1    137.20.188.0/24 [110/164] via 137.20.35.5, 00:32:03, Serial0.35
O E1    137.20.168.0/24 [110/164] via 137.20.35.5, 00:32:03, Serial0.35
O E1    137.20.166.0/24 [110/164] via 137.20.35.5, 00:32:03, Serial0.35
O E1    137.20.29.0/28 [110/164] via 137.20.12.2, 00:50:14, Serial0.2
O IA    137.20.30.0/24 [110/74] via 137.20.35.3, 00:50:14, Serial0.35
O E1    137.20.29.9/32 [110/164] via 137.20.12.2, 00:50:14, Serial0.2
O       137.20.22.0/28 [110/70] via 137.20.12.2, 00:50:34, Serial0.2
C       137.20.12.0/24 is directly connected, Serial0.2
O       137.20.12.2/32 [110/64] via 137.20.12.2, 00:50:34, Serial0.2
O E1    137.20.9.0/28 [110/164] via 137.20.12.2, 00:50:14, Serial0.2
C       137.20.10.0/24 is directly connected, Ethernet0
O IA    137.20.4.1/32 [110/129] via 137.20.35.3, 00:50:14, Serial0.35
O IA    137.20.5.0/24 [110/65] via 137.20.35.5, 00:50:14, Serial0.35
O       137.20.5.1/32 [110/65] via 137.20.35.5, 00:50:35, Serial0.35
C       137.20.1.0/24 is directly connected, Loopback0
O IA    137.20.3.0/24 [110/65] via 137.20.35.3, 00:50:14, Serial0.35
O       137.20.2.1/32 [110/65] via 137.20.12.2, 00:50:35, Serial0.2
O E1    137.20.2.0/24 [110/164] via 137.20.12.2, 00:50:15, Serial0.2
O       137.20.3.1/32 [110/65] via 137.20.35.3, 00:50:35, Serial0.35
O IA    137.20.55.0/27 [110/65] via 137.20.35.5, 00:50:15, Serial0.35
O IA    137.20.44.0/28 [110/134] via 137.20.35.3, 00:50:15, Serial0.35
O IA    137.20.40.0/24 [110/138] via 137.20.35.3, 00:50:15, Serial0.35
O       137.20.35.5/32 [110/64] via 137.20.35.5, 00:50:35, Serial0.35
O       137.20.35.3/32 [110/64] via 137.20.35.3,
OSPF: rcv. v:2 t:1 l:48 rid:137.20.55.1
      aid:0.0.0.1 chk:B11A aut:0 auk: from Serial0.35
OSPF: rcv. v:2 t:1 l:48 rid:137.20.55.1
      aid:0.0.0.1 chk:B11A aut:0 auk: from Serial0.3500:50:35, Serial0.35
C       137.20.35.0/28 is directly connected, Serial0.35
O IA    137.20.34.0/29 [110/128] via 137.20.35.3, 00:50:16, Serial0.35
                          



Steven Clubb 
Network Engineer
 <http://www.cattech.com/> 	 
Phone:	 
408.341.1722
Cell:	 
408.568.8854
FAX:	 
408.341.1720

sclubb@xxxxxxxxxxx <mailto:sclubb@xxxxxxxxxxx> 

 


  

 
 

_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab