GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
RE: RIP Version 2 Authentication posted 01/15/2001
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


ya, try changing the time may be to a non-zero value.

-----Original Message-----
From: John Dill [mailto:jdill@xxxxxxxxxxxx]
Sent: Monday, 15 January 2001 18:25
To: ccielab@xxxxxxxxxxxxxx
Subject: RE: RIP Version 2 Authentication


Stanford,

Your config looks good at first take, although you might roll back the
accept- and send- lifetimes until you get it working.

Any chance you have a trailing space on one of your keys?  I wouldn't trust
cut-and-paste.  Type them carefully.

John

>>> Stephen Masraum <masraum@xxxxxxxxxx> 01/14/01 11:09PM >>>
I have gotten it working before.  I can't remember the whole config, and
don't have a router handy to check.  It's not that hard once you know what
needs to be done.  Could you be missing a command under "router rip"?

Steve

-----Original Message-----
From: nobody@xxxxxxxxxxxxxx [mailto:nobody@xxxxxxxxxxxxxx]On Behalf Of
Stanford Wong - CNS
Sent: Monday, January 15, 2001 12:59 AM
To: Ccielab
Subject: RIP Version 2 Authentication


Has anybody out there got RIP authentication working?

I have been working on this for a couple of days it doesn't seem to work.

The connection is two routers connected directly to each other via a
fastethernet connection.

When I do a debug ip rip events all I get is -
00:08:04: RIP: ignored v2 packet from 10.0.0.1 (invalid authentication)

here are the two configs -

---------------------Router D-------------------------
hostname rd
!
key chain turkey
 key 1
  key-string password1
  accept-lifetime 00:00:00 Jan 14 2001 infinite
  send-lifetime 00:00:00 Jan 14 2001 infinite
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.0
!
interface FastEthernet0
 ip address 10.0.0.2 255.255.255.0
 ip rip authentication key-chain turkey
 speed auto
 no cdp enable
!
router rip
 version 2
 passive-interface Loopback0
 network 4.0.0.0
 network 10.0.0.0
!
ip classless
-------------------------Router C-------------------------

hostname rc
!
key chain turkey
 key 1
  key-string password1
  accept-lifetime 00:00:00 Jan 14 2001 infinite
  send-lifetime 00:00:00 Jan 14 2001 infinite
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0
 ip address 10.0.0.1 255.255.255.0
 ip rip authentication key-chain turkey
 speed auto
 no cdp enable
!
router rip
 version 2
 passive-interface Loopback0
 network 3.0.0.0
 network 10.0.0.0
!
ip classless
------------------------------------------------------------

Here is the version of IOS that I am using....
IOS (tm) C1700 Software (C1700-SY-M), Version 12.1(1), RELEASE SOFTWARE
(fc1)

Am I missing something or does this thing not even work?  Getting a little
frustrated because this should be a no brainer, but it doesn't work.

Thanks in advance for any insight/suggestions.

stanford

_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab

_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab

_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab

_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab