GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: NLSP - filtering connected interfaces posted 01/15/2001
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Ronnie,

Good ideas .. I had already tried "no network AAAAAA" under the router rip.
As for disabling ipx nlsp on the loopback, nlsp is not supported on a
loopback. I did try it just for the heck of and it fussed at me ("IPX NLSP
not allowed on non-LAN multipoint interfaces")

Hmmmm ..


Thanks for the response,
ST



Ronnie Royston wrote:

> I don't have this stuff set up right now, but I believe you might try:
>
> On R1:
>
> int lo0
>  no ipx nlsp enab
> !
> ipx router rip no netw (lo0)
>
> Lemme know if that helps.
>
> -----Original Message-----
> From: Sandy Turnage [mailto:sturnage@xxxxxxxxxxx]
> Sent: Sunday, January 14, 2001 5:43 PM
> To: ccielab@xxxxxxxxxxxxxx
> Subject: NLSP - filtering connected interfaces
>
> Is their a way to keep connected interfaces from being advertised by
> NLSP?
>
> I have a router R1 with NLSP enabled on a serial interface which is
> connected to R2. I have a loopback configured with ipx network AAAAAA
> configured on R1. I want to block this from being advertised to R2. I
> have tried distribute-list in, distribute-list out and ipx
> output-network-filter but it refuses to be filtered. I don't think it's
> my access-list because I am using the same one to filter on my IPX EIGRP
> link. I can also filter out IPX routes learned via EIGRP but it
> reaaalllyyy wants to let R2 know about ipx network AAAAAA.
>
>               EIGRP (Tun 0)  (s0)     NLSP
>       R4-----------------R1-----------------R2
>                GRE tunnel     |         HDLC
>                                      |
>                                Loopback 0
>                                ipx network AAAAAA
>
> R1
> ---
> version 11.3
> service timestamps debug uptime
> service timestamps log uptime
> no service password-encryption
> !
> hostname R1
> !
> !
> ip subnet-zero
> ip tcp synwait-time 5
> no ip domain-lookup
> ipx routing 0001.0001.0001
> ipx internal-network 1111
> !
> !
> !
> interface Loopback0
>  ip address 10.0.111.1 255.255.255.0
>  ipx network AAAAAA
> !
>  interface Tunnel0
>  ip address 10.0.14.1 255.255.255.0
>  ipx network 606060
>  tunnel source Loopback0
>  tunnel destination 10.0.144.1
> !
> interface Ethernet0
>  ip address 192.168.1.1 255.255.255.0
>  no ip directed-broadcast
> !
> interface Serial0
>  ip address 10.0.12.1 255.255.255.0
>  no ip directed-broadcast
>  no ip mroute-cache
>  ipx network 505050
>  ipx output-network-filter 800
>  ipx nlsp enable
>  ipx nlsp rip off
>  ipx nlsp sap off
>  no fair-queue
>  clockrate 2000000
> !
> interface Serial1
>  ip address 10.0.13.1 255.255.255.0
>  no ip directed-broadcast
>  clockrate 2000000
> !
> router eigrp 100
>  network 10.0.0.0
>  network 192.168.1.0
> !
> ip classless
> !
> access-list 800 deny AAAAAA
> access-list 800 permit FFFFFFFF
> access-list 801 deny 202020
> access-list 801 permit FFFFFFFF
> access-list 802 deny 202020
> access-list 802 deny AAAAAA
> access-list 802 permit FFFFFFFF
> !
> !
> ipx router eigrp 100
>  redistribute nlsp
>  distribute-list 800 out
>  network 606060
> !
> !
> ipx router nlsp
>  area-address 505050 FFFFFFFF
>  redistribute eigrp 100
>  distribute-list 800 out
>  distribute-list 802 in
> !
> !
> ipx router rip
>  no network 606060
>  no network 505050
> !
> !
> ipx sap 4 filterme AAAAAA.1234.4567.1234 451 1
> ipx sap 4 Server1 AAAAAA.0000.0000.5555 451 1
> !
> alias exec si show ip route
> alias exec six show ipx route
> !
> line con 0
>  exec-timeout 0 0
>  logging synchronous
>  transport input none
> line aux 0
> line vty 0 4
>  login
> !
> end
>
> TIA,
> ST
>
> _______________________________________________________
> To unsubscribe from the CCIELAB list, send a message to
> majordomo@xxxxxxxxxxxxxx with the body containing:
> unsubscribe ccielab

_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab