GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: ipx weirdness over frame-relay posted 01/08/2001
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Julie,
     Try changing default IPX values to Novell or Cisco on all routers and 
see if that works.

R1(config)#default ipx ping-default [cisco |novell]

Brgds,

Ray May



>From: "Connary, Julie Ann" <jconnary@xxxxxxxxx>
>Reply-To: "Connary, Julie Ann" <jconnary@xxxxxxxxx>
>To: ccielab@xxxxxxxxxxxxxx
>Subject: ipx weirdness over frame-relay
>Date: Mon, 08 Jan 2001 15:28:28 -0500
>
>Hi,
>
>has anyone seen the following  IPX problem where you can ping from one
>spoke to another spoke but not vice-versa?
>It looks like R5 is treating the ipx ping from each spoke differently. Why?
>I think it is the OS versions - but very wierd.
>
>
>
>                          S0                   ipx network 200 on E0
>       /---------------------------R2 ipx routing 2222.2222.2222
>     /
>R5 ipx routing 5555.5555.5555
>    \
>      \-------------------------------R3 ipx routing 3333.3333.3333
>                         S0                      ipx network 333 on Token 0
>
>
>R5 is the frame hub.
>R5 has no ipx split-horizon eigrp 1
>R5 uses subinterfaces
>R2 and R3 can see each others routes via EIGRP.
>
>Frame is ipx network 5130
>
>R2 can ping R3 on Frame network 5130
>R2 can ping R3's token interface 333
>R5 can ping R2 and R3 on Frame
>R5 can ping R2 E0 and R3 token interfaces
>
>R3 CANNOT ping R2 frame or Ethernet 0 interface.
>
>A debug ipx packet on R5 shows the following when pinging from R3 to R2:
>
>IPX: Se0.1:5130.3333.3333.3333->5130.2222.2222.2222 ln=100 tc=00, rcvd,
>tc:00->0
>1
>IPX: Se0.1:5130.3333.3333.3333->5130.2222.2222.2222 ln=100 tc=01,
>gw=Se0.1:5130.
>2222.2222.2222
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, rcvd
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, local
>IPX: Se0.1:5130.3333.3333.3333->5130.2222.2222.2222 ln=100 tc=00, rcvd,
>tc:00->0
>1
>IPX: Se0.1:5130.3333.3333.3333->5130.2222.2222.2222 ln=100 tc=01,
>gw=Se0.1:5130.
>2222.2222.2222
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, rcvd
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, local
>IPX: Se0.1:5130.3333.3333.3333->5130.2222.2222.2222 ln=100 tc=00, rcvd,
>tc:00->0
>1
>IPX: Se0.1:5130.3333.3333.3333->5130.2222.2222.2222 ln=100 tc=01,
>gw=Se0.1:5130.
>2222.2222.2222
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, rcvd
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, local
>
>IPX: Se0.1:5130.3333.3333.3333->5130.2222.2222.2222 ln=100 tc=00, rcvd,
>tc:00->0
>1
>IPX: Se0.1:5130.3333.3333.3333->5130.2222.2222.2222 ln=100 tc=01,
>gw=Se0.1:5130.
>2222.2222.2222
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, rcvd
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, local
>IPX: Se0.1:5130.3333.3333.3333->5130.2222.2222.2222 ln=100 tc=00, rcvd,
>tc:00->0
>1
>IPX: Se0.1:5130.3333.3333.3333->5130.2222.2222.2222 ln=100 tc=01,
>gw=Se0.1:5130.
>2222.2222.2222
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, rcvd
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, local
>
>
>Now look at a debug when I ping from R2 to R3 - notice how it looks like R5
>is directly answering the pings:
>
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, rcvd
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, local
>IPX: local:5130.5555.5555.5555->5130.2222.2222.2222 ln=100 tc=00,
>gw=Se0.1:5130.
>2222.2222.2222
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, rcvd
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, local
>IPX: local:5130.5555.5555.5555->5130.2222.2222.2222 ln=100 tc=00,
>gw=Se0.1:5130.
>2222.2222.2222
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, rcvd
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, local
>IPX: local:5130.5555.5555.5555->5130.2222.2222.2222 ln=100 tc=00,
>gw=Se0.1:5130.
>2222.2222.2222
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, rcvd
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, local
>IPX: local:5130.5555.5555.5555->5130.2222.2222.2222 ln=100 tc=00,
>gw=Se0.1:5130.
>2222.2222.2222
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, rcvd
>IPX: Se0.1:5130.2222.2222.2222->5130.3333.3333.3333 ln=100 tc=00, local
>IPX: local:5130.5555.5555.5555->5130.2222.2222.2222 ln=100 tc=00,
>gw=Se0.1:5130.
>2222.2222.2222
>
>
>
>R5 ipx setup: (System image file is "flash:c2500-ds-l.112-4.f1.bin", booted
>via flash)
>
>ipx routing 5555.5555.5555
>!
>interface Serial0.1 multipoint
>   ip address 137.20.100.34 255.255.255.224
>   ipx network 5130
>   no ipx split-horizon eigrp 1
>   frame-relay map ipx 5130.2222.2222.2222 501 broadcast
>   frame-relay map ip 137.20.100.33 501 broadcast
>   frame-relay map ip 137.20.100.35 503 broadcast
>   frame-relay map ipx 5130.3333.3333.3333 503 broadcast
>!
>ipx router eigrp 1
>   network 5130
>   network 695
>!
>!
>ipx router rip
>   no network 5130
>   no network 695
>
>
>
>R2 IPX setup: (System image file is "flash:/c2500-ds-l.112-4.f1.bin",
>booted via flash)
>
>ipx routing 2222.2222.2222
>interface Serial0
>   ip address 137.20.100.33 255.255.255.224
>   no ip mroute-cache
>   encapsulation frame-relay
>   ip ospf priority 0
>   keepalive 15
>   ipx network 5130
>   clock rate 2000000
>   frame-relay map ip 137.20.100.34 105 broadcast
>   frame-relay map ip 137.20.100.35 105 broadcast
>   frame-relay map ipx 5130.3333.3333.3333 105 broadcast
>   frame-relay map ipx 5130.5555.5555.5555 105 broadcast
>   frame-relay lmi-type ansi
>
>
>ipx router eigrp 1
>   network 5130
>!
>!
>ipx router rip
>   no network 5130
>
>
>
>R3 ipx setup:  (System image file is "flash:c2500-ds56-l.112-21.bin",
>booted via flash)
>
>ipx routing 3333.3333.3333
>interface Serial0
>   ip address 137.20.100.35 255.255.255.224
>   encapsulation frame-relay
>   ip ospf priority 0
>   keepalive 15
>   ipx network 5130
>   no fair-queue
>   clockrate 2000000
>   frame-relay map ipx 5130.2222.2222.2222 305 broadcast
>   frame-relay map ip 137.20.100.33 305 broadcast
>   frame-relay map ip 137.20.100.34 305 broadcast
>   frame-relay map ipx 5130.5555.5555.5555 305 broadcast
>   frame-relay lmi-type ansi
>
>ipx router eigrp 1
>   network 5130
>!
>!
>ipx router rip
>   no network 5130
>
>------------------------------------------------------------------------
>                                          Julie Ann Connary
>            |           |                  Network Consulting Engineer
>           |||         |||                  Federal Support Program
>         .|||||.     .|||||.                 13635 Dulles Technology Drive,
>Herndon VA 20171
>       .:|||||||||:.:|||||||||:.                 Pager: 1-888-642-0551
>      c i s c o S y s t e m s     Email: jconnary@xxxxxxxxx
>
>------------------------------------------------------------------------
>_______________________________________________________
>To unsubscribe from the CCIELAB list, send a message to
>majordomo@xxxxxxxxxxxxxx with the body containing:
>unsubscribe ccielab

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com

_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab