GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: OSPF Routing posted 05/05/2000
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Using an alternate injected route is a good idea as the default route...
I 'll try it. 

Earl Aboytes wrote:
> 
> Make sure you have ip classless turned on in both routers.  In your ASBR issue the command ip default-network x.x.x.x.  The big caveat here is that the network you specify must be a non-subnetted network that appears in your routing table.  Otherwise it will just appear as a static route in your config.  Typically, in these labs that we work on, everyone uses a class B address and variably subnets it.  Furthermore, it is typical to have several class C networks being injected into OSPF from some other protocol, other than IGRP.  Use one of these class C networks as your default network.  You cannot use part of the subnetted class B.  It just won't work.
> Earl
> 
> At 09:52 AM 5/5/00 -0700, Michael Needham wrote:
> >The question I have is how would you inject inject the default route
> >into IGRP if you cannot use static, summary routes or rotue to nulls but
> >are redistributing IGRP to OSPF into each other (all routers using the
> >same network addresses).... I can't figure it out..... Any ideas?
> >
> >Earl Aboytes wrote:
> > >
> > > Pay attention to the redistribute connected and the route map.  The
> > > network for the summary address is my isdn link.
> > >
> > > interface BRI0
> > >  ip address 170.100.7.1 255.255.255.252
> > >  no ip directed-broadcast
> > >  encapsulation ppp
> > >  dialer pool-member 1
> > >  isdn switch-type basic-ni
> > >  isdn spid1 0835866201
> > >  isdn spid2 0835866401
> > >  ppp callback accept
> > >  ppp authentication chap
> > >
> > > router ospf 1
> > >  summary-address 170.100.7.0 255.255.255.0
> > >  redistribute connected subnets route-map ospf_conn
> > >  redistribute igrp 1 metric 30 metric-type 1 subnets
> > >  passive-interface Dialer0
> > >  network 170.100.1.0 0.0.0.255 area 0
> > >  network 170.100.2.0 0.0.0.255 area 0
> > >  network 170.100.7.0 0.0.0.15 area 0
> > >  network 170.100.42.240 0.0.0.15 area 0
> > >  area 0 range 170.100.7.0 255.255.255.0
> > > !
> > > router igrp 1
> > >  redistribute ospf 1 metric 1544 10 255 1 1500
> > >  passive-interface BRI0
> > >  passive-interface Dialer0
> > >  passive-interface Ethernet0
> > >  network 170.100.0.0
> > >
> > > access-list 3 permit 170.100.7.0 0.0.0.15
> > > access-list 3 permit 170.100.42.240 0.0.0.15
> > >
> > > route-map ospf_conn permit 10
> > >  match ip address 3
> > > !
> > > Hope this answers your question
> > > Earl
> > >
> > > At 05:37 PM 5/4/00 -0400, John Conzone wrote:
> > >
> > > >     If I remember correctly, I had an ASBR with RIP as the other
> > > > protocol, or maybe EIGRP, I was running both along with OSPF, but I
> > > > was able to redistribute a summary from OSPF into the other IGP with
> > > > the summary-adddress command. In fact I think thats its purpose.
> > > > ----- Original Message -----
> > > >
> > > >> From: Joe Martin
> > > >> To: wyan@xxxxxxxxxx ; ccielab@xxxxxxxxxxxxxx
> > > >> Sent: Thursday, May 04, 2000 1:05 AM
> > > >> Subject: Re: OSPF Routing
> > > >>
> > > >> According to Bruce Caslow (speaking to him in person), there isn't
> > > >> any way for OSPF to summarize out of the OSPF domain.  You may
> > > >> summarize into OSPF at the ASBR(summary) or summarize out of an
> > > >> area at the ABR(area range).  The other way to get this IGRP
> > > >> network functioning would be to specify an IP DEFAULT-NETWORK on
> > > >> the router that contains both IGRP and OSPF.  Make sure to specify
> > > >> a wholly unique major network number that does not exist within
> > > >> the IGRP domain.
> > > >>
> > > >> I know i've heard many people say that summary out of OSPF works,
> > > >> and to admit it I haven't tested it.  Please feel free to comment.
> > > >>
> > > >> JOE
> > > >>
> > > >> > ----- Original Message -----
> > > >> > From: wyan@xxxxxxxxxx
> > > >> > To: ccielab@xxxxxxxxxxxxxx
> > > >> > Sent: Wednesday, May 03, 2000 8:53 PM
> > > >> > Subject: OSPF Routing
> > > >> >
> > > >> >
> > > >> >
> > > >> > You need to summarize the 30-bit and 28-bit subnets to a 24-bit
> > > >> > subnet with
> > > >> > a
> > > >> > static route. Check the case study on P.730 of Doyle's Routing
> > > >> > TCP/IP. That
> > > >> > may help.
> > > >> >
> > > >> >
> > > >> > Weidong Yan
> > > >> >
> > > >> >
> > > >> > ---------------------- Forwarded by Weidong Yan/Markham/IBM on
> > > >> > 05/03/2000
> > > >> > 11:47 PM ---------------------------
> > > >> >
> > > >> > "Ben Rife" <brife@xxxxxxxxxx> on 05/01/2000 04:31:24 PM
> > > >> >
> > > >> > Please respond to "Ben Rife" <brife@xxxxxxxxxx>
> > > >> >
> > > >> > To:   ccielab@xxxxxxxxxxxxxx
> > > >> > cc:
> > > >> > Subject:  OSPF Routing
> > > >> >
> > > >> >
> > > >> >
> > > >> >
> > > >> > Hey Gang!
> > > >> >
> > > >> > Question:
> > > >> >
> > > >> > I have a frame backbone running OSPF Area 0. Two of the spokes
> > > >> > are
> > > >> > connected via ISDN as well. (Address spaces vary from /24, /30,
> > > >> > /28, etc
> > > >> > for 140.100.0.0 address.)
> > > >> >
> > > >> > The hub router is also connected to an IGRP domain (/24 for
> > > >> > 140.100.0.0).
> > > >> >
> > > >> > The problem I am having is that I can't seem to get the ISDN link
> > > >> > 140.100.5.0/30 advertised to the IGRP domain. The ISDN link is in
> > > >> > AREA 0. I
> > > >> > believe that if the link was in another area (ie 3), I could use
> > > >> > the well
> > > >> > known, area 3 range... cmd).
> > > >> > What do I do, since it is in Area 0 and is connected to the ASBR?
> > > >> >
> > > >> > Any ideas?
> > > >> > Thanks,
> > > >> > Ben
> > > >> >
> > >
> > > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> > > Earl Aboytes
> > > Senior Technical Consultant
> > > GTE-Managed Solutions
> > > 800-483-5325 x8817
> > > earl.aboytes@xxxxxxxxxxxxxx
> > > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> > > _______________________________________________________ To unsubscribe
> > > from the CCIELAB list, send a message to majordomo@xxxxxxxxxxxxxx with
> > > the body containing: unsubscribe ccielab
> 
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Earl Aboytes
> Senior Technical Consultant
> GTE-Managed Solutions
> 800-483-5325 x8817
> earl.aboytes@xxxxxxxxxxxxxx
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~


Earl Aboytes wrote:
> 
> Make sure you have ip classless turned on in both routers.  In your ASBR issue the command ip default-network x.x.x.x.  The big caveat here is that the network you specify must be a non-subnetted network that appears in your routing table.  Otherwise it will just appear as a static route in your config.  Typically, in these labs that we work on, everyone uses a class B address and variably subnets it.  Furthermore, it is typical to have several class C networks being injected into OSPF from some other protocol, other than IGRP.  Use one of these class C networks as your default network.  You cannot use part of the subnetted class B.  It just won't work.
> Earl
> 
> At 09:52 AM 5/5/00 -0700, Michael Needham wrote:
> >The question I have is how would you inject inject the default route
> >into IGRP if you cannot use static, summary routes or rotue to nulls but
> >are redistributing IGRP to OSPF into each other (all routers using the
> >same network addresses).... I can't figure it out..... Any ideas?
> >
> >Earl Aboytes wrote:
> > >
> > > Pay attention to the redistribute connected and the route map.  The
> > > network for the summary address is my isdn link.
> > >
> > > interface BRI0
> > >  ip address 170.100.7.1 255.255.255.252
> > >  no ip directed-broadcast
> > >  encapsulation ppp
> > >  dialer pool-member 1
> > >  isdn switch-type basic-ni
> > >  isdn spid1 0835866201
> > >  isdn spid2 0835866401
> > >  ppp callback accept
> > >  ppp authentication chap
> > >
> > > router ospf 1
> > >  summary-address 170.100.7.0 255.255.255.0
> > >  redistribute connected subnets route-map ospf_conn
> > >  redistribute igrp 1 metric 30 metric-type 1 subnets
> > >  passive-interface Dialer0
> > >  network 170.100.1.0 0.0.0.255 area 0
> > >  network 170.100.2.0 0.0.0.255 area 0
> > >  network 170.100.7.0 0.0.0.15 area 0
> > >  network 170.100.42.240 0.0.0.15 area 0
> > >  area 0 range 170.100.7.0 255.255.255.0
> > > !
> > > router igrp 1
> > >  redistribute ospf 1 metric 1544 10 255 1 1500
> > >  passive-interface BRI0
> > >  passive-interface Dialer0
> > >  passive-interface Ethernet0
> > >  network 170.100.0.0
> > >
> > > access-list 3 permit 170.100.7.0 0.0.0.15
> > > access-list 3 permit 170.100.42.240 0.0.0.15
> > >
> > > route-map ospf_conn permit 10
> > >  match ip address 3
> > > !
> > > Hope this answers your question
> > > Earl
> > >
> > > At 05:37 PM 5/4/00 -0400, John Conzone wrote:
> > >
> > > >     If I remember correctly, I had an ASBR with RIP as the other
> > > > protocol, or maybe EIGRP, I was running both along with OSPF, but I
> > > > was able to redistribute a summary from OSPF into the other IGP with
> > > > the summary-adddress command. In fact I think thats its purpose.
> > > > ----- Original Message -----
> > > >
> > > >> From: Joe Martin
> > > >> To: wyan@xxxxxxxxxx ; ccielab@xxxxxxxxxxxxxx
> > > >> Sent: Thursday, May 04, 2000 1:05 AM
> > > >> Subject: Re: OSPF Routing
> > > >>
> > > >> According to Bruce Caslow (speaking to him in person), there isn't
> > > >> any way for OSPF to summarize out of the OSPF domain.  You may
> > > >> summarize into OSPF at the ASBR(summary) or summarize out of an
> > > >> area at the ABR(area range).  The other way to get this IGRP
> > > >> network functioning would be to specify an IP DEFAULT-NETWORK on
> > > >> the router that contains both IGRP and OSPF.  Make sure to specify
> > > >> a wholly unique major network number that does not exist within
> > > >> the IGRP domain.
> > > >>
> > > >> I know i've heard many people say that summary out of OSPF works,
> > > >> and to admit it I haven't tested it.  Please feel free to comment.
> > > >>
> > > >> JOE
> > > >>
> > > >> > ----- Original Message -----
> > > >> > From: wyan@xxxxxxxxxx
> > > >> > To: ccielab@xxxxxxxxxxxxxx
> > > >> > Sent: Wednesday, May 03, 2000 8:53 PM
> > > >> > Subject: OSPF Routing
> > > >> >
> > > >> >
> > > >> >
> > > >> > You need to summarize the 30-bit and 28-bit subnets to a 24-bit
> > > >> > subnet with
> > > >> > a
> > > >> > static route. Check the case study on P.730 of Doyle's Routing
> > > >> > TCP/IP. That
> > > >> > may help.
> > > >> >
> > > >> >
> > > >> > Weidong Yan
> > > >> >
> > > >> >
> > > >> > ---------------------- Forwarded by Weidong Yan/Markham/IBM on
> > > >> > 05/03/2000
> > > >> > 11:47 PM ---------------------------
> > > >> >
> > > >> > "Ben Rife" <brife@xxxxxxxxxx> on 05/01/2000 04:31:24 PM
> > > >> >
> > > >> > Please respond to "Ben Rife" <brife@xxxxxxxxxx>
> > > >> >
> > > >> > To:   ccielab@xxxxxxxxxxxxxx
> > > >> > cc:
> > > >> > Subject:  OSPF Routing
> > > >> >
> > > >> >
> > > >> >
> > > >> >
> > > >> > Hey Gang!
> > > >> >
> > > >> > Question:
> > > >> >
> > > >> > I have a frame backbone running OSPF Area 0. Two of the spokes
> > > >> > are
> > > >> > connected via ISDN as well. (Address spaces vary from /24, /30,
> > > >> > /28, etc
> > > >> > for 140.100.0.0 address.)
> > > >> >
> > > >> > The hub router is also connected to an IGRP domain (/24 for
> > > >> > 140.100.0.0).
> > > >> >
> > > >> > The problem I am having is that I can't seem to get the ISDN link
> > > >> > 140.100.5.0/30 advertised to the IGRP domain. The ISDN link is in
> > > >> > AREA 0. I
> > > >> > believe that if the link was in another area (ie 3), I could use
> > > >> > the well
> > > >> > known, area 3 range... cmd).
> > > >> > What do I do, since it is in Area 0 and is connected to the ASBR?
> > > >> >
> > > >> > Any ideas?
> > > >> > Thanks,
> > > >> > Ben
> > > >> >
> > >
> > > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> > > Earl Aboytes
> > > Senior Technical Consultant
> > > GTE-Managed Solutions
> > > 800-483-5325 x8817
> > > earl.aboytes@xxxxxxxxxxxxxx
> > > ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> > > _______________________________________________________ To unsubscribe
> > > from the CCIELAB list, send a message to majordomo@xxxxxxxxxxxxxx with
> > > the body containing: unsubscribe ccielab
> 
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
> Earl Aboytes
> Senior Technical Consultant
> GTE-Managed Solutions
> 800-483-5325 x8817
> earl.aboytes@xxxxxxxxxxxxxx
> ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
begin:vcard 
n:Needham;Michael
tel;fax:(416)-216-8099
tel;work:(416)-216-8701
x-mozilla-html:FALSE
url:www.cisco.com
org:Cisco Systems
adr:;;150 York Street, Suite 600;Toronto;Ontario;M5H 3S5;Canada
version:2.1
email;internet:mineedha@xxxxxxxxx
title:Systems Engineer
note:EMPOWERING THE INTERNET GENERATION
fn:Michael Needham
end:vcard