GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: Dialer profile with floating static route problem. posted 04/17/2000
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


The lab usually does not even allow you to use static routes (floating or
otherwise) so don't count on being able to use them.

The problem you are having is that statically configured routes do not
change when the network topology changes.  Floating static routes are best
used over top of a dynamic routing protocol.  Try removing your default
routes, and use a dynamic routing protocol instead.  If you want to keep the
routing tables small at the remote sites, you can use OSPF stub areas, or
summaries to help, or just use EIGRP and let it auto-summarize.  What ever
protocol you choose, use floating statics overtop of (that is, with a higher
admin distance) than the dynamic routing protocol you are using.

P.S. I usually use 210 as the admin distance for floating statics.  200 is
the same as EBGP routes and you could create a conflict.  Anything over 201
is a good choice and should always be safe without having to think about it.


Thank You

Derek Small
dwsmall@xxxxxxxxxx


----- Original Message -----
From: Frank K. Lu <fclu@xxxxxxxxxxxxx>
Cc: CCIE Lab <ccielab@xxxxxxxxxxxxxx>
Sent: Saturday, April 15, 2000 10:51 PM
Subject: Dialer profile with floating static route problem.


> Hello all,
>
>     I was trying to setup the ISDN floating static route to backup the
> frame relay circuit, but have ran into some problems.
>
> On all the spoke sites, I have only default route pointing to the hub
> site and another default route with higher administrative distance
> pointing to hub site・s ISDN as backup.
>
> On hub site, I have ODR enabled to learn all the networks from all the
> spoke sites via frame relay circuit and have configured ISDN dialer
> profile with floating static route to back up each spoke sites.
>
> If spoke site・s frame relay down, the ISDN will kick in no problem, but
> if hub site's frame relay down, even the hub site's ISDN kick in but
> since spoke site・s frame relay was up and the floating static route
> won・t take over, the packets will still been sent to the  frame relay
> interface.
>
> What should be the solution for this problem?
>
> May be on the lab exam it won・t be any static route need to be
> configured, just some questions that I ran into when I tried the dialer
> profile, ODRK
>
> Here are the partial config for both hub and spoke routers:
>
> ******* HUB (R1) *******
> !
> interface Serial0
>  no ip address
>  encapsulation frame-relay IETF
>  cdp enable
> !
> interface Serial0.1 multipoint
>  ip address 192.168.16.1 255.255.255.0
>  cdp enable
>  frame-relay map ip 192.168.16.2 30 broadcast
>  frame-relay map ip 192.168.16.3 30 broadcast
> !
> interface BRI0
>  no ip address
>  encapsulation ppp
>  isdn spid1 0835866101 8358661
>  isdn spid2 0835866301 8358663
>  dialer pool-member 1
>  dialer pool-member 2
>  no cdp enable
> !
> interface Dialer1
>  ip address 192.168.101.1 255.255.255.252
>  encapsulation ppp
>  dialer remote-name R2
>  dialer idle-timeout 30
>  dialer string 8358662
>  dialer string 8358664
>  dialer pool 1
>  dialer-group 1
>  no cdp enable
> !
> interface Dialer2
>  ip address 192.168.101.5 255.255.255.252
>  encapsulation ppp
>  dialer remote-name R3
>  dialer string 2668538
>  dialer string 2668539
>  dialer pool 2
>  dialer-group 1
>  no cdp enable
> !
> router odr
> !
> router ospf 100
>  network 192.168.1.99 0.0.0.0 area 0
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 192.168.1.1
> ip route 192.168.30.0 255.255.255.0 192.168.101.6 200
> ip route 192.168.31.0 255.255.255.0 192.168.101.2 200
> !
> dialer-list 1 protocol ip permit
> !
>
> ******** SPOKE (R2) ********
> !
> interface Serial0
>  ip address 192.168.16.2 255.255.255.0
>  encapsulation frame-relay IETF
>  cdp enable
>  frame-relay map ip 192.168.16.1 31 broadcast
> !
> interface BRI0
>  ip address 192.168.101.2 255.255.255.252
>  encapsulation ppp
>  isdn spid1 0835866201 8358662
>  isdn spid2 0835866401 8358664
>  dialer idle-timeout 30
>  dialer map ip 192.168.101.1 broadcast 8358661
>  dialer map ip 192.168.101.1 broadcast 8358662
>  dialer-group 1
>  no fair-queue
>  no cdp enable
>  ppp multilink
> !
> ip classless
> ip route 0.0.0.0 0.0.0.0 192.168.16.1
> ip route 0.0.0.0 0.0.0.0 192.168.101.1 10
> !
> dialer-list 1 protocol ip permit
> !
>
> Thank you for any answer or comment.
> Frank
>
> _______________________________________________________
> To unsubscribe from the CCIELAB list, send a message to
> majordomo@xxxxxxxxxxxxxx with the body containing:
> unsubscribe ccielab

_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab