GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: OSPF into IGRP posted 04/05/2000
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


Guess someone needs to let Global Knowledge know they are teaching
incorrectly...  What happens in 11.2 (11.3 too?) is that a static route to
null0 for the summary-address is added.  With this route now added, IGRP
natively announce the network, it's not redistributed from OSPF.  When you
reboot the router the route is no longer there so IGRP no longer sees the
route (at least from what I've seen)...  But still, even if the static route
stayed, you now have a static route in your table, how is the proctor going
to like that?

In 12.0 it doesn't add this null0 route so summary-address doesn't work at
all...  The route in question is 10.128.0.0/16 coming from another OSPF
router...

7206_D#wr t
[...]
router ospf 64
 summary-address 10.128.0.0 255.240.0.0
 redistribute igrp 64 subnets route-map igrp_to_ospf
 network 10.80.0.0 0.15.255.255 area 0
!
router igrp 64
 redistribute ospf 64 route-map ospf_to_igrp
 passive-interface FastEthernet0/0
 network 10.0.0.0
 default-metric 512 2000 255 1 1500
!
access-list 20 deny   10.80.0.0
access-list 20 deny   10.96.0.0
access-list 20 deny   10.112.0.0
access-list 20 permit any
access-list 30 permit 10.96.0.0
access-list 30 permit 10.112.0.0
route-map igrp_to_ospf permit 10
 match ip address 30
!
route-map ospf_to_igrp permit 10
 match ip address 20
[...]
7206_D#

7206_F#sh ip route
[...]
Gateway of last resort is not set

     10.0.0.0/12 is subnetted, 4 subnets
I       10.64.0.0 [100/21541] via 10.96.1.1, 00:00:19, FastEthernet0/0
I       10.80.0.0 [100/120] via 10.96.1.1, 00:00:19, FastEthernet0/0
C       10.96.0.0 is directly connected, FastEthernet0/0
C       10.112.0.0 is directly connected, FastEthernet1/0
7206_F#


Now, on 7206_D we just add "ip route 10.128.0.0 255.240.0.0 Null0" and
remove the summary-address command

7206_F#sh ip route
[...]
Gateway of last resort is not set

     10.0.0.0/12 is subnetted, 5 subnets
I       10.64.0.0 [100/21541] via 10.96.1.1, 00:00:24, FastEthernet0/0
I       10.80.0.0 [100/120] via 10.96.1.1, 00:00:24, FastEthernet0/0
C       10.96.0.0 is directly connected, FastEthernet0/0
C       10.112.0.0 is directly connected, FastEthernet1/0
I       10.128.0.0 [100/21541] via 10.96.1.1, 00:00:24, FastEthernet0/0
7206_F#


-Ryan


----- Original Message -----
From: "Henry Steuart" <henry@xxxxxxxxxxxxxxxxxxxx>
To: "Ryan B" <rbenigno@xxxxxxxx>; <stanley_seow@xxxxxxxxxxxxx>
Cc: <ccielab@xxxxxxxxxxxxxx>
Sent: Tuesday, April 04, 2000 1:17 PM
Subject: Re: OSPF into IGRP


> Ryan
>
> Sorry to be obstinate, but as anyone who has completed Geotrain's [now
> Global Knowledge] ANEW1 will tell you, the summary addresses DO work when
> redistributing OSPF into IGRP.  This is [one of the things] they are
> designed to do.  At least under 11.2(15).
>
> As you correctly assert, summary addresses can ALSO be used to summarize
> INTO ospf at an ASBR.
>
> I know of AT LEAST 2 CCIEs on this list that can confirm this for you.....
>
> Regards
> Henry Steuart
> CCSI #97174
>
> At 04:01 PM 4/5/00, Ryan B wrote:
> >This does *NOT* work....  summary-address is used for redistribution into
> >OSPF from other protocols..  The fact that it even kinda works (until you
> >reboot from what I've seen) is more of a bug then anything... In fact, I
> >just tried it on 12.0 and I doesn't even "kinda" work, but it did in
11.2.
> >
> >Again, unless you have multiple classful networks to work with there is
no
> >way to get this done without static routes.
> >
> >----- Original Message -----
> >From: "Henry Steuart" <henry@xxxxxxxxxxxxxxxxxxxx>
> >To: <stanley_seow@xxxxxxxxxxxxx>
> >Cc: <ccielab@xxxxxxxxxxxxxx>
> >Sent: Tuesday, April 04, 2000 11:12 AM
> >Subject: Re: OSPF into IGRP
> >
> >
> > > Stanley
> > >
> > > Use the ospf "summary address" command on your ASBR to advertise the
/24s
> > > that cover the smaller subnets.  Then redistribute OSPF into IGRP.  It
is
> >a
> > > "hack", but required if you need to use a classful protocol like IGRP
or
> > > RIP(1).
> > >
> > > E.g.
> > > (config)#router ospf 1
> > > (config-router)#ospf summary-address 170.0.1.0 255.255.255.0
> > > ! covers any smaller (/25 thru /32) subnet in the 170.0.1.0 /24
space...
> > >
> > > Enjoy!!
> > >
> > > Henry Steuart
> > > CCSI# 97174
> > > henry@xxxxxxxxxxxxxxxxxxxx
> > >
> > > At 11:49 AM 4/5/00, you wrote:
> > >
> > > >Hi all,
> > > >
> > > >Need some help here..
> > > >
> > > >I am trying to redistribute OSPF into IGRP....
> > > >
> > > >OSPF have some /24 /29 /30 routes whereas IGRP have only
> > > >/24 routes....
> > > >
> > > >all of them are in 170.100.0.0 networks.
> > > >
> > > >What are the command to redistribute all the subnets from OSPF into
> > > >IGRP..
> > > >
> > > >How do I summarize those /29 and /30 routes into /24 routes in OSPF
??
> > > >
> > > >Thanks
> > > >
> > > >
> > > >Stanley
> > > >_______________________________________________________
> > > >To unsubscribe from the CCIELAB list, send a message to
> > > >majordomo@xxxxxxxxxxxxxx with the body containing:
> > > >unsubscribe ccielab
> > >
> > > _______________________________________________________
> > > To unsubscribe from the CCIELAB list, send a message to
> > > majordomo@xxxxxxxxxxxxxx with the body containing:
> > > unsubscribe ccielab
>

_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab