GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: Help with BGP between 2 ASs: Are they talking ? posted 07/31/1999
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


The BGP session is not working in my opinion.  You have two choices:  in
the neighbor command point to the serial interface, e.g.
	router bgp 100
	neighbor 192.168.1.2 remote-as 200

	router bgp 200
	neighbor 192.168.1.1 remote-as 100

or if you want to use the loopback interfaces:

	router bgp 100
	neighbor 207.87.0.1 remote-as 200
	neighbor 207.87.0.1 ebgp-multihop 2
	neighbor 207.87.0.1 update-source loopback 0

	router bgp 200
	neighbor 24.0.0.1 remote-as 100
	neighbor 24.0.0.1 ebgp-multihop 2
	neighbor 24.0.0.1 update-source looppback 0

use the sh ip bgp summary command to verify connectivity.

Jason Aarons wrote:
> 
> I don't have much experience with BGP are these two talking ?  I can ping
> both loopbacks, etc.  I just don't know if the show commands indicate they
> are or are not talking ?
> 
> Did I set these two up right or do I have more to t-shoot ?
> 
> hostname jersey-as-100
> !
> interface Loopback0
> ip address 24.0.0.1 255.0.0.0
> !
> interface Serial1
> ip address 192.168.1.1 255.255.255.0
> clockrate 148000
> router bgp 100
> redistribute static
> neighbor 207.87.0.1 remote-as 200
> !
> no ip classless
> ip route 207.87.0.0 255.255.0.0 Serial1 250
> !
> END
> 
> jersey-as-100#show ip bgp  neighbor
> BGP neighbor is 207.87.0.1, remote AS 200, external
> link
> Index 1, Offset 0, Mask 0x2
>   BGP version 4, remote router ID 0.0.0.0
>   BGP state = Idle, table version = 0
>   Last read 00:00:07, hold time is 180, keepalive
> interval is 60 seconds
>   Minimum time between advertisement runs is 30
> seconds
>   Received 0 messages, 0 notifications, 0 in queue
>   Sent 0 messages, 0 notifications, 0 in queue
>   Connections established 0; dropped 0
>   Last reset never
>   No. of prefix received 0
>   External BGP neighbor not directly connected.
>   No active TCP connection
> jersey-as-100#show ip bgp summary
> BGP table version is 2, main routing table version 2
> 1 network entries (1/3 paths) using 208 bytes of
> memory
> 1 BGP path attribute entries using 96 bytes of memory
> 0 BGP route-map cache entries using 0 bytes of memory
> 0 BGP filter-list cache entries using 0 bytes of
> memory
> 
> Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ
> OutQ Up/Down  State/PfxRcd
> 207.87.0.1      4   200       0       0        0    0
>   0 never    Idle
> 
> ----------------------SWITCHING
> ROUTERS---------------------
> 
> hostname dallas-as-200
> !
> interface Loopback0
> ip address 207.87.0.1 255.255.0.0
> !
> interface Serial0/0
> ip address 192.168.1.2 255.255.255.0
> !
> router bgp 200
> redistribute static
> neighbor 24.0.0.1 remote-as 100
> !
> ip classless
> ip route 24.0.0.0 255.0.0.0 Serial0/0
> !
> END
> 
> dallas#show ip bgp neigh
> BGP neighbor is 24.0.0.1, remote AS 100, external link
> Index 1, Offset 0, Mask 0x2
>   BGP version 4, remote router ID 0.0.0.0
>   BGP state = Idle, table version = 0
>   Last read 00:00:19, hold time is 180, keepalive
> interval is 60 seconds
>   Minimum time between advertisement runs is 30
> seconds
>   Received 0 messages, 0 notifications, 0 in queue
>   Sent 0 messages, 0 notifications, 0 in queue
>   Connections established 0; dropped 0
>   Last reset never
>   No. of prefix received 0
>   External BGP neighbor not directly connected.
>   No active TCP connection
> 
> dallas-as-200#show ip bgp summary
> BGP table version is 9, main routing table version 9
> 1 network entries (1/3 paths) using 208 bytes of
> memory
> 1 BGP path attribute entries using 120 bytes of memory
> 0 BGP route-map cache entries using 0 bytes of memory
> 0 BGP filter-list cache entries using 0 bytes of
> memory
> 
> Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ
> OutQ Up/Down  State/PfxRcd
> 24.0.0.1        4   100       0       0        0    0
>   0 never    Idle
> 
> _______________________________________________________________
> Get Free Email and Do More On The Web. Visit http://www.msn.com
> 
> _______________________________________________________
> To unsubscribe from the CCIELAB list, send a message to
> majordomo@xxxxxxxxxxxxxx with the body containing:
> unsubscribe ccielab
_______________________________________________________
To unsubscribe from the CCIELAB list, send a message to
majordomo@xxxxxxxxxxxxxx with the body containing:
unsubscribe ccielab