GroupStudy.com GroupStudy.com - A virtual community of network engineers
 Home  BookStore  StudyNotes  Links  Archives  StudyRooms  HelpWanted  Discounts  Login
Re: DDR/CHAT Script Problem [1:1999] posted 02/13/2001
[Chronological Index] [Thread Index] [Top] [Date Prev][Date Next] [Thread Prev][Thread Next]


chat-script 3741260 ABORT ERROR "" "AT Z" OK "ATDT \T" TIMEOUT 60
"CONNECT" \c

It's been a while since I've troubleshot modems.. wouldn't the "ATDT \T" 
above actually be "ATDT /T"? I may be wrong of course.. (wouldn't be the 
first time).


>From: "Andrew C. Ohnstad" 
>Reply-To: "Andrew C. Ohnstad" 
>To: associate@xxxxxxxxxxxxxx
>Subject: DDR/CHAT Script Problem [1:1999]
>Date: Tue, 13 Feb 2001 03:06:51 -0500
>
>Greetings,
>
>I have a 2511 that I am trying to make dial thru a modem hooked up to one
>of the Async ports to an ISP.
>
>My problem is that even though I have a CHAT script in the config, DDR
>can't seem to find it.  Here's the debug:
>
>02:34:07: As1 DDR: rotor dialout [priority]
>02:34:07: As1 DDR: Dialing cause ip (s=192.168.1.1, d=1.1.1.1)
>02:34:07: As1 DDR: Attempting to dial 3741260
>02:34:07: CHAT1: Attempting async line dialer script
>02:34:07: CHAT1: no matching chat script found for 3741260
>02:34:07: CHAT1: Dialing using Modem script: d0efault-d0ials0cript &
>System script: none
>
>Yet in my config:
>
>chat-script 3741260 ABORT ERROR "" "AT Z" OK "ATDT \T" TIMEOUT 60
>"CONNECT" \c
>
>
>Here's the whole config, and the resulantant debug info.
>All assistance appreciated!
>
>
>*******
>
>First#sh run
>Building configuration...
>
>Current configuration:
>!
>version 12.0
>service timestamps debug uptime
>service timestamps log uptime
>service password-encryption
>!
>hostname First
>!
>boot system flash
>enable secret 5 xxx
>!
>ip subnet-zero
>chat-script 3741260 ABORT ERROR "" "AT Z" OK "ATDT \T" TIMEOUT 60
>"CONNECT" \c
>!
>!
>!
>interface Ethernet0
>  ip address 192.168.1.1 255.255.255.0
>  no ip directed-broadcast
>  no ip mroute-cache
>!
>interface Serial0
>  no ip address
>  no ip directed-broadcast
>  no ip mroute-cache
>  shutdown
>!
>interface Serial1
>  no ip address
>  no ip directed-broadcast
>  no ip mroute-cache
>  shutdown
>  no cdp enable
>!
>interface Async1
>  no ip address
>  no ip directed-broadcast
>  encapsulation ppp
>  dialer in-band
>  dialer pool-member 1
>  async default routing
>  no fair-queue
>!
>interface Dialer1
>  description Outbound calls
>  ip address negotiated
>  no ip directed-broadcast
>  encapsulation ppp
>  dialer remote-name ISP
>  dialer idle-timeout 1200
>  dialer string 3741260
>  dialer load-threshold 5 either
>  dialer pool 1
>  dialer-group 1
>  no fair-queue
>  no cdp enable
>  ppp authentication chap callin
>  ppp chap hostname jawlee
>  ppp chap password 7 xxxx
>!
>ip classless
>ip route 0.0.0.0 0.0.0.0 Dialer1
>!
>access-list 100 permit ip any any
>dialer-list 1 protocol ip permit
>!
>line con 0
>  exec-timeout 0 0
>  transport input none
>line 1
>  modem InOut
>  transport input all
>  stopbits 1
>  flowcontrol hardware
>line 2 16
>line aux 0
>line vty 0 4
>  password 7 0101130A
>  login
>!
>end
>
>First#
>
>
>First#ping 1.1.1.1
>
>Type escape sequence to abort.
>Sending 5, 100-byte ICMP Echos to 1.1.1.1, timeout is 2 seconds:
>
>02:34:07: As1 DDR: rotor dialout [priority]
>02:34:07: As1 DDR: Dialing cause ip (s=192.168.1.1, d=1.1.1.1)
>02:34:07: As1 DDR: Attempting to dial 3741260
>02:34:07: CHAT1: Attempting async line dialer script
>02:34:07: CHAT1: no matching chat script found for 3741260
>02:34:07: CHAT1: Dialing using Modem script: d0efault-d0ials0cript &
>System scri
>pt: none
>02:34:07: CHAT1: process started
>02:34:07: CHAT1: Asserting DTR
>02:34:07: CHAT1: Chat script d0efault-d0ials0cript started...
>02:34:12: CHAT1: Chat script d0efault-d0ials0cript finished, status =
>Connection
>  timed out; remote host not responding
>02:34:12: TTY1: Line reset by "Async dialer"
>02:34:12: As1 DDR: disconnecting call
>02:34:12: TTY1: Modem: READY->HANGUP
>02:34:12: TTY1: destroy timer type 0
>02:34:12: TTY1: destroy timer type 1
>02:34:12: TTY1: destroy timer type 3
>02:34:12: TTY1: destroy timer type 4
>02:34:12: TTY1: destroy timer type 2
>02:34:12: TTY1: dropping DTR, hanging up
>02:34:12: tty1: Modem: HANGUP->IDLE..
>Success rate is 0 percent (0/5)
>First#
>02:34:17: TTY1: restoring DTR
>
>
>
>
>Message Posted at:
>http://www.groupstudy.com/form/read.php?f=1&i=1999&t=1999
>--------------------------------------------------
>You are reading GroupStudy's Associate Mailing List.  To unsubscribe follow
>the directions on http://www.groupstudy.com/list/Associates.html

_________________________________________________________________
Get your FREE download of MSN Explorer at http://explorer.msn.com




Message Posted at:
http://www.groupstudy.com/form/read.php?f=1&i=2007&t=1999
--------------------------------------------------
You are reading GroupStudy's Associate Mailing List.  To unsubscribe follow
the directions on http://www.groupstudy.com/list/Associates.html